aboutsummaryrefslogtreecommitdiff
path: root/deskutils/launchy/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-22 16:34:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2010-06-22 16:34:59 +0000
commit023f2936a05808d167a89f91776fa5e9232e44a3 (patch)
tree920f9e35bc058ebcbd54e0842aca59ca478245af /deskutils/launchy/Makefile
parent9f477c73f6519b28ee7746755b999dcc1cc4ea1c (diff)
downloadports-023f2936a05808d167a89f91776fa5e9232e44a3.tar.gz
ports-023f2936a05808d167a89f91776fa5e9232e44a3.zip
Notes
Diffstat (limited to 'deskutils/launchy/Makefile')
-rw-r--r--deskutils/launchy/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/deskutils/launchy/Makefile b/deskutils/launchy/Makefile
index 4a01b5ad5171..631e34a26101 100644
--- a/deskutils/launchy/Makefile
+++ b/deskutils/launchy/Makefile
@@ -6,29 +6,34 @@
#
PORTNAME= launchy
-PORTVERSION= 2.1.2
-PORTREVISION= 2
+PORTVERSION= 2.5
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}/Launchy%20on%20Linux/${PORTVERSION}
-MAINTAINER= danfe@FreeBSD.org
-COMMENT= Access applications, files, and bookmarks with just a few keystrokes
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An open source keystroke launcher
BUILD_DEPENDS= ${LOCALBASE}/include/boost/spirit/core.hpp:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/bin/xdg-open:${PORTSDIR}/devel/xdg-utils
USE_DOS2UNIX= readme.lyx readme.txt
-USE_GMAKE= yes
USE_QT_VER= 4
-QT_COMPONENTS= qmake_build moc_build uic_build gui network
-MAKEFILE= makefile
-ALL_TARGET= release
-MAKE_ARGS= PREFIX="${PREFIX}"
-
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build gui network
PORTDOCS= *
post-patch:
- @${REINPLACE_CMD} 's,make ,g&,' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} 's,/usr,${PREFIX},' \
+ ${WRKSRC}/platforms/unix/unix.pro \
+ ${WRKSRC}/plugins/calcy/calcy.pro \
+ ${WRKSRC}/plugins/gcalc/gcalc.pro \
+ ${WRKSRC}/plugins/runner/runner.pro \
+ ${WRKSRC}/plugins/verby/verby.pro \
+ ${WRKSRC}/plugins/weby/weby.pro \
+ ${WRKSRC}/src/src.pro
+
+do-configure:
+ @(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} -r Launchy.pro)
post-install:
.if !defined(NOPORTDOCS)