aboutsummaryrefslogtreecommitdiff
path: root/deskutils/lumina-fileinfo
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /deskutils/lumina-fileinfo
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'deskutils/lumina-fileinfo')
-rw-r--r--deskutils/lumina-fileinfo/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/deskutils/lumina-fileinfo/Makefile b/deskutils/lumina-fileinfo/Makefile
index eb07c3de5069..3b3fef629ee7 100644
--- a/deskutils/lumina-fileinfo/Makefile
+++ b/deskutils/lumina-fileinfo/Makefile
@@ -22,8 +22,8 @@ I18N_DESC= Install localization files
MAKE_JOBS_UNSAFE=yes
-USES= qmake
-USE_QT5= core gui widgets network svg \
+USES= qmake qt:5
+USE_QT= core gui widgets network svg \
buildtools_build x11extras concurrent multimedia
USE_GITHUB= yes
GH_ACCOUNT= trueos
@@ -32,7 +32,7 @@ GH_TAGNAME= b6536c1547571ae8dd0618bed752e2e0025bf2a7
WRKSRC_SUBDIR= src-qt5/desktop-utils/${PORTNAME}
.if${PORT_OPTIONS:MI18N}
-USE_QT5+= linguist_build
+USE_QT+= linguist_build
QMAKE_ARGS+=CONFIG+=WITH_I18N
.endif