aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mindforger/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-12-23 17:16:32 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-12-23 17:16:32 +0000
commit3525c4891ec9e8a4ce436ccc7be194218264e909 (patch)
tree714238ee209c3c4c290b07072f88361b5e558eac /deskutils/mindforger/Makefile
parent1c736683a111936cc5ac7f23836c63b65493a452 (diff)
downloadports-3525c4891ec9e8a4ce436ccc7be194218264e909.tar.gz
ports-3525c4891ec9e8a4ce436ccc7be194218264e909.zip
Diffstat (limited to 'deskutils/mindforger/Makefile')
-rw-r--r--deskutils/mindforger/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/deskutils/mindforger/Makefile b/deskutils/mindforger/Makefile
index fc84ee3fc04b..cd0e1d333d93 100644
--- a/deskutils/mindforger/Makefile
+++ b/deskutils/mindforger/Makefile
@@ -10,12 +10,27 @@ COMMENT= Thinking notebook and markdown editor
LICENSE= GPLv2+
USES= qmake qt:5
-USE_GITHUB= yes
-GH_ACCOUNT= dvorka
USE_QT= buildtools_build core declarative gui location network \
printsupport webchannel webengine widgets
+USE_GITHUB= yes
+GH_ACCOUNT= dvorka
+GH_PROJECT= cmark:cm
+GH_TAGNAME= f06d944:cm
+GH_SUBDIR= deps/cmark-gfm:cm
+
+QMAKE_ARGS= CONFIG+="mfnocxx mfwebengine"
+
+OPTIONS_DEFINE= CMARK
+OPTIONS_DEFAULT= CMARK
+CMARK_DESC= CommonMark support (Markdown -> HTML rendering)
+
+CMARK_BUILD_DEPENDS= cmake:devel/cmake
+CMARK_QMAKE_OFF= CONFIG+="mfnomd2html"
-QMAKE_ARGS= CONFIG+="mfwebengine mfnocxx mfnomd2html"
+pre-build-CMARK-on:
+ @cd ${WRKSRC_cm} && cmake -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON \
+ -DCMARK_TESTS:BOOL=OFF -DCMARK_SHARED:BOOL=OFF \
+ -B build && cmake --build build
post-patch:
@${REINPLACE_CMD} -e '/_WIN32/s,_APPLE,_${OPSYS},' \