aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nautilus-sendto
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 10:40:22 +0000
commit2a3357182d8cb640f374f8c60b71b6c99ec43843 (patch)
tree7a5f4c1c91d14d9fcab2b30589db732cde4a3725 /deskutils/nautilus-sendto
parent92fdeef4740a0893f904a81b5150a5e3f5604b10 (diff)
downloadports-2a3357182d8cb640f374f8c60b71b6c99ec43843.tar.gz
ports-2a3357182d8cb640f374f8c60b71b6c99ec43843.zip
Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfix
instead of gnomehack and pet portlint. Add conflicts with future gnome3 versions. Reviewed by: miwi, bapt
Notes
Notes: svn path=/head/; revision=314632
Diffstat (limited to 'deskutils/nautilus-sendto')
-rw-r--r--deskutils/nautilus-sendto/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/deskutils/nautilus-sendto/Makefile b/deskutils/nautilus-sendto/Makefile
index 88cccc7dc605..93b695c59e78 100644
--- a/deskutils/nautilus-sendto/Makefile
+++ b/deskutils/nautilus-sendto/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: nautilus-sendto
-# Date created: 2004-12-03
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/deskutils/nautilus-sendto/Makefile,v 1.30 2010/09/30 06:21:18 kwm Exp $
@@ -19,37 +16,37 @@ GLIB_SCHEMAS= org.gnome.Nautilus.Sendto.gschema.xml
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= intlhack gnomeprefix nautilus2 gnomehack \
- evolutiondataserver
-GNOME_DESKTOP_VERSION=2
+USES= pathfix
+USE_GNOME= intlhack gnomeprefix nautilus2 gnomehack evolutiondataserver
USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-plugins="${SENDTO_PLUGINS}"
-OPTIONS= PIDGIN "Build pidgin sendto plugin" off \
- UPNP "Build upnp sendto plugin" off
+OPTIONS_DEFINE= PIDGIN UPNP
+PIDGIN_DESC= Build pidgin sendto plugin
+UPNP_DESC= Build upnp sendto plugin
# check configure script for allowed_plugins="..." for new plugins
SENDTO_PLUGINS= evolution gajim nautilus-burn removable-devices
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PIDGIN)
+.if ${PORT_OPTIONS:MPIDGIN}
SENDTO_PLUGINS:=${SENDTO_PLUGINS} pidgin
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS+= pidgin:${PORTSDIR}/net-im/pidgin
PLIST_SUB+= PIDGIN=""
.else
PLIST_SUB+= PIDGIN="@comment "
.endif
-.if defined(WITH_UPNP)
+.if ${PORT_OPTIONS:MUPNP}
SENDTO_PLUGINS:=${SENDTO_PLUGINS} upnp
-LIB_DEPENDS+= gupnp-1.0:${PORTSDIR}/net/gupnp
+LIB_DEPENDS+= gupnp-1:${PORTSDIR}/net/gupnp
PLIST_SUB+= UPNP=""
.else
PLIST_SUB+= UPNP="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>