aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nautilus-sendto
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /deskutils/nautilus-sendto
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Notes
Diffstat (limited to 'deskutils/nautilus-sendto')
-rw-r--r--deskutils/nautilus-sendto/Makefile28
-rw-r--r--deskutils/nautilus-sendto/distinfo6
-rw-r--r--deskutils/nautilus-sendto/pkg-plist25
3 files changed, 43 insertions, 16 deletions
diff --git a/deskutils/nautilus-sendto/Makefile b/deskutils/nautilus-sendto/Makefile
index c48514eb9156..fb1cce45d685 100644
--- a/deskutils/nautilus-sendto/Makefile
+++ b/deskutils/nautilus-sendto/Makefile
@@ -3,34 +3,46 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/deskutils/nautilus-sendto/Makefile,v 1.22 2009/11/18 18:50:49 kwm Exp $
+# $MCom: ports/deskutils/nautilus-sendto/Makefile,v 1.25 2010/04/10 23:24:02 kwm Exp $
PORTNAME= nautilus-sendto
-PORTVERSION= 2.28.2
-PORTREVISION= 4
+PORTVERSION= 2.28.4
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Integration between nautilus, evolution, and pidgin
-BUILD_DEPENDS= empathy:${PORTSDIR}/net-im/empathy
-RUN_DEPENDS= empathy:${PORTSDIR}/net-im/empathy
-
MAN1= nautilus-sendto.1
GCONF_SCHEMAS= nst.schemas
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= intlhack gnomeprefix gnometarget nautilus2 gnomehack
+USE_GNOME= intlhack gnomeprefix gnometarget nautilus2 gnomehack \
+ evolutiondataserver
USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-plugins="${SENDTO_PLUGINS}"
+
+OPTIONS= PIDGIN "Build pidgin sendto plugin" off
+
+# check configure script for allowed_plugins="..." for new plugins
+SENDTO_PLUGINS= bluetooth evolution gajim nautilus-burn removable-devices
+
+# Not these plugins:
+# empathy (moved to empathy port) upnp
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/pidgin)
+.if defined(WITH_PIDGIN)
+SENDTO_PLUGINS:=${SENDTO_PLUGINS} pidgin
+LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS+= pidgin:${PORTSDIR}/net-im/pidgin
+PLIST_SUB+= PIDGIN=""
+.else
+PLIST_SUB+= PIDGIN="@comment "
.endif
.include <bsd.port.post.mk>
diff --git a/deskutils/nautilus-sendto/distinfo b/deskutils/nautilus-sendto/distinfo
index 022045f2ed34..6361c56f4b45 100644
--- a/deskutils/nautilus-sendto/distinfo
+++ b/deskutils/nautilus-sendto/distinfo
@@ -1,3 +1,3 @@
-MD5 (nautilus-sendto-2.28.2.tar.bz2) = b37ab6eec43d95bef42bb8ed67ae290f
-SHA256 (nautilus-sendto-2.28.2.tar.bz2) = 0fa992b9a4489b712465e82eb182db3eaea9280397871f9d95849c25d1c33893
-SIZE (nautilus-sendto-2.28.2.tar.bz2) = 423429
+MD5 (nautilus-sendto-2.28.4.tar.bz2) = e68236367190d01a31d11fb746822bed
+SHA256 (nautilus-sendto-2.28.4.tar.bz2) = ff6b1a73f7e662fb49c3a1aee59a5c17fc96c23fcf63c3b10b6142eaef344f06
+SIZE (nautilus-sendto-2.28.4.tar.bz2) = 436967
diff --git a/deskutils/nautilus-sendto/pkg-plist b/deskutils/nautilus-sendto/pkg-plist
index c4b82e754979..816f0b08933f 100644
--- a/deskutils/nautilus-sendto/pkg-plist
+++ b/deskutils/nautilus-sendto/pkg-plist
@@ -4,14 +4,12 @@ lib/nautilus-sendto/plugins/libnstbluetooth.la
lib/nautilus-sendto/plugins/libnstbluetooth.so
lib/nautilus-sendto/plugins/libnstburn.la
lib/nautilus-sendto/plugins/libnstburn.so
-lib/nautilus-sendto/plugins/libnstempathy.la
-lib/nautilus-sendto/plugins/libnstempathy.so
lib/nautilus-sendto/plugins/libnstevolution.la
lib/nautilus-sendto/plugins/libnstevolution.so
lib/nautilus-sendto/plugins/libnstgajim.la
lib/nautilus-sendto/plugins/libnstgajim.so
-lib/nautilus-sendto/plugins/libnstpidgin.la
-lib/nautilus-sendto/plugins/libnstpidgin.so
+%%PIDGIN%%lib/nautilus-sendto/plugins/libnstpidgin.la
+%%PIDGIN%%lib/nautilus-sendto/plugins/libnstpidgin.so
lib/nautilus-sendto/plugins/libnstremovable_devices.la
lib/nautilus-sendto/plugins/libnstremovable_devices.so
lib/nautilus/extensions-2.0/libnautilus-sendto.la
@@ -29,12 +27,14 @@ libdata/pkgconfig/nautilus-sendto.pc
%%DOCSDIR%%/right.png
%%DOCSDIR%%/style.css
%%DOCSDIR%%/up.png
+share/locale/af/LC_MESSAGES/nautilus-sendto.mo
share/locale/ar/LC_MESSAGES/nautilus-sendto.mo
share/locale/as/LC_MESSAGES/nautilus-sendto.mo
share/locale/ast/LC_MESSAGES/nautilus-sendto.mo
-share/locale/be@latin/LC_MESSAGES/nautilus-sendto.mo
share/locale/be/LC_MESSAGES/nautilus-sendto.mo
+share/locale/be@latin/LC_MESSAGES/nautilus-sendto.mo
share/locale/bg/LC_MESSAGES/nautilus-sendto.mo
+share/locale/bn/LC_MESSAGES/nautilus-sendto.mo
share/locale/bn_IN/LC_MESSAGES/nautilus-sendto.mo
share/locale/br/LC_MESSAGES/nautilus-sendto.mo
share/locale/ca/LC_MESSAGES/nautilus-sendto.mo
@@ -43,6 +43,7 @@ share/locale/da/LC_MESSAGES/nautilus-sendto.mo
share/locale/de/LC_MESSAGES/nautilus-sendto.mo
share/locale/dz/LC_MESSAGES/nautilus-sendto.mo
share/locale/el/LC_MESSAGES/nautilus-sendto.mo
+share/locale/en@shaw/LC_MESSAGES/nautilus-sendto.mo
share/locale/en_CA/LC_MESSAGES/nautilus-sendto.mo
share/locale/en_GB/LC_MESSAGES/nautilus-sendto.mo
share/locale/es/LC_MESSAGES/nautilus-sendto.mo
@@ -61,9 +62,12 @@ share/locale/ka/LC_MESSAGES/nautilus-sendto.mo
share/locale/kn/LC_MESSAGES/nautilus-sendto.mo
share/locale/ko/LC_MESSAGES/nautilus-sendto.mo
share/locale/lt/LC_MESSAGES/nautilus-sendto.mo
+share/locale/lv/LC_MESSAGES/nautilus-sendto.mo
share/locale/mk/LC_MESSAGES/nautilus-sendto.mo
+share/locale/ml/LC_MESSAGES/nautilus-sendto.mo
share/locale/mr/LC_MESSAGES/nautilus-sendto.mo
share/locale/nb/LC_MESSAGES/nautilus-sendto.mo
+share/locale/nds/LC_MESSAGES/nautilus-sendto.mo
share/locale/ne/LC_MESSAGES/nautilus-sendto.mo
share/locale/nl/LC_MESSAGES/nautilus-sendto.mo
share/locale/oc/LC_MESSAGES/nautilus-sendto.mo
@@ -78,6 +82,8 @@ share/locale/rw/LC_MESSAGES/nautilus-sendto.mo
share/locale/sk/LC_MESSAGES/nautilus-sendto.mo
share/locale/sl/LC_MESSAGES/nautilus-sendto.mo
share/locale/sq/LC_MESSAGES/nautilus-sendto.mo
+share/locale/sr/LC_MESSAGES/nautilus-sendto.mo
+share/locale/sr@latin/LC_MESSAGES/nautilus-sendto.mo
share/locale/sv/LC_MESSAGES/nautilus-sendto.mo
share/locale/ta/LC_MESSAGES/nautilus-sendto.mo
share/locale/te/LC_MESSAGES/nautilus-sendto.mo
@@ -85,6 +91,7 @@ share/locale/th/LC_MESSAGES/nautilus-sendto.mo
share/locale/uk/LC_MESSAGES/nautilus-sendto.mo
share/locale/vi/LC_MESSAGES/nautilus-sendto.mo
share/locale/zh_CN/LC_MESSAGES/nautilus-sendto.mo
+share/locale/zh_HK/LC_MESSAGES/nautilus-sendto.mo
share/locale/zh_TW/LC_MESSAGES/nautilus-sendto.mo
share/nautilus-sendto/ui/nautilus-sendto.ui
@dirrm %%DOCSDIR%%
@@ -93,14 +100,22 @@ share/nautilus-sendto/ui/nautilus-sendto.ui
@dirrm lib/nautilus-sendto/plugins
@dirrm lib/nautilus-sendto
@dirrm include/nautilus-sendto
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
+@dirrmtry share/locale/nds/LC_MESSAGES
+@dirrmtry share/locale/nds
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES