aboutsummaryrefslogtreecommitdiff
path: root/deskutils/owncloudclient
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-03-19 11:30:31 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-03-19 11:30:31 +0000
commit58f9e613bd7757620f8753957f700c9e9b21c745 (patch)
treede16d405f4b98f25afbe07d0d28e32bd9885bd07 /deskutils/owncloudclient
parentd0cbba0ef619ceda900d53d3763d5f401f2a910b (diff)
downloadports-58f9e613bd7757620f8753957f700c9e9b21c745.tar.gz
ports-58f9e613bd7757620f8753957f700c9e9b21c745.zip
Notes
Diffstat (limited to 'deskutils/owncloudclient')
-rw-r--r--deskutils/owncloudclient/Makefile2
-rw-r--r--deskutils/owncloudclient/distinfo6
-rw-r--r--deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake13
-rw-r--r--deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp13
-rw-r--r--deskutils/owncloudclient/pkg-plist5
5 files changed, 11 insertions, 28 deletions
diff --git a/deskutils/owncloudclient/Makefile b/deskutils/owncloudclient/Makefile
index 8aff6cad0200..b4dc86810952 100644
--- a/deskutils/owncloudclient/Makefile
+++ b/deskutils/owncloudclient/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= owncloudclient
-PORTVERSION= 2.2.4
+PORTVERSION= 2.3.0
DISTVERSIONPREFIX= v
CATEGORIES= deskutils
diff --git a/deskutils/owncloudclient/distinfo b/deskutils/owncloudclient/distinfo
index bad908a1fa03..e7d8a08ec23e 100644
--- a/deskutils/owncloudclient/distinfo
+++ b/deskutils/owncloudclient/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1480459091
-SHA256 (owncloud-client-v2.2.4_GH0.tar.gz) = 416e8a003ba95387cb5e22fac909c2c2ee21765de413a26397027d36ad89e39b
-SIZE (owncloud-client-v2.2.4_GH0.tar.gz) = 14256271
+TIMESTAMP = 1488995726
+SHA256 (owncloud-client-v2.3.0_GH0.tar.gz) = eb9cb9edeb843253f356238ac82bcaf2dd6df65d85da7593f4d8c9791a87489d
+SIZE (owncloud-client-v2.3.0_GH0.tar.gz) = 14342829
diff --git a/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake b/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake
deleted file mode 100644
index 637a6c609880..000000000000
--- a/deskutils/owncloudclient/files/patch-cmake-modules-FindIconv.cmake
+++ /dev/null
@@ -1,13 +0,0 @@
---- cmake/modules/FindIconv.cmake.orig 2015-07-09 17:51:37 UTC
-+++ cmake/modules/FindIconv.cmake
-@@ -36,9 +36,7 @@ find_library(ICONV_LIBRARY
- )
-
- if (ICONV_LIBRARY)
-- get_filename_component(_ICONV_NAME ${ICONV_LIBRARY} NAME)
-- get_filename_component(_ICONV_PATH ${ICONV_LIBRARY} PATH)
-- check_library_exists(${_ICONV_NAME} iconv ${_ICONV_PATH} HAVE_ICONV)
-+ set(HAVE_ICONV TRUE)
- else()
- check_function_exists(iconv HAVE_ICONV)
- endif()
diff --git a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
index f3fc7d46d546..4704c6b28cd4 100644
--- a/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
+++ b/deskutils/owncloudclient/files/patch-src_gui_generalsettings.cpp
@@ -1,21 +1,16 @@
--- src/gui/generalsettings.cpp.orig 2016-05-12 07:59:12 UTC
+++ src/gui/generalsettings.cpp
-@@ -109,6 +109,7 @@ void GeneralSettings::loadMiscSettings()
+@@ -124,6 +124,7 @@
void GeneralSettings::slotUpdateInfo()
{
+#if 0
- OCUpdater *updater = dynamic_cast<OCUpdater*>(Updater::instance());
+ // Note: the sparkle-updater is not an OCUpdater
+ OCUpdater *updater = qobject_cast<OCUpdater*>(Updater::instance());
if (ConfigFile().skipUpdateCheck()) {
- updater = 0; // don't show update info if updates are disabled
-@@ -121,9 +122,12 @@ void GeneralSettings::slotUpdateInfo()
- _ui->updateStateLabel->setText(updater->statusString());
- _ui->restartButton->setVisible(updater->downloadState() == OCUpdater::DownloadComplete);
- } else {
-+#endif
+@@ -140,6 +141,7 @@
// can't have those infos from sparkle currently
_ui->updatesGroupBox->setVisible(false);
-+#if 0
}
+#endif
}
diff --git a/deskutils/owncloudclient/pkg-plist b/deskutils/owncloudclient/pkg-plist
index 8526c03f4809..e1c3e63c2dd7 100644
--- a/deskutils/owncloudclient/pkg-plist
+++ b/deskutils/owncloudclient/pkg-plist
@@ -20,6 +20,7 @@ lib/owncloud/libocsync.so.%%VERSION%%
%%PORTDOCS%%man/man1/owncloud.1.gz
%%PORTDOCS%%man/man1/owncloudcmd.1.gz
share/applications/owncloud.desktop
+share/caja-python/extensions/syncstate-ownCloud.py
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/.buildinfo
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-1.png
%%PORTDOCS%%%%DOCSDIR%%/html/unthemed/_images/client-2.png
@@ -218,8 +219,8 @@ share/icons/hicolor/72x72/apps/ownCloud_sync.png
share/icons/hicolor/72x72/apps/ownCloud_sync_shared.png
share/icons/hicolor/72x72/apps/ownCloud_warn.png
share/icons/hicolor/72x72/apps/ownCloud_warn_shared.png
-share/nautilus-python/extensions/syncstate.py
-share/nemo-python/extensions/syncstate.py
+share/nautilus-python/extensions/syncstate-ownCloud.py
+share/nemo-python/extensions/syncstate-ownCloud.py
share/owncloud/i18n/client_TW.qm
share/owncloud/i18n/client_ca.qm
share/owncloud/i18n/client_cs.qm