aboutsummaryrefslogtreecommitdiff
path: root/deskutils/parcellite
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-19 02:17:46 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2015-08-19 02:17:46 +0000
commitdd0229f65e28b5fd79e86666ef914807c1b84342 (patch)
tree1574df857efc0df3fab32c25b2c7b1f52ae73e87 /deskutils/parcellite
parent17d9def2af1e6b86cba7c7fa3b58d6537e7c62b6 (diff)
downloadports-dd0229f65e28b5fd79e86666ef914807c1b84342.tar.gz
ports-dd0229f65e28b5fd79e86666ef914807c1b84342.zip
deskutils/parcellite: update to 1.1.9
- Update to 1.1.9. - Remove patch-src__main.c - it's not needed now. - Add CPPFLAGS/LIBS (unbreak configure). - Patch Makefiles - add missing libraries to LDADD. - Add LICENSE_FILE. - Add all used dependencies (USE_GNOME=glib20 pango, USE_XORG=x11). - Honor Option NLS PR: 201875 Submitted by: s3erios@gmail.com Approved by: maintainer timeout (koalative@gmail.com ; 23 days)
Notes
Notes: svn path=/head/; revision=394672
Diffstat (limited to 'deskutils/parcellite')
-rw-r--r--deskutils/parcellite/Makefile46
-rw-r--r--deskutils/parcellite/distinfo4
-rw-r--r--deskutils/parcellite/files/extrapatch-configure.ac162
-rw-r--r--deskutils/parcellite/files/patch-src__main.c10
4 files changed, 194 insertions, 28 deletions
diff --git a/deskutils/parcellite/Makefile b/deskutils/parcellite/Makefile
index 0cfdc861f39f..71069719d387 100644
--- a/deskutils/parcellite/Makefile
+++ b/deskutils/parcellite/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= parcellite
-PORTVERSION= 1.1.7
-PORTREVISION= 1
+PORTVERSION= 1.1.9
PORTEPOCH= 1
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -12,37 +11,52 @@ MAINTAINER= koalative@gmail.com
COMMENT= Lightweight GTK+ clipboard manager
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-
-USES= gettext-tools gmake pkgconfig
+USES= pkgconfig
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 intltool
+USE_GNOME= glib20 gtk20 pango
+USE_XORG= x11
+CONFIGURE_ARGS+=--disable-appindicator
PORTDOCS= AUTHORS ChangeLog README
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
LIBS+= -lgio-2.0
-OPTIONS_DEFINE= DOCS NLS
+OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext-runtime
+NLS_USES= gmake gettext
+NLS_USE= GNOME=intltool
+NLS_USES_OFF= autoreconf
+NLS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extrapatch-configure.ac
NLS_LIBS= -lintl
SUB_FILES= pkg-message
-.include <bsd.port.options.mk>
+post-patch-NLS-on:
+ @${REINPLACE_CMD} -e 's|$$(DATADIRNAME)/locale|share/locale|' \
+ ${WRKSRC}/po/Makefile.in.in
+
+post-patch-NLS-off:
+ @${REINPLACE_CMD} -e 's|@INTLTOOL_DESKTOP_RULE@||' \
+ ${WRKSRC}/data/Makefile.am
+ @${REINPLACE_CMD} -e 's|_Name|Name|' -e 's|_Comment|Comment|' \
+ ${WRKSRC}/data/parcellite-startup.desktop.in \
+ ${WRKSRC}/data/parcellite.desktop.in
post-patch:
- @${REINPLACE_CMD} -e 's|"/proc/|"/compat/linux/proc/|; \
- s|"/proc"|"/compat/linux/proc"|' \
+ @${REINPLACE_CMD} -e 's|/proc|/compat/linux/proc|g' \
${WRKSRC}/src/utils.c
-.if ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e 's|$$(DATADIRNAME)/locale|share/locale|' \
- ${WRKSRC}/po/Makefile.in.in
-.endif
+
+pre-build-NLS-off:
+ @${REINPLACE_CMD} -e '/SUBDIRS = /s| po||' ${WRKSRC}/Makefile
+ ${MV} ${WRKSRC}/data/parcellite-startup.desktop.in \
+ ${WRKSRC}/data/parcellite-startup.desktop
+ ${MV} ${WRKSRC}/data/parcellite.desktop.in \
+ ${WRKSRC}/data/parcellite.desktop
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/deskutils/parcellite/distinfo b/deskutils/parcellite/distinfo
index a1a76d3b74c2..47bd3b3aa0f7 100644
--- a/deskutils/parcellite/distinfo
+++ b/deskutils/parcellite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (parcellite-1.1.7.tar.gz) = 870f3789f247b200a609cb6dbefa42204779b2575a9dafa5b90828d2fce05f5f
-SIZE (parcellite-1.1.7.tar.gz) = 723826
+SHA256 (parcellite-1.1.9.tar.gz) = cba89585082eebbe848ac1c0023cc71a0184c0db24ebc5f8a21039e46d7f11d4
+SIZE (parcellite-1.1.9.tar.gz) = 720177
diff --git a/deskutils/parcellite/files/extrapatch-configure.ac b/deskutils/parcellite/files/extrapatch-configure.ac
new file mode 100644
index 000000000000..084dc3c2507b
--- /dev/null
+++ b/deskutils/parcellite/files/extrapatch-configure.ac
@@ -0,0 +1,162 @@
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.
+--- configure.ac.orig 2014-10-01 14:43:09 UTC
++++ configure.ac
+@@ -19,15 +19,9 @@ GETTEXT_PACKAGE=parcellite
+ AC_SUBST(GETTEXT_PACKAGE)
+ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [gettext package])
+
+-ALL_LINGUAS="ca cs da de es fr hu it ja nb pl pl_PL pt_BR ro ru sv tr zh_CN"
+-AM_GLIB_GNU_GETTEXT()
+-AC_PROG_INTLTOOL([0.23])
+-
+ parcellitelocaledir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(parcellitelocaledir)
+
+-AM_GNU_GETTEXT([external])
+-
+ # -------------------------------------------------------------------------------
+ # Main settings.
+ # -------------------------------------------------------------------------------
+@@ -104,7 +98,7 @@ AC_CHECK_LIB([$gtk_libs],gtk_status_icon
+ # -------------------------------------------------------------------------------
+ # Checks for header files.
+ # -------------------------------------------------------------------------------
+-AC_CHECK_HEADERS([stdlib.h string.h pthread.h libintl.h])
++AC_CHECK_HEADERS([stdlib.h string.h pthread.h])
+
+ # -------------------------------------------------------------------------------
+ # Checks for typedefs, structures, and compiler characteristics.
diff --git a/deskutils/parcellite/files/patch-src__main.c b/deskutils/parcellite/files/patch-src__main.c
deleted file mode 100644
index 20cb98a441bd..000000000000
--- a/deskutils/parcellite/files/patch-src__main.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/main.c.orig 2013-10-15 19:39:04.000000000 +0200
-+++ ./src/main.c 2013-12-31 15:12:54.000000000 +0100
-@@ -2097,6 +2097,7 @@
- }
- clip_lock= g_mutex_new();
- hist_lock= g_mutex_new();
-+ g_mutex_trylock(clip_lock);
- g_mutex_unlock(clip_lock);
-
- show_icon=!get_pref_int32("no_icon");