aboutsummaryrefslogtreecommitdiff
path: root/deskutils/preferences
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2017-08-21 13:26:28 +0000
committerDavid Chisnall <theraven@FreeBSD.org>2017-08-21 13:26:28 +0000
commit31e0b9f12cc7c944cfa44082f5ff6c94615f8d68 (patch)
tree1818a753b93ff1ef78365147f674b9e83bcf0048 /deskutils/preferences
parented4f9411de6026a3b60201af8fab0ba50db224cb (diff)
downloadports-31e0b9f12cc7c944cfa44082f5ff6c94615f8d68.tar.gz
ports-31e0b9f12cc7c944cfa44082f5ff6c94615f8d68.zip
Update GNUstep core libraries.
Update the default Objective-C compiler. Fix various build failures in GNUstep ports from newer versions of the GNUstep core libraries and from changes to GNUstep Make. Update various ports that use GNUstep and bump the portrevision of the ones that haven't had a new release.
Notes
Notes: svn path=/head/; revision=448472
Diffstat (limited to 'deskutils/preferences')
-rw-r--r--deskutils/preferences/Makefile2
-rw-r--r--deskutils/preferences/files/patch-GNUmakefile.preamble31
-rw-r--r--deskutils/preferences/files/patch-Keyboard.m10
-rw-r--r--deskutils/preferences/files/patch-Modules_Keyboard_GNUmakefile (renamed from deskutils/preferences/files/patch-Modules-Keyboard-GNUmakefile)6
-rw-r--r--deskutils/preferences/files/patch-Modules_Keyboard_Keyboard.m13
-rw-r--r--deskutils/preferences/files/patch-PrefsModule_GNUmakefile.preamble21
6 files changed, 69 insertions, 14 deletions
diff --git a/deskutils/preferences/Makefile b/deskutils/preferences/Makefile
index 9f90bbef26f7..e4df930a5f82 100644
--- a/deskutils/preferences/Makefile
+++ b/deskutils/preferences/Makefile
@@ -2,7 +2,7 @@
PORTNAME= preferences
PORTVERSION= 1.2.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= deskutils gnustep
MASTER_SITES= SF/prefsapp/prefsapp/${PORTVERSION}
DISTNAME= Preferences-${PORTVERSION}
diff --git a/deskutils/preferences/files/patch-GNUmakefile.preamble b/deskutils/preferences/files/patch-GNUmakefile.preamble
new file mode 100644
index 000000000000..14914b05ebcb
--- /dev/null
+++ b/deskutils/preferences/files/patch-GNUmakefile.preamble
@@ -0,0 +1,31 @@
+--- GNUmakefile.preamble.orig 2002-02-12 04:35:17 UTC
++++ GNUmakefile.preamble
+@@ -2,10 +2,10 @@
+ ADDITIONAL_CPPFLAGS +=
+
+ # Additional flags to pass to the Objective-C compiler
+-ADDITIONAL_OBJCFLAGS += -Wall -Werror
++ADDITIONAL_OBJCFLAGS += -Wall
+
+ # Additional flags to pass to the C compiler
+-ADDITIONAL_CFLAGS += -Wall -Werror
++ADDITIONAL_CFLAGS += -Wall
+
+ # Additional include directories the compiler should search
+ ADDITIONAL_INCLUDE_DIRS +=
+@@ -30,15 +30,3 @@ ADDITIONAL_OBJC_LIBS +=
+ ADDITIONAL_TOOL_LIBS +=
+ # WebObjects
+ ADDITIONAL_WO_LIBS +=
+-
+-#
+-# Flags dealing with installing and uninstalling
+-#
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
+-
+-# Additional directories to be created during installation
+-ADDITIONAL_INSTALL_DIRS += \
+- $(GNUSTEP_USER_ROOT)/Library/Preferences \
+- $(GNUSTEP_LOCAL_ROOT)/Library/Preferences \
+- $(GNUSTEP_NETWORK_ROOT)/Library/Preferences \
+- $(GNUSTEP_SYSTEM_ROOT)/Library/Preferences
diff --git a/deskutils/preferences/files/patch-Keyboard.m b/deskutils/preferences/files/patch-Keyboard.m
deleted file mode 100644
index bdf962baf8c3..000000000000
--- a/deskutils/preferences/files/patch-Keyboard.m
+++ /dev/null
@@ -1,10 +0,0 @@
---- Modules/Keyboard/Keyboard.m.orig 2002-06-08 10:29:36.000000000 +0200
-+++ Modules/Keyboard/Keyboard.m 2010-05-22 11:24:43.000000000 +0200
-@@ -37,6 +37,7 @@
- #import <AppKit/NSButton.h>
- #import <AppKit/NSNibLoading.h>
- #import <AppKit/NSOpenPanel.h>
-+#import <Foundation/NSUserDefaults.h>
-
- #import "Keyboard.h"
- #import "KeyboardView.h"
diff --git a/deskutils/preferences/files/patch-Modules-Keyboard-GNUmakefile b/deskutils/preferences/files/patch-Modules_Keyboard_GNUmakefile
index 603e28217bbe..02a1348e3eb4 100644
--- a/deskutils/preferences/files/patch-Modules-Keyboard-GNUmakefile
+++ b/deskutils/preferences/files/patch-Modules_Keyboard_GNUmakefile
@@ -1,11 +1,11 @@
---- Modules/Keyboard/GNUmakefile.orig 2014-07-30 00:10:57.436168949 +0800
-+++ Modules/Keyboard/GNUmakefile 2014-07-30 00:11:06.363171068 +0800
+--- Modules/Keyboard/GNUmakefile.orig 2002-02-12 04:49:55 UTC
++++ Modules/Keyboard/GNUmakefile
@@ -3,7 +3,7 @@ include $(GNUSTEP_MAKEFILES)/common.make
BUNDLE_NAME= Keyboard
BUNDLE_EXTENSION= .prefs
-BUNDLE_INSTALL_DIR= $(GNUSTEP_SYSTEM_ROOT)/Library/Preferences
-+BUNDLE_INSTALL_DIR= $(DESTDIR)$(GNUSTEP_SYSTEM_ROOT)/Library/Preferences
++BUNDLE_INSTALL_DIR= $(DESTDIR)/$(GNUSTEP_SYSTEM_LIBRARY)/Preferences
Keyboard_RESOURCE_FILES= \
Keyboard.gorm
diff --git a/deskutils/preferences/files/patch-Modules_Keyboard_Keyboard.m b/deskutils/preferences/files/patch-Modules_Keyboard_Keyboard.m
new file mode 100644
index 000000000000..3dbd87aaaa21
--- /dev/null
+++ b/deskutils/preferences/files/patch-Modules_Keyboard_Keyboard.m
@@ -0,0 +1,13 @@
+--- Modules/Keyboard/Keyboard.m.orig 2017-08-13 12:40:14 UTC
++++ Modules/Keyboard/Keyboard.m
+@@ -34,9 +34,7 @@ static const char rcsid[] =
+ # include "Config.h"
+ #endif
+
+-#import <AppKit/NSButton.h>
+-#import <AppKit/NSNibLoading.h>
+-#import <AppKit/NSOpenPanel.h>
++#import <Cocoa/Cocoa.h>
+
+ #import "Keyboard.h"
+ #import "KeyboardView.h"
diff --git a/deskutils/preferences/files/patch-PrefsModule_GNUmakefile.preamble b/deskutils/preferences/files/patch-PrefsModule_GNUmakefile.preamble
new file mode 100644
index 000000000000..5b75f7af9ff0
--- /dev/null
+++ b/deskutils/preferences/files/patch-PrefsModule_GNUmakefile.preamble
@@ -0,0 +1,21 @@
+--- PrefsModule/GNUmakefile.preamble.orig 2002-02-12 05:02:11 UTC
++++ PrefsModule/GNUmakefile.preamble
+@@ -2,10 +2,10 @@
+ ADDITIONAL_CPPFLAGS +=
+
+ # Additional flags to pass to the Objective-C compiler
+-ADDITIONAL_OBJCFLAGS += -Wall -Werror
++ADDITIONAL_OBJCFLAGS += -Wall
+
+ # Additional flags to pass to the C compiler
+-ADDITIONAL_CFLAGS += -Wall -Werror
++ADDITIONAL_CFLAGS += -Wall
+
+ # Additional include directories the compiler should search
+ ADDITIONAL_INCLUDE_DIRS +=
+@@ -34,5 +34,4 @@ ADDITIONAL_WO_LIBS +=
+ #
+ # Flags dealing with installing and uninstalling
+ #
+-GNUSTEP_INSTALLATION_DIR=$(GNUSTEP_SYSTEM_ROOT)
+ # Additional directories to be created during installation