aboutsummaryrefslogtreecommitdiff
path: root/deskutils/py-vdirsyncer
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-06-20 17:05:41 +0000
commit4376dbbb58dab5a7bf7a8240ca39b562de78343b (patch)
tree8997a738fc5162cf5f1383dd3c61c0423454979b /deskutils/py-vdirsyncer
parent6cb7ca00bb0a9a3aa67008824300ee8d16203a1b (diff)
downloadports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.tar.gz
ports-4376dbbb58dab5a7bf7a8240ca39b562de78343b.zip
Use PY_FLAVOR for dependencies.
FLAVOR is the current port's flavor, it should not be used outside of this scope. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=472884
Diffstat (limited to 'deskutils/py-vdirsyncer')
-rw-r--r--deskutils/py-vdirsyncer/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/deskutils/py-vdirsyncer/Makefile b/deskutils/py-vdirsyncer/Makefile
index 4edeec69857d..13d7b36416e6 100644
--- a/deskutils/py-vdirsyncer/Makefile
+++ b/deskutils/py-vdirsyncer/Makefile
@@ -12,13 +12,13 @@ COMMENT= Synchronize calendars and contacts
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.10.1:devel/py-setuptools_scm@${FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomicwrites>=0.1.7:devel/py-atomicwrites@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}click>=5.0:devel/py-click@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}click-log>=0.1.3:devel/py-click-log@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}click-threading>=0.1.2:devel/py-click-threading@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.4.1:www/py-requests@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}requests-toolbelt>=0.4.0:www/py-requests-toolbelt@${FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.10.1:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomicwrites>=0.1.7:devel/py-atomicwrites@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=5.0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click-log>=0.1.3:devel/py-click-log@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click-threading>=0.1.2:devel/py-click-threading@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.4.1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests-toolbelt>=0.4.0:www/py-requests-toolbelt@${PY_FLAVOR}
USES= python:3.4+
USE_PYTHON= autoplist distutils
@@ -27,6 +27,6 @@ NO_ARCH= yes
OPTIONS_DEFINE= GOOGLE
GOOGLE_DESC= Enable Google Calendar support
-GOOGLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0:www/py-requests-oauthlib@${FLAVOR}
+GOOGLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests-oauthlib>=0:www/py-requests-oauthlib@${PY_FLAVOR}
.include <bsd.port.mk>