aboutsummaryrefslogtreecommitdiff
path: root/deskutils/remind
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-12-06 09:01:56 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-12-06 09:01:56 +0000
commitbe61e7c06ec1032f1ba91c1fad4d932656a2f3f7 (patch)
treea4a9b8e58cefe5369338fa1fe4dc823bb9fb01b1 /deskutils/remind
parenta2d03dddbcf255de9748d33180b1152dbf663472 (diff)
downloadports-be61e7c06ec1032f1ba91c1fad4d932656a2f3f7.tar.gz
ports-be61e7c06ec1032f1ba91c1fad4d932656a2f3f7.zip
- Update to 3.1.10
- Add tcl/tk support PR: ports/152832 Submitted by: Herbert J. Skuhra <h.skuhra AT gmail.com>
Notes
Notes: svn path=/head/; revision=265752
Diffstat (limited to 'deskutils/remind')
-rw-r--r--deskutils/remind/Makefile45
-rw-r--r--deskutils/remind/distinfo5
2 files changed, 41 insertions, 9 deletions
diff --git a/deskutils/remind/Makefile b/deskutils/remind/Makefile
index 56bd764f6f9b..3d76c270af07 100644
--- a/deskutils/remind/Makefile
+++ b/deskutils/remind/Makefile
@@ -6,22 +6,36 @@
#
PORTNAME= remind
-PORTVERSION= 3.1.3
+PORTVERSION= 3.1.10
CATEGORIES= deskutils
MASTER_SITES= http://www.roaringpenguin.com/files/download/ \
http://freebsd.unixfreunde.de/sources/
-DISTNAME= ${PORTNAME}-03.01.03
+DISTNAME= ${PORTNAME}-03.01.10
MAINTAINER= jadawin@FreeBSD.org
COMMENT= Sophisticated calendar and alarm program
+LICENSE= GPLv2
+
+OPTIONS= TCLTK "Tcl/Tk support" off
+
GNU_CONFIGURE= yes
MAKE_ARGS= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
-MAN1= rem.1 rem2ps.1 remind.1 tkremind.1 cm2rem.1
+MAN1= rem.1 rem2ps.1 remind.1
+
+PLIST_FILES= bin/rem bin/rem2ps bin/remind
-PLIST_FILES= bin/cm2rem.tcl bin/rem bin/rem2ps bin/remind \
- bin/tkremind
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TCLTK)
+USE_TK= yes
+RUN_DEPENDS+= dtplite:${PORTSDIR}/devel/tcllib
+MAN1+= cm2rem.1 tkremind.1
+PLIST_FILES+= bin/cm2rem.tcl bin/tkremind
+.endif
+
+.include <bsd.port.pre.mk>
post-patch:
# This seems more than a little ugly.
@@ -49,5 +63,24 @@ post-patch:
.if defined(A4)
@${REINPLACE_CMD} -e 's#"Letter", 612, 792#"A4", 595, 842#' ${WRKSRC}/src/custom.h
.endif
+.if defined(WITH_TCLTK)
+ @${REINPLACE_CMD} -e 's,wish,${WISH},' ${WRKSRC}/scripts/tkremind
+ @${REINPLACE_CMD} -e 's,tclsh,${TCLSH},' ${WRKSRC}/scripts/cm2rem.tcl
+.endif
+
+do-install:
+.for i in rem2ps remind
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${i} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/${i}.1 ${PREFIX}/man/man1
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/man/rem.1 ${PREFIX}/man/man1
+ ${LN} -sf ${PREFIX}/bin/remind ${PREFIX}/bin/rem
+.if defined(WITH_TCLTK)
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/cm2rem.tcl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/tkremind ${PREFIX}/bin
+.for i in cm2rem tkremind
+ ${INSTALL_MAN} ${WRKSRC}/man/${i}.1 ${PREFIX}/man/man1
+.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/remind/distinfo b/deskutils/remind/distinfo
index 354662718250..bd664506e948 100644
--- a/deskutils/remind/distinfo
+++ b/deskutils/remind/distinfo
@@ -1,3 +1,2 @@
-MD5 (remind-03.01.03.tar.gz) = 32fa5390910829db16f1f126a0120e94
-SHA256 (remind-03.01.03.tar.gz) = e70d9ae57c9cfdc41b0eb38da06cdf48cb7f38c11a6d77e068a86a5c67b22d8b
-SIZE (remind-03.01.03.tar.gz) = 304315
+SHA256 (remind-03.01.10.tar.gz) = c62bea8db26b08704c1d7bc33f6775509ea649a4ff69316334639e4cdd9ed53e
+SIZE (remind-03.01.10.tar.gz) = 357033