aboutsummaryrefslogtreecommitdiff
path: root/deskutils/spice-gtk/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-04-14 08:22:47 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-04-14 08:22:47 +0000
commit56f16b3e49e9986883c03c2e1ecb00d020254be4 (patch)
tree2447c6e9749e114d623607b527a52d2cd7689039 /deskutils/spice-gtk/Makefile
parent2538a040cb5ed56190620f3bbcae6e50994abb42 (diff)
downloadports-56f16b3e49e9986883c03c2e1ecb00d020254be4.tar.gz
ports-56f16b3e49e9986883c03c2e1ecb00d020254be4.zip
deskutils/spice-gtk: add missing LIB_DEPENDS, USES+=gnome
spice-gtk picks up libva when present with no option to disable it easily, so make it a requisite for a consistent dependency situation in bare-metal and jail builds. The FreeBSD ports rig complains that USE_GNOME requires USES=gnome, so add that. PR: 237264 Approved by: xxjack12xx@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=498873
Diffstat (limited to 'deskutils/spice-gtk/Makefile')
-rw-r--r--deskutils/spice-gtk/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index 9c25a5cfe6ce..88e847f30379 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -17,12 +17,13 @@ NOT_FOR_ARCHS_REASON= server only supports little-endian
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libjson-glib-1.0.so:devel/json-glib \
- libopus.so:audio/opus
+ libopus.so:audio/opus \
+ libva-x11.so:multimedia/libva
BUILD_DEPENDS= spice-protocol>=0.12.15:devel/spice-protocol \
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing@${PY_FLAVOR}
RUN_DEPENDS= spice-protocol>=0.12.15:devel/spice-protocol
-USES= autoreconf cpe gettext-tools gmake jpeg libtool pkgconfig tar:bzip2 \
+USES= autoreconf cpe gettext-tools gmake gnome jpeg libtool pkgconfig tar:bzip2 \
python ssl localbase:ldflags
USE_XORG= x11 pixman
USE_GNOME= cairo gdkpixbuf2 gnomeprefix gtk30 intltool introspection:build