aboutsummaryrefslogtreecommitdiff
path: root/deskutils/spice-gtk
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2018-01-20 17:46:37 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2018-01-20 17:46:37 +0000
commit0c784348472a67d23712404179a09ea273fbe8f8 (patch)
tree46c6dad842c8088cab1f4a1106c4394906fd59f8 /deskutils/spice-gtk
parent887edb80c9dc66c157958814cdb28473e3a79013 (diff)
downloadports-0c784348472a67d23712404179a09ea273fbe8f8.tar.gz
ports-0c784348472a67d23712404179a09ea273fbe8f8.zip
Notes
Diffstat (limited to 'deskutils/spice-gtk')
-rw-r--r--deskutils/spice-gtk/Makefile53
-rw-r--r--deskutils/spice-gtk/distinfo6
-rw-r--r--deskutils/spice-gtk/pkg-plist39
3 files changed, 47 insertions, 51 deletions
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index 34985f8ff973..b8c206dcac9c 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -2,35 +2,26 @@
# $FreeBSD$
PORTNAME= spice-gtk
-PORTVERSION= 0.33
-PORTREVISION?= 0
+PORTVERSION= 0.34
CATEGORIES?= deskutils gnome
MASTER_SITES= http://www.spice-space.org/download/gtk/
MAINTAINER= olevole@olevole.ru
-COMMENT?= Gtk client and libraries for SPICE remote desktop servers
+COMMENT= Gtk client and libraries for SPICE remote desktop servers
LICENSE= GPLv2
-USE_XORG= pixman
-USE_GNOME= gnomeprefix gtk20 gtk30 intltool introspection:build
-USES= autoreconf cpe gmake jpeg libtool pkgconfig tar:bzip2 \
- python ssl localbase:ldflags
-CPE_VENDOR= redhat
-
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libopus.so:audio/opus
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol \
${PYTHON_PKGNAMEPREFIX}pyparsing>=2.0.1:devel/py-pyparsing@${PY_FLAVOR}
RUN_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol
-.if defined(SPICE_SLAVE)
-PORTREVISION= 1
-CATEGORIES+= python
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-USES:= ${USES:Npython} python:2.7
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:x11-toolkits/py-gtk2
-CONFIGURE_ARGS+= --with-python
-.endif
+USES= autoreconf cpe gmake jpeg libtool pkgconfig tar:bzip2 \
+ python ssl localbase:ldflags
+USE_XORG= x11 pixman
+USE_GNOME= cairo gdkpixbuf2 gnomeprefix gtk30 intltool introspection:build
+CPE_VENDOR= redhat
SPICE_SSL_CFLAGS= -I${OPENSSLINC}
SPICE_SSL_LIBS= -L${OPENSSLLIB} -lcrypto -lssl
@@ -41,28 +32,34 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
# we can't use pathfix with USES=autoreconf
-MAKE_ARGS= pkgconfigdir="$(PREFIX)/libdata/pkgconfig"
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= NLS DOCS SASL
-OPTIONS_DEFAULT= GSTREAMER SASL
+OPTIONS_DEFINE= LZ4 NLS DOCS SASL
+OPTIONS_DEFAULT= GSTREAMER LZ4 PULSEAUDIO SASL
+
+OPTIONS_GROUP= AUDIO
+OPTIONS_GROUP_AUDIO= GSTREAMER PULSEAUDIO
+
OPTIONS_SUB= yes
+LZ4_CONFIGURE_ENABLE= lz4
+LZ4_LIB_DEPENDS+= liblz4.so:archivers/liblz4
+
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
-OPTIONS_SINGLE= AUDIO
-OPTIONS_SINGLE_AUDIO= GSTREAMER PULSEAUDIO NOAUDIO
-
NOAUDIO_DESC= Disable audio backend
-GSTREAMER_CONFIGURE_ON= --with-audio=gstreamer
-GSTREAMER_USE= GSTREAMER1=yes
-PULSEAUDIO_CONFIGURE_ON= --with-audio=pulse
+GSTREAMER_CONFIGURE_ENABLE= gstaudio
+GSTREAMER_USE= GSTREAMER1=yes
+GSTREAMER_CONFIGURE_ON= --enable-gstvideo=yes
+GSTREAMER_CONFIGURE_OFF= --enable-gstvideo=no
+
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_ENABLE= pulse
-NOAUDIO_CONFIGURE_ON= --with-audio=no
+
SASL_CONFIGURE_WITH= sasl=yes
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
diff --git a/deskutils/spice-gtk/distinfo b/deskutils/spice-gtk/distinfo
index 41a1d1300fd3..a0f531cb29a0 100644
--- a/deskutils/spice-gtk/distinfo
+++ b/deskutils/spice-gtk/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477412449
-SHA256 (spice-gtk-0.33.tar.bz2) = 7daf33b786ab8ebc9fe6e7b11745100ee1ab66e61a5811d1d5aabe4d66eaaf39
-SIZE (spice-gtk-0.33.tar.bz2) = 1383927
+TIMESTAMP = 1515485373
+SHA256 (spice-gtk-0.34.tar.bz2) = e9720e01165f8451c9f3f58ad50e3afb990993b81cc2db86b3661b7ac5b976ee
+SIZE (spice-gtk-0.34.tar.bz2) = 1480566
diff --git a/deskutils/spice-gtk/pkg-plist b/deskutils/spice-gtk/pkg-plist
index 1e0634db124b..8e2298f8be1a 100644
--- a/deskutils/spice-gtk/pkg-plist
+++ b/deskutils/spice-gtk/pkg-plist
@@ -47,24 +47,7 @@ libdata/pkgconfig/spice-client-glib-2.0.pc
libdata/pkgconfig/spice-client-gtk-3.0.pc
libdata/pkgconfig/spice-controller.pc
man/man1/spice-client.1.gz
-share/doc/spice-gtk/SpiceAudio.html
-share/doc/spice-gtk/SpiceChannel.html
-share/doc/spice-gtk/SpiceCursorChannel.html
-share/doc/spice-gtk/SpiceDisplayChannel.html
-share/doc/spice-gtk/SpiceFileTransferTask.html
-share/doc/spice-gtk/SpiceInputsChannel.html
-share/doc/spice-gtk/SpiceMainChannel.html
-share/doc/spice-gtk/SpicePlaybackChannel.html
-share/doc/spice-gtk/SpicePortChannel.html
-share/doc/spice-gtk/SpiceRecordChannel.html
-share/doc/spice-gtk/SpiceSession.html
-share/doc/spice-gtk/SpiceSmartcardChannel.html
-share/doc/spice-gtk/SpiceSmartcardManager.html
-share/doc/spice-gtk/SpiceUsbDeviceManager.html
-share/doc/spice-gtk/SpiceUsbredirChannel.html
-share/doc/spice-gtk/SpiceWebdavChannel.html
share/doc/spice-gtk/annotation-glossary.html
-share/doc/spice-gtk/api-index-deprecated.html
share/doc/spice-gtk/api-index-full.html
share/doc/spice-gtk/api-reference.html
share/doc/spice-gtk/application-support.html
@@ -78,13 +61,29 @@ share/doc/spice-gtk/left.png
share/doc/spice-gtk/object-tree.html
share/doc/spice-gtk/right-insensitive.png
share/doc/spice-gtk/right.png
-share/doc/spice-gtk/spice-gtk-SpiceDisplay.html
-share/doc/spice-gtk/spice-gtk-SpiceGtkSession.html
share/doc/spice-gtk/spice-gtk-SpiceURI.html
-share/doc/spice-gtk/spice-gtk-SpiceUsbDeviceWidget.html
share/doc/spice-gtk/spice-gtk-Utilities.html
share/doc/spice-gtk/spice-gtk-Version-Information.html
share/doc/spice-gtk/spice-gtk.devhelp2
+share/doc/spice-gtk/SpiceAudio.html
+share/doc/spice-gtk/SpiceChannel.html
+share/doc/spice-gtk/SpiceCursorChannel.html
+share/doc/spice-gtk/SpiceDisplay.html
+share/doc/spice-gtk/SpiceDisplayChannel.html
+share/doc/spice-gtk/SpiceFileTransferTask.html
+share/doc/spice-gtk/SpiceGtkSession.html
+share/doc/spice-gtk/SpiceInputsChannel.html
+share/doc/spice-gtk/SpiceMainChannel.html
+share/doc/spice-gtk/SpicePlaybackChannel.html
+share/doc/spice-gtk/SpicePortChannel.html
+share/doc/spice-gtk/SpiceRecordChannel.html
+share/doc/spice-gtk/SpiceSession.html
+share/doc/spice-gtk/SpiceSmartcardChannel.html
+share/doc/spice-gtk/SpiceSmartcardManager.html
+share/doc/spice-gtk/SpiceUsbDeviceManager.html
+share/doc/spice-gtk/SpiceUsbDeviceWidget.html
+share/doc/spice-gtk/SpiceUsbredirChannel.html
+share/doc/spice-gtk/SpiceWebdavChannel.html
share/doc/spice-gtk/style.css
share/doc/spice-gtk/up-insensitive.png
share/doc/spice-gtk/up.png