aboutsummaryrefslogtreecommitdiff
path: root/deskutils/spice-gtk
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2015-02-09 16:21:59 +0000
committerJason Helfman <jgh@FreeBSD.org>2015-02-09 16:21:59 +0000
commit1f225e555cb77a1e9b9e23f824dd77a71a004d40 (patch)
tree1c247e62f548ab7b5f6c1d714670165ae9e570d6 /deskutils/spice-gtk
parentbeb4e272158f74067a0e238411e2871ba0e8f87f (diff)
downloadports-1f225e555cb77a1e9b9e23f824dd77a71a004d40.tar.gz
ports-1f225e555cb77a1e9b9e23f824dd77a71a004d40.zip
Add new ports: spice-gtk and py-spice-gtk
spice-gtk is a GTK+2 and GTK+3 SPICE widget. It features glib-based objects for SPICE protocol parsing and a gtk widget for embedding the SPICE display into other applications such as virt-manager. Python bindings are available too. WWW: http://www.spice-space.org/ PR: 196949 (based on) Submitted by: olevole@olevole.ru
Notes
Notes: svn path=/head/; revision=378739
Diffstat (limited to 'deskutils/spice-gtk')
-rw-r--r--deskutils/spice-gtk/Makefile64
-rw-r--r--deskutils/spice-gtk/distinfo2
-rw-r--r--deskutils/spice-gtk/pkg-descr6
-rw-r--r--deskutils/spice-gtk/pkg-plist94
4 files changed, 166 insertions, 0 deletions
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
new file mode 100644
index 000000000000..76389d71d01e
--- /dev/null
+++ b/deskutils/spice-gtk/Makefile
@@ -0,0 +1,64 @@
+# Created by: olevole@olevole.ru
+# $FreeBSD$
+
+PORTNAME= spice-gtk
+PORTVERSION= 0.26
+CATEGORIES?= deskutils gnome
+MASTER_SITES= http://www.spice-space.org/download/gtk/
+
+MAINTAINER= olevole@olevole.ru
+COMMENT?= Gtk client and libraries for SPICE remote desktop servers
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+
+USE_XORG= pixman
+USE_GNOME= gnomeprefix gtk20 gtk30 intltool introspection:build
+USES= gmake libtool pkgconfig tar:bzip2 pathfix
+
+.if defined(SPICE_SLAVE)
+CATEGORIES+= python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
+CONFIGURE_ARGS+= --with-python
+PLIST_FILES+= %%PYTHON_SITELIBDIR%%/SpiceClientGtk.a \
+ %%PYTHON_SITELIBDIR%%/SpiceClientGtk.so
+USES+= python
+.endif
+
+CONFIGURE_ENV+= SSL_CFLAGS=-I${OPENSSLINC} \
+ SSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= NLS DOCS SASL
+OPTIONS_DEFAULT= GSTREAMER SASL
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+OPTIONS_SINGLE= AUDIO
+OPTIONS_SINGLE_AUDIO= GSTREAMER PULSEAUDIO NOAUDIO
+
+NOAUDIO_DESC= Disable audio backend
+
+GSTREAMER_CONFIGURE_ON= --with-audio=gstreamer
+GSTREAMER_USE= gstreamer=yes
+PULSEAUDIO_CONFIGURE_ON= --with-audio=pulse
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
+PULSEAUDIO_CONFIGURE_ENABLE= pulse
+NOAUDIO_CONFIGURE_ON= --with-audio=no
+SASL_CONFIGURE_WITH= sasl=yes
+SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+
+.include <bsd.port.mk>
diff --git a/deskutils/spice-gtk/distinfo b/deskutils/spice-gtk/distinfo
new file mode 100644
index 000000000000..597410f2aad5
--- /dev/null
+++ b/deskutils/spice-gtk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (spice-gtk-0.26.tar.bz2) = d61cabeb4ae03afb5bb921139491d1088ca0cdf77c7e70b8039fe62c2246e3f9
+SIZE (spice-gtk-0.26.tar.bz2) = 1278731
diff --git a/deskutils/spice-gtk/pkg-descr b/deskutils/spice-gtk/pkg-descr
new file mode 100644
index 000000000000..508001018118
--- /dev/null
+++ b/deskutils/spice-gtk/pkg-descr
@@ -0,0 +1,6 @@
+spice-gtk is a GTK+2 and GTK+3 SPICE widget. It features glib-based objects
+for SPICE protocol parsing and a gtk widget for embedding the SPICE display
+into other applications such as virt-manager.
+Python bindings are available too.
+
+WWW: http://www.spice-space.org/
diff --git a/deskutils/spice-gtk/pkg-plist b/deskutils/spice-gtk/pkg-plist
new file mode 100644
index 000000000000..5f18b37052e6
--- /dev/null
+++ b/deskutils/spice-gtk/pkg-plist
@@ -0,0 +1,94 @@
+share/vala/vapi/spice-protocol.vapi
+%%NLS%%share/locale/fr/LC_MESSAGES/spice-gtk.mo
+share/gir-1.0/SpiceClientGtk-3.0.gir
+share/gir-1.0/SpiceClientGLib-2.0.gir
+share/doc/spice-gtk/up.png
+share/doc/spice-gtk/up-insensitive.png
+share/doc/spice-gtk/style.css
+share/doc/spice-gtk/spice-gtk.devhelp2
+share/doc/spice-gtk/spice-gtk-Utilities.html
+share/doc/spice-gtk/spice-gtk-SpiceURI.html
+share/doc/spice-gtk/right.png
+share/doc/spice-gtk/right-insensitive.png
+share/doc/spice-gtk/object-tree.html
+share/doc/spice-gtk/left.png
+share/doc/spice-gtk/left-insensitive.png
+share/doc/spice-gtk/index.sgml
+share/doc/spice-gtk/index.html
+share/doc/spice-gtk/home.png
+share/doc/spice-gtk/ch03.html
+share/doc/spice-gtk/ch02.html
+share/doc/spice-gtk/ch01.html
+share/doc/spice-gtk/application-support.html
+share/doc/spice-gtk/api-reference.html
+share/doc/spice-gtk/api-index-full.html
+share/doc/spice-gtk/api-index-deprecated.html
+share/doc/spice-gtk/annotation-glossary.html
+share/doc/spice-gtk/SpiceWebdavChannel.html
+share/doc/spice-gtk/SpiceUsbredirChannel.html
+share/doc/spice-gtk/SpiceUsbDeviceWidget.html
+share/doc/spice-gtk/SpiceUsbDeviceManager.html
+share/doc/spice-gtk/SpiceSmartcardManager.html
+share/doc/spice-gtk/SpiceSmartcardChannel.html
+share/doc/spice-gtk/SpiceSession.html
+share/doc/spice-gtk/SpiceRecordChannel.html
+share/doc/spice-gtk/SpicePortChannel.html
+share/doc/spice-gtk/SpicePlaybackChannel.html
+share/doc/spice-gtk/SpiceMainChannel.html
+share/doc/spice-gtk/SpiceInputsChannel.html
+share/doc/spice-gtk/SpiceGtkSession.html
+share/doc/spice-gtk/SpiceDisplayChannel.html
+share/doc/spice-gtk/SpiceDisplay.html
+share/doc/spice-gtk/SpiceCursorChannel.html
+share/doc/spice-gtk/SpiceChannel.html
+share/doc/spice-gtk/SpiceAudio.html
+man/man1/spice-client.1.gz
+libdata/pkgconfig/spice-controller.pc
+libdata/pkgconfig/spice-client-gtk-3.0.pc
+libdata/pkgconfig/spice-client-glib-2.0.pc
+lib/libspice-controller.so.0.0.0
+lib/libspice-controller.so.0
+lib/libspice-controller.so
+lib/libspice-controller.a
+lib/libspice-client-gtk-3.0.so.4.0.0
+lib/libspice-client-gtk-3.0.so.4
+lib/libspice-client-gtk-3.0.so
+lib/libspice-client-gtk-3.0.a
+lib/libspice-client-glib-2.0.so.8.5.0
+lib/libspice-client-glib-2.0.so.8
+lib/libspice-client-glib-2.0.so
+lib/libspice-client-glib-2.0.a
+lib/girepository-1.0/SpiceClientGtk-3.0.typelib
+lib/girepository-1.0/SpiceClientGLib-2.0.typelib
+include/spice-controller/spice-controller.h
+include/spice-client-gtk-3.0/usb-device-widget.h
+include/spice-client-gtk-3.0/spice-widget.h
+include/spice-client-gtk-3.0/spice-widget-enums.h
+include/spice-client-gtk-3.0/spice-gtk-session.h
+include/spice-client-gtk-3.0/spice-grabsequence.h
+include/spice-client-glib-2.0/usb-device-manager.h
+include/spice-client-glib-2.0/spice-version.h
+include/spice-client-glib-2.0/spice-util.h
+include/spice-client-glib-2.0/spice-uri.h
+include/spice-client-glib-2.0/spice-types.h
+include/spice-client-glib-2.0/spice-session.h
+include/spice-client-glib-2.0/spice-option.h
+include/spice-client-glib-2.0/spice-glib-enums.h
+include/spice-client-glib-2.0/spice-client.h
+include/spice-client-glib-2.0/spice-channel.h
+include/spice-client-glib-2.0/spice-channel-enums.h
+include/spice-client-glib-2.0/spice-audio.h
+include/spice-client-glib-2.0/smartcard-manager.h
+include/spice-client-glib-2.0/channel-webdav.h
+include/spice-client-glib-2.0/channel-usbredir.h
+include/spice-client-glib-2.0/channel-smartcard.h
+include/spice-client-glib-2.0/channel-record.h
+include/spice-client-glib-2.0/channel-port.h
+include/spice-client-glib-2.0/channel-playback.h
+include/spice-client-glib-2.0/channel-main.h
+include/spice-client-glib-2.0/channel-inputs.h
+include/spice-client-glib-2.0/channel-display.h
+include/spice-client-glib-2.0/channel-cursor.h
+bin/spicy-stats
+bin/spicy-screenshot
+bin/spicy