aboutsummaryrefslogtreecommitdiff
path: root/deskutils/spice-gtk
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-03-15 17:06:36 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-03-15 17:06:36 +0000
commit762d4558957ff45c6221627e2a945a5bfc7987b2 (patch)
tree798726403c01aeb35c5377b46310c785f8152964 /deskutils/spice-gtk
parentec0d7fe6c2e260f02409eaa527f3d468b2ff6c26 (diff)
downloadports-762d4558957ff45c6221627e2a945a5bfc7987b2.tar.gz
ports-762d4558957ff45c6221627e2a945a5bfc7987b2.zip
deskutils/spice-gtk: fix BUILD_DEPENDS when GSTREAMER is off
The deskutils/spice-gtk port adds 'python' to USES only when SPICE_SLAVE is defined. However, it unconditionally adds python dependencies to BUILD_DEPENDS and uses PYTHON_PKGNAMEPREFIX that's defined via USES=python, and that looks like a bug. However, when GSTREAMER option is enabled (that's the default), Mk/bsd.gstreamer.mk sets PYTHON_PKGNAMEPREFIX to 'py*-' if it's not defined, so the bug is not triggered with the default options set, but fails when GSTREAMER is disabled. Fix this by unconditionally adding 'python' to USES. Approved by: Oleg Ginzburg (maintainer, via email)
Notes
Notes: svn path=/head/; revision=411194
Diffstat (limited to 'deskutils/spice-gtk')
-rw-r--r--deskutils/spice-gtk/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/deskutils/spice-gtk/Makefile b/deskutils/spice-gtk/Makefile
index e84d676abc79..637155101985 100644
--- a/deskutils/spice-gtk/Makefile
+++ b/deskutils/spice-gtk/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
USE_XORG= pixman
USE_GNOME= gnomeprefix gtk20 gtk30 intltool introspection:build
-USES= cpe gmake jpeg libtool pkgconfig tar:bzip2 pathfix
+USES= cpe gmake jpeg libtool pkgconfig tar:bzip2 pathfix python
CPE_VENDOR= redhat
BUILD_DEPENDS= spice-protocol>=0.12.10:${PORTSDIR}/devel/spice-protocol \
@@ -27,7 +27,6 @@ BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gtk2>=0:${PORTSDIR}/x11-toolkits/py-gtk2
CONFIGURE_ARGS+= --with-python
PLIST_FILES+= %%PYTHON_SITELIBDIR%%/SpiceClientGtk.so
-USES+= python
.endif
CONFIGURE_ENV+= SSL_CFLAGS=-I${OPENSSLINC} \