aboutsummaryrefslogtreecommitdiff
path: root/deskutils/taskcoach/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2013-11-18 06:16:26 +0000
committerKevin Lo <kevlo@FreeBSD.org>2013-11-18 06:16:26 +0000
commit7cf614fbf3de9b00ca7c28d46f6f0be1be3ec714 (patch)
tree44eda2b569756e0bcba57bda066b6302d96db84c /deskutils/taskcoach/Makefile
parent0fdb74f6ac06cce1f737195b62b68bc37f53f860 (diff)
Notes
Diffstat (limited to 'deskutils/taskcoach/Makefile')
-rw-r--r--deskutils/taskcoach/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/deskutils/taskcoach/Makefile b/deskutils/taskcoach/Makefile
index b42a406934fb..b6d164af5212 100644
--- a/deskutils/taskcoach/Makefile
+++ b/deskutils/taskcoach/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= taskcoach
-PORTVERSION= 1.3.31
-PORTREVISION= 1
+PORTVERSION= 1.3.33
CATEGORIES= deskutils python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Release-${PORTVERSION}
DISTNAME= TaskCoach-${PORTVERSION}
@@ -21,15 +20,15 @@ USE_WX= 2.8
WX_COMPS= python:lib
WX_UNICODE= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|taskcoach.py|taskcoach|' \
- ${WRKSRC}/build.in/fedora/taskcoach.desktop
+ ${WRKSRC}/build.in/linux_common/taskcoach.desktop
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/taskcoach.py ${PREFIX}/bin/taskcoach
- @${INSTALL_DATA} ${WRKSRC}/build.in/fedora/taskcoach.desktop \
- ${PREFIX}/share/applications/
+ ${INSTALL_SCRIPT} ${WRKSRC}/taskcoach.py \
+ ${STAGEDIR}${PREFIX}/bin/taskcoach
+ @${INSTALL_DATA} ${WRKSRC}/build.in/linux_common/taskcoach.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications/
@${INSTALL_DATA} ${WRKSRC}/icons.in/taskcoach.png \
- ${PREFIX}/share/pixmaps
+ ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>