aboutsummaryrefslogtreecommitdiff
path: root/deskutils/teapot
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-29 09:01:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-29 09:01:48 +0000
commit6387eaca39918d41eee9c59e5b32376302476b11 (patch)
tree673951e90cafe701cd45866613f18e3e724df200 /deskutils/teapot
parenta74dfcae3a0ab62c10c82945d70ccd664aebcc8a (diff)
downloadports-6387eaca39918d41eee9c59e5b32376302476b11.tar.gz
ports-6387eaca39918d41eee9c59e5b32376302476b11.zip
Notes
Diffstat (limited to 'deskutils/teapot')
-rw-r--r--deskutils/teapot/Makefile6
-rw-r--r--deskutils/teapot/files/patch-CMakeLists.txt8
2 files changed, 8 insertions, 6 deletions
diff --git a/deskutils/teapot/Makefile b/deskutils/teapot/Makefile
index 108a9237945b..91e2bf7a78cb 100644
--- a/deskutils/teapot/Makefile
+++ b/deskutils/teapot/Makefile
@@ -12,7 +12,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= ports@FreeBSD.org
COMMENT= Full-screen curses based spread sheet program
-LICENSE= GPLv3
+LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake ncurses
@@ -27,9 +27,11 @@ post-patch:
@${REINPLACE_CMD} -e 's|share/man/man1|man/man1|g' \
${WRKSRC}/CMakeLists.txt
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC_DOCS} && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
diff --git a/deskutils/teapot/files/patch-CMakeLists.txt b/deskutils/teapot/files/patch-CMakeLists.txt
index a67cce2ffac2..4fda3475c9d1 100644
--- a/deskutils/teapot/files/patch-CMakeLists.txt
+++ b/deskutils/teapot/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt 2012-02-06 06:30:53.000000000 -0500
-+++ CMakeLists.txt 2012-02-25 18:06:26.000000000 -0500
-@@ -5,7 +5,7 @@
+--- CMakeLists.txt.orig 2012-02-06 11:30:53 UTC
++++ CMakeLists.txt
+@@ -5,7 +5,7 @@ set(Teapot_VERSION_MAJOR 2)
set(Teapot_VERSION_MINOR 3)
set(Teapot_VERSION_PATCH 0)
@@ -9,7 +9,7 @@
option(ENABLE_UTF8 "Enable UTF-8 support" ON)
option(ENABLE_STATIC "Link FLTK statically" OFF)
-@@ -40,30 +40,6 @@
+@@ -40,30 +40,6 @@ if (CURSES_FOUND)
install(TARGETS teapot DESTINATION bin)
endif ()