aboutsummaryrefslogtreecommitdiff
path: root/deskutils/treeline
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-05-31 19:31:11 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-05-31 19:31:11 +0000
commitd5caf944f36c21d83c262162b2e256e27a12ba16 (patch)
tree1cde3448969d29020f3e27327c938f4d1917c820 /deskutils/treeline
parent97b7725f31a1c670f1821197b7ab55fa2084891a (diff)
downloadports-d5caf944f36c21d83c262162b2e256e27a12ba16.tar.gz
ports-d5caf944f36c21d83c262162b2e256e27a12ba16.zip
- Fix build by explicit stating sip as build dependency
- Remove pkg-install script, plugins directory is created in do-install target, no need to do this twice - Add LICENSE_FILE - Convert to USES=pyqt
Notes
Notes: svn path=/head/; revision=416214
Diffstat (limited to 'deskutils/treeline')
-rw-r--r--deskutils/treeline/Makefile12
-rw-r--r--deskutils/treeline/pkg-install5
2 files changed, 6 insertions, 11 deletions
diff --git a/deskutils/treeline/Makefile b/deskutils/treeline/Makefile
index 3aaa7d109f23..8e2fd14239f4 100644
--- a/deskutils/treeline/Makefile
+++ b/deskutils/treeline/Makefile
@@ -15,18 +15,18 @@ MAINTAINER= pawel@FreeBSD.org
COMMENT= Structured information storage program
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/doc/LICENSE
BUILD_DEPENDS= aspell:textproc/aspell
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-gui>=0:x11-toolkits/py-qt4-gui \
- ${PYTHON_PKGNAMEPREFIX}qt4-network>=0:net/py-qt4-network \
- aspell:textproc/aspell
+RUN_DEPENDS= aspell:textproc/aspell
-WRKSRC= ${WRKDIR}/TreeLine
-USE_QT4= # empty
-USES= python:2
+USES= python:2 pyqt:4
+USE_PYQT= gui network sip_build
NO_BUILD= yes
NO_ARCH= yes
+WRKSRC= ${WRKDIR}/TreeLine
+
DESKTOP_ENTRIES= "TreeLine" "" "${DATADIR}/icons/tree/treeline.png" \
"${PORTNAME}" "Utility;" false
diff --git a/deskutils/treeline/pkg-install b/deskutils/treeline/pkg-install
deleted file mode 100644
index ce96cc637334..000000000000
--- a/deskutils/treeline/pkg-install
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" ]; then
- mkdir -p ${PKG_PREFIX}/lib/treeline/plugins
-fi