aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ultralist/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-11-12 14:20:20 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-11-12 14:20:20 +0000
commit661f7a27d14813ce9e785334fe5cc4e33fb0cf88 (patch)
tree3c0f8505d24682f803220fdc18ab640bffb62873 /deskutils/ultralist/Makefile
parent5bbabc4d0ab1abb33ed7032e9826fd7a95b89b32 (diff)
downloadports-661f7a27d14813ce9e785334fe5cc4e33fb0cf88.tar.gz
ports-661f7a27d14813ce9e785334fe5cc4e33fb0cf88.zip
deskutils/ultralist: Update to 1.6.3
ChangeLog: https://github.com/ultralist/ultralist/releases/1.6.3 PR: 251070 Submitted by: vulcan@wired.sh (maintainer) MFH: 2020Q4 (blanket, bugfix release)
Notes
Notes: svn path=/head/; revision=554964
Diffstat (limited to 'deskutils/ultralist/Makefile')
-rw-r--r--deskutils/ultralist/Makefile44
1 files changed, 41 insertions, 3 deletions
diff --git a/deskutils/ultralist/Makefile b/deskutils/ultralist/Makefile
index e9383df74185..833cd4cea032 100644
--- a/deskutils/ultralist/Makefile
+++ b/deskutils/ultralist/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ultralist
-DISTVERSION= 1.6.2
+DISTVERSION= 1.6.3
CATEGORIES= deskutils
MAINTAINER= vulcan@wired.sh
@@ -10,15 +10,53 @@ COMMENT= Simple, powerful, task management system for the command line
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= go
+USES= go:modules
USE_GITHUB= yes
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GH_TUPLE= cheynewallace:tabby:v1.1.0:cheynewallace_tabby/vendor/github.com/cheynewallace/tabby \
+ chzyer:readline:2972be24d48e:chzyer_readline/vendor/github.com/chzyer/readline \
+ davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
+ fatih:color:v1.9.0:fatih_color/vendor/github.com/fatih/color \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
+ go-ini:ini:v1.51.0:go_ini_ini/vendor/gopkg.in/ini.v1 \
+ go-yaml:yaml:9f266ea9e77c:go_yaml_yaml_1/vendor/gopkg.in/yaml.v3 \
+ go-yaml:yaml:v2.2.4:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ golang:sys:33540a1f6037:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
+ hashicorp:hcl:v1.0.0:hashicorp_hcl/vendor/github.com/hashicorp/hcl \
+ inconshreveable:mousetrap:v1.0.0:inconshreveable_mousetrap/vendor/github.com/inconshreveable/mousetrap \
+ jinzhu:copier:b57f9002281a:jinzhu_copier/vendor/github.com/jinzhu/copier \
+ juju:ansiterm:720a0952cc2a:juju_ansiterm/vendor/github.com/juju/ansiterm \
+ julienschmidt:httprouter:v1.3.0:julienschmidt_httprouter/vendor/github.com/julienschmidt/httprouter \
+ lunixbochs:vtclean:2d01aacdc34a:lunixbochs_vtclean/vendor/github.com/lunixbochs/vtclean \
+ magiconair:properties:v1.8.1:magiconair_properties/vendor/github.com/magiconair/properties \
+ manifoldco:promptui:v0.7.0:manifoldco_promptui/vendor/github.com/manifoldco/promptui \
+ mattn:go-colorable:v0.1.4:mattn_go_colorable/vendor/github.com/mattn/go-colorable \
+ mattn:go-isatty:v0.0.11:mattn_go_isatty/vendor/github.com/mattn/go-isatty \
+ mitchellh:mapstructure:v1.1.2:mitchellh_mapstructure/vendor/github.com/mitchellh/mapstructure \
+ myesui:uuid:v1.0.0:myesui_uuid/vendor/github.com/myesui/uuid \
+ pelletier:go-toml:v1.2.0:pelletier_go_toml/vendor/github.com/pelletier/go-toml \
+ pmezard:go-difflib:v1.0.0:pmezard_go_difflib/vendor/github.com/pmezard/go-difflib \
+ skratchdot:open-golang:eef842397966:skratchdot_open_golang/vendor/github.com/skratchdot/open-golang \
+ spf13:afero:v1.1.2:spf13_afero/vendor/github.com/spf13/afero \
+ spf13:cast:v1.3.0:spf13_cast/vendor/github.com/spf13/cast \
+ spf13:cobra:v1.0.0:spf13_cobra/vendor/github.com/spf13/cobra \
+ spf13:jwalterweatherman:v1.0.0:spf13_jwalterweatherman/vendor/github.com/spf13/jwalterweatherman \
+ spf13:pflag:v1.0.3:spf13_pflag/vendor/github.com/spf13/pflag \
+ spf13:viper:v1.7.0:spf13_viper/vendor/github.com/spf13/viper \
+ stretchr:testify:v1.2.2:stretchr_testify_1/vendor/gopkg.in/stretchr/testify.v1 \
+ stretchr:testify:v1.6.1:stretchr_testify/vendor/github.com/stretchr/testify \
+ subosito:gotenv:v1.2.0:subosito_gotenv/vendor/github.com/subosito/gotenv \
+ twinj:uuid:v1.0.0:twinj_uuid
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
+post-extract:
+ @${MKDIR} ${WRKSRC}/vendor/github.com/twinj
+ @${RLN} ${WRKSRC_myesui_uuid} ${WRKSRC}/vendor/github.com/twinj/uuid
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}