aboutsummaryrefslogtreecommitdiff
path: root/deskutils/wmpinboard
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2009-07-24 17:02:57 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2009-07-24 17:02:57 +0000
commit1b95b8c7b07758311ae9422824a197b7ea11c503 (patch)
treeefa0b1cd0f432ce24f0f0b783165bbf694961714 /deskutils/wmpinboard
parente76ce15096a1c9d137b86b1df44d7fcbac55b302 (diff)
downloadports-1b95b8c7b07758311ae9422824a197b7ea11c503.tar.gz
ports-1b95b8c7b07758311ae9422824a197b7ea11c503.zip
Fix execution on 64bit platforms
PR: 134474 Submitted by: Pavel Gorshkov
Notes
Notes: svn path=/head/; revision=238337
Diffstat (limited to 'deskutils/wmpinboard')
-rw-r--r--deskutils/wmpinboard/Makefile2
-rw-r--r--deskutils/wmpinboard/files/patch-xmisc.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/deskutils/wmpinboard/Makefile b/deskutils/wmpinboard/Makefile
index f77e77eb005c..24b5737cafc8 100644
--- a/deskutils/wmpinboard/Makefile
+++ b/deskutils/wmpinboard/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wmpinboard
PORTVERSION= 1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= deskutils afterstep windowmaker
MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
diff --git a/deskutils/wmpinboard/files/patch-xmisc.c b/deskutils/wmpinboard/files/patch-xmisc.c
new file mode 100644
index 000000000000..4987c8d2a19a
--- /dev/null
+++ b/deskutils/wmpinboard/files/patch-xmisc.c
@@ -0,0 +1,22 @@
+--- src/xmisc.c.orig 2009-05-27 17:03:25.000000000 +0400
++++ src/xmisc.c 2009-05-27 16:42:40.000000000 +0400
+@@ -204,7 +204,7 @@
+ return;
+ }
+
+- if (XGetIMValues(xim, XNQueryInputStyle, &xim_styles, 0) || !xim_styles) {
++ if (XGetIMValues(xim, XNQueryInputStyle, &xim_styles, NULL) || !xim_styles) {
+ XCloseIM(xim);
+ #ifdef DEBUG_IC
+ fprintf(stderr, "Input method doesn't support any style.\n");
+@@ -258,7 +258,7 @@
+ }
+
+ InputContext = XCreateIC(xim, XNInputStyle, input_style,
+- XNClientWindow, win, XNFocusWindow, win, 0);
++ XNClientWindow, win, XNFocusWindow, win, NULL);
+
+ if (!InputContext) {
+ XCloseIM(xim);
+
+