aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xneur
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-28 03:48:06 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-28 03:48:06 +0000
commit44b3b1b9153cc7accda4276b7992c1c9ed55733e (patch)
tree890d4dc017fbf1cb0cd2018de6d584efcecf2314 /deskutils/xneur
parent7d21b823cfc56df3e34e232ff1980629e08edc75 (diff)
downloadports-44b3b1b9153cc7accda4276b7992c1c9ed55733e.tar.gz
ports-44b3b1b9153cc7accda4276b7992c1c9ed55733e.zip
deskutils/xneur: only add -fnested-functions when using base GCC
This fixes build on powerpc64 elfv2, probably also other architectures that recently switched to clang.
Notes
Notes: svn path=/head/; revision=556476
Diffstat (limited to 'deskutils/xneur')
-rw-r--r--deskutils/xneur/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/deskutils/xneur/Makefile b/deskutils/xneur/Makefile
index 8caafe2ca26e..af4e42d20b1a 100644
--- a/deskutils/xneur/Makefile
+++ b/deskutils/xneur/Makefile
@@ -27,12 +27,6 @@ USE_XORG= xtst
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --libdir=${PREFIX}/lib/xneur --with-gtk=gtk2
-CFLAGS_mips= -fnested-functions
-CFLAGS_mips64= -fnested-functions
-CFLAGS_powerpc= -fnested-functions
-CFLAGS_powerpcspe= -fnested-functions
-CFLAGS_powerpc64= -fnested-functions
-CFLAGS_sparc64= -fnested-functions
USE_LDCONFIG= ${PREFIX}/lib/xneur ${PREFIX}/lib/xneur/xneur
INSTALLS_ICONS= yes
@@ -61,8 +55,14 @@ SOUND_USES= openal:al,alut
SOUND_CONFIGURE_ON= --with-sound=openal
SOUND_CONFIGURE_OFF= --with-sound=no
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_VERSION} == 42
+CFLAGS+= -fnested-functions
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,-Werror,,g; s,-ldl,,g' ${WRKSRC}/configure
@${MV} ${WRKSRC}/etc/xneurrc ${WRKSRC}/etc/xneurrc.sample
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>