aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xpad3
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2014-12-30 18:27:51 +0000
committerJason Helfman <jgh@FreeBSD.org>2014-12-30 18:27:51 +0000
commit2421d5f908ce8404385d96a8fe70c5c44412126b (patch)
tree2f8175732703b733c63270d10ee7c2a67490c90e /deskutils/xpad3
parent9b2c2e3349be2d70e2db0d2070e611d63780b9fc (diff)
downloadports-2421d5f908ce8404385d96a8fe70c5c44412126b.tar.gz
ports-2421d5f908ce8404385d96a8fe70c5c44412126b.zip
- renamed deskutils/xpad to deskutils/xpad3 in preparation for rename
of deskutils/xpad-current to deskutils/xpad
Notes
Notes: svn path=/head/; revision=375841
Diffstat (limited to 'deskutils/xpad3')
-rw-r--r--deskutils/xpad3/Makefile40
-rw-r--r--deskutils/xpad3/distinfo2
-rw-r--r--deskutils/xpad3/files/patch-src-xpad-pad.c11
-rw-r--r--deskutils/xpad3/pkg-descr17
-rw-r--r--deskutils/xpad3/pkg-plist26
5 files changed, 96 insertions, 0 deletions
diff --git a/deskutils/xpad3/Makefile b/deskutils/xpad3/Makefile
new file mode 100644
index 000000000000..d1e241c3d31c
--- /dev/null
+++ b/deskutils/xpad3/Makefile
@@ -0,0 +1,40 @@
+# Created by: Guillaume Paquet <amyfoub@gmail.com>
+# $FreeBSD$
+
+PORTNAME= xpad
+PORTVERSION= 3.1
+PORTREVISION= 8
+CATEGORIES= deskutils
+MASTER_SITES= http://launchpad.net/xpad/stable/${PORTVERSION}/+download/
+PKGNAMESUFFIX= 3
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Virtual note-pad system for your X11 desktop
+
+LICENSE= GPLv3
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+CONFLICTS_INSTALL= xpad-current-[0-9]*
+
+USE_XORG= x11 sm
+USE_GNOME= gtk20 intltool
+USES= pkgconfig gmake tar:bzip2
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+
+NLS_USES= gettext
+NLS_CPPFLAGS= ${CXXFLAGS} -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.options.mk>
+
+post-patch:
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|SUBDIRS = autopackage doc src images po|SUBDIRS = autopackage doc src images|' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/deskutils/xpad3/distinfo b/deskutils/xpad3/distinfo
new file mode 100644
index 000000000000..84771edc322e
--- /dev/null
+++ b/deskutils/xpad3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xpad-3.1.tar.bz2) = 5069c2d2edde431c4eca13bdd55de69e68d14cc3e9f047c080d39f91b7e9e879
+SIZE (xpad-3.1.tar.bz2) = 184838
diff --git a/deskutils/xpad3/files/patch-src-xpad-pad.c b/deskutils/xpad3/files/patch-src-xpad-pad.c
new file mode 100644
index 000000000000..90d9923f9d63
--- /dev/null
+++ b/deskutils/xpad3/files/patch-src-xpad-pad.c
@@ -0,0 +1,11 @@
+--- src/xpad-pad.c.orig 2010-06-05 15:18:08.000000000 +0200
++++ src/xpad-pad.c 2010-06-05 15:18:28.000000000 +0200
+@@ -274,7 +274,7 @@
+ "gravity", GDK_GRAVITY_STATIC, /* static gravity makes saving pad x,y work */
+ "skip-pager-hint", !xpad_settings_get_has_decorations (xpad_settings ()),
+ "skip-taskbar-hint", !xpad_settings_get_has_decorations (xpad_settings ()),
+- "type", GTK_WINDOW_TOPLEVEL,
++ /*"type", GTK_WINDOW_TOPLEVEL,*/
+ "type-hint", GDK_WINDOW_TYPE_HINT_NORMAL,
+ "window-position", GTK_WIN_POS_MOUSE,
+ "child", vbox,
diff --git a/deskutils/xpad3/pkg-descr b/deskutils/xpad3/pkg-descr
new file mode 100644
index 000000000000..4298030e183d
--- /dev/null
+++ b/deskutils/xpad3/pkg-descr
@@ -0,0 +1,17 @@
+xpad is a sticky note application written using GTK+ 2.0 that strives to be
+simple, fault-tolerant, and customizable. xpad consists of independent pad
+windows; each is basically a text box in which notes can be written. Despite
+being called xpad, all that is needed to run or compile it is the GTK+ 2.0
+libraries. Here is a list of major features in the current xpad stable
+release:
+
+ * GTK+ 2.0 powered text view.
+ * Fault tolerant. All information is kept on the hard drive, not memory.
+ * xpad is very customizable. The color scheme (text, background, and window
+ borders) and the font can be changed.
+ * A customizable toolbar puts the most frequently used commands at your
+ fingertips.
+ * Support for the X session management protocol.
+ * Support for the www.freedesktop.org system tray proposal.
+
+WWW: http://xpad.sourceforge.net/
diff --git a/deskutils/xpad3/pkg-plist b/deskutils/xpad3/pkg-plist
new file mode 100644
index 000000000000..01f3ab30bf06
--- /dev/null
+++ b/deskutils/xpad3/pkg-plist
@@ -0,0 +1,26 @@
+bin/xpad
+man/man1/xpad.1.gz
+share/applications/xpad.desktop
+share/icons/hicolor/scalable/apps/xpad.svg
+%%NLS%%share/locale/af/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xpad.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xpad.mo