aboutsummaryrefslogtreecommitdiff
path: root/deskutils/xpostit
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>1996-05-06 11:45:42 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>1996-05-06 11:45:42 +0000
commitecc7ab71cabe4ba1a4237cef5e531e646a362cf8 (patch)
tree2f5a0226969935a6e72cc282c6683262f50a6a96 /deskutils/xpostit
parentad350a399e87a6d35b4f47e1291273f744d3f48f (diff)
downloadports-ecc7ab71cabe4ba1a4237cef5e531e646a362cf8.tar.gz
ports-ecc7ab71cabe4ba1a4237cef5e531e646a362cf8.zip
XPostIt -- Stick small Post-it notes onto your X11 screen.
Notes
Notes: svn path=/head/; revision=3070
Diffstat (limited to 'deskutils/xpostit')
-rw-r--r--deskutils/xpostit/Makefile24
-rw-r--r--deskutils/xpostit/distinfo1
-rw-r--r--deskutils/xpostit/files/patch-aa40
-rw-r--r--deskutils/xpostit/pkg-comment1
-rw-r--r--deskutils/xpostit/pkg-descr23
-rw-r--r--deskutils/xpostit/pkg-plist4
6 files changed, 93 insertions, 0 deletions
diff --git a/deskutils/xpostit/Makefile b/deskutils/xpostit/Makefile
new file mode 100644
index 000000000000..acd6bd048003
--- /dev/null
+++ b/deskutils/xpostit/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: xpostit
+# Version required: 3.3.1
+# Date created: 6 May 1996
+# Whom: joerg
+#
+# $Id$
+#
+
+DISTNAME= xpostit3.3.1
+EXTRACT_SUFX= .tar.Z
+WRKSRC= work/xpostit
+CATEGORIES+= x11
+#
+# Not all servers archie could find actually still have it. Alas, some
+# servers only have the comp.sources.x version, with its distfile named
+# `part01.gz'.
+#
+MASTER_SITES= ftp://rs104.hrz.th-darmstadt.de/pub/X11/R5contrib/
+
+MAINTAINER= joerg@FreeBSD.ORG
+
+USE_IMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/xpostit/distinfo b/deskutils/xpostit/distinfo
new file mode 100644
index 000000000000..170bad58a8a4
--- /dev/null
+++ b/deskutils/xpostit/distinfo
@@ -0,0 +1 @@
+MD5 (xpostit3.3.1.tar.Z) = 9fa0b297118054ea3242e0ae00cf2345
diff --git a/deskutils/xpostit/files/patch-aa b/deskutils/xpostit/files/patch-aa
new file mode 100644
index 000000000000..3a45504b0389
--- /dev/null
+++ b/deskutils/xpostit/files/patch-aa
@@ -0,0 +1,40 @@
+--- plaid.c.orig Thu Dec 10 17:40:26 1992
++++ plaid.c Mon May 6 13:23:17 1996
+@@ -60,6 +60,7 @@
+ {
+ Arg args[4];
+ register int nargs;
++ Dimension width, height;
+
+ /*
+ * Create the plaid widget.
+@@ -78,20 +79,22 @@
+ * Get the width and height of the widget.
+ */
+ nargs = 0;
+- SetArg(XtNwidth, NULL);
+- SetArg(XtNheight, NULL);
++ SetArg(XtNwidth, &width);
++ SetArg(XtNheight, &height);
+ XtGetValues(plaidwidget, args, nargs);
+
+ /*
+ * If the user didn't set them, then we
+ * should set them to the defaults.
+ */
+- if ((args[0].value == 0) || (args[1].value == 0)) {
+- if (args[0].value == 0)
+- XtSetArg(args[0], XtNwidth, DefaultPlaidWidth);
++ if (width == 0 || height == 0) {
++ nargs = 0;
+
+- if (args[1].value == 0)
+- XtSetArg(args[1], XtNheight, DefaultPlaidHeight);
++ if (width == 0)
++ SetArg(XtNwidth, DefaultPlaidWidth);
++
++ if (height == 0)
++ SetArg(XtNheight, DefaultPlaidHeight);
+
+ XtSetValues(plaidwidget, args, nargs);
+ }
diff --git a/deskutils/xpostit/pkg-comment b/deskutils/xpostit/pkg-comment
new file mode 100644
index 000000000000..9e9fe4516ed2
--- /dev/null
+++ b/deskutils/xpostit/pkg-comment
@@ -0,0 +1 @@
+PostIt (R) messages onto your X11 screen
diff --git a/deskutils/xpostit/pkg-descr b/deskutils/xpostit/pkg-descr
new file mode 100644
index 000000000000..d8fe3a613407
--- /dev/null
+++ b/deskutils/xpostit/pkg-descr
@@ -0,0 +1,23 @@
+Copyright 1991 by David A. Curry
+
+Permission to use, copy, modify, distribute, and sell this software and its
+documentation for any purpose is hereby granted without fee, provided that
+the above copyright notice appear in all copies and that both that copyright
+notice and this permission notice appear in supporting documentation. The
+author makes no representations about the suitability of this software for
+any purpose. It is provided "as is" without express or implied warranty.
+
+------------------------------------------------------------------------
+
+This is XPostIt Version 3.3.1 for X11 Releases 4 and 5. XPostIt allows
+you to create small notes to yourself in windows on the screen, and save
+them in disk files. This is generally neater than having numerous real
+Post-it notes stuck all around the edges of your monitor.
+
+------------------------------------------------------------------------
+
+Dave Curry
+Purdue University
+Engineering Computer Network
+West Lafayette, IN 47907
+davy@ecn.purdue.edu
diff --git a/deskutils/xpostit/pkg-plist b/deskutils/xpostit/pkg-plist
new file mode 100644
index 000000000000..fccb2d5c7457
--- /dev/null
+++ b/deskutils/xpostit/pkg-plist
@@ -0,0 +1,4 @@
+bin/xpostit
+lib/X11/app-defaults/XPostit
+lib/X11/app-defaults/XPostit-color
+man/man1/xpostit.1.gz