aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ydotool
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-04-17 16:39:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-04-17 16:39:17 +0000
commitce739d744c6478297df4158fb8c4bd98562950a7 (patch)
tree3480095ea3701593f17699f6d169e33169b24781 /deskutils/ydotool
parent1ea936055b7b8818169d3e5b9c24f33886905668 (diff)
downloadports-ce739d744c6478297df4158fb8c4bd98562950a7.tar.gz
ports-ce739d744c6478297df4158fb8c4bd98562950a7.zip
New port deskutils/ydotool
Generic command-line automation tool (no X!) Allows to emulate keyboard input or mouse activity WWW: https://github.com/ReimuNotMoe/ydotool For now no rc script provided for ydotoold until I figure out a sane way to handle it in a generic way
Notes
Notes: svn path=/head/; revision=531951
Diffstat (limited to 'deskutils/ydotool')
-rw-r--r--deskutils/ydotool/Makefile35
-rw-r--r--deskutils/ydotool/distinfo3
-rw-r--r--deskutils/ydotool/files/patch-CMakeLists.txt42
-rw-r--r--deskutils/ydotool/pkg-descr5
4 files changed, 85 insertions, 0 deletions
diff --git a/deskutils/ydotool/Makefile b/deskutils/ydotool/Makefile
new file mode 100644
index 000000000000..5275bd7521b2
--- /dev/null
+++ b/deskutils/ydotool/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= ydotool
+PORTVERSION= 0.1.8
+DISTVERSIONPREFIX= v
+CATEGORIES= deskutils
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Generic command-line automation tool (no X!)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/uinput.h:devel/evdev-proto
+LIB_DEPENDS= libepoll-shim.so:devel/libepoll-shim \
+ libuInputPlus.so:devel/libuInputPlus \
+ libboost_program_options.so:devel/boost-libs \
+ libevdevPlus.so:devel/libevdevPlus
+
+USES= cmake localbase
+
+CXXFLAGS+= -I${LOCALBASE}/include/libepoll-shim
+LDFLAGS+= -L${LOCALBASE}/lib -lepoll-shim
+
+USE_GITHUB= yes
+GH_ACCOUNT= ReimuNotMoe
+
+PLIST_FILES= bin/ydotool \
+ bin/ydotoold \
+ lib/libydotool.so \
+ lib/libydotool.so.0
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/ydotool/distinfo b/deskutils/ydotool/distinfo
new file mode 100644
index 000000000000..2708252bc729
--- /dev/null
+++ b/deskutils/ydotool/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1587107905
+SHA256 (ReimuNotMoe-ydotool-v0.1.8_GH0.tar.gz) = 6ebc4ede0a11aa7ced6b52637a4a59cc1528b4c5ed54478d38f0248a40b40a07
+SIZE (ReimuNotMoe-ydotool-v0.1.8_GH0.tar.gz) = 13362
diff --git a/deskutils/ydotool/files/patch-CMakeLists.txt b/deskutils/ydotool/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..6fc6edb7fca7
--- /dev/null
+++ b/deskutils/ydotool/files/patch-CMakeLists.txt
@@ -0,0 +1,42 @@
+--- CMakeLists.txt.orig 2019-10-01 17:22:23 UTC
++++ CMakeLists.txt
+@@ -47,10 +47,12 @@ set(SOURCE_FILES_CLIENT
+
+ add_library(ydotool_library SHARED ${SOURCE_FILES_LIBRARY})
+ set_target_properties(ydotool_library PROPERTIES OUTPUT_NAME ydotool)
+-add_library(ydotool_library_static STATIC ${SOURCE_FILES_LIBRARY})
+-set_target_properties(ydotool_library_static PROPERTIES OUTPUT_NAME ydotool)
+-target_link_libraries(ydotool_library dl boost_program_options uInputPlus evdevPlus)
+-target_link_libraries(ydotool_library_static dl boost_program_options uInputPlus evdevPlus)
++set_target_properties(ydotool_library PROPERTIES VERSION ${PROJECT_VERSION})
++set_target_properties(ydotool_library PROPERTIES VERSION ${CPACK_PACKAGE_VERSION_MAJOR})
++#add_library(ydotool_library_static STATIC ${SOURCE_FILES_LIBRARY})
++#set_target_properties(ydotool_library_static PROPERTIES OUTPUT_NAME ydotool)
++#target_link_libraries(ydotool_library dl boost_program_options uInputPlus evdevPlus)
++#target_link_libraries(ydotool_library_static dl boost_program_options uInputPlus evdevPlus)
+
+ link_libraries(-L.)
+ add_executable(ydotoold ${SOURCE_FILES_DAEMON})
+@@ -60,9 +62,9 @@ add_executable(ydotool_client ${SOURCE_FILES_CLIENT})
+ target_link_libraries(ydotool_client ydotool_library boost_program_options pthread uInputPlus evdevPlus)
+ set_target_properties(ydotool_client PROPERTIES OUTPUT_NAME ydotool)
+
+-add_executable(ydotool_client_static ${SOURCE_FILES_CLIENT})
+-target_link_libraries(ydotool_client_static ydotool_library_static boost_program_options pthread uInputPlus evdevPlus -static)
+-set_target_properties(ydotool_client_static PROPERTIES OUTPUT_NAME ydotool_static)
++#add_executable(ydotool_client_static ${SOURCE_FILES_CLIENT})
++#target_link_libraries(ydotool_client_static ydotool_library_static boost_program_options pthread uInputPlus evdevPlus -static)
++#set_target_properties(ydotool_client_static PROPERTIES OUTPUT_NAME ydotool_static)
+
+ #add_library(mousemove SHARED Tools/MouseMove/MouseMove.hpp Tools/MouseMove/MouseMove.cpp)
+ #target_link_libraries(mousemove ydotool_library boost_program_options uInputPlus evdevPlus)
+@@ -80,6 +82,6 @@ set_target_properties(ydotool_client_static PROPERTIES
+ #target_link_libraries(recorder ydotool_library boost_program_options uInputPlus evdevPlus)
+
+
+-install(TARGETS ydotool_library ydotool_library_static DESTINATION lib)
++install(TARGETS ydotool_library DESTINATION lib)
+ #install(TARGETS mousemove key click type recorder DESTINATION lib/ydotool)
+-install(TARGETS ydotoold ydotool_client DESTINATION bin)
+\ No newline at end of file
++install(TARGETS ydotoold ydotool_client DESTINATION bin)
diff --git a/deskutils/ydotool/pkg-descr b/deskutils/ydotool/pkg-descr
new file mode 100644
index 000000000000..ca471566c3cd
--- /dev/null
+++ b/deskutils/ydotool/pkg-descr
@@ -0,0 +1,5 @@
+Generic command-line automation tool (no X!)
+
+Allows to emulate keyboard input or mouse activity
+
+WWW: https://github.com/ReimuNotMoe/ydotool