aboutsummaryrefslogtreecommitdiff
path: root/deskutils/zim
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2017-05-08 20:10:24 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2017-05-08 20:10:24 +0000
commitc1cc1d7639ab1d695ccba1af9a3e25764f4ad350 (patch)
tree4f0ff4e3dddc9da8177d9de70cc763e297837967 /deskutils/zim
parent6191007be63ddbe88836b9aa41359163a571a2da (diff)
downloadports-c1cc1d7639ab1d695ccba1af9a3e25764f4ad350.tar.gz
ports-c1cc1d7639ab1d695ccba1af9a3e25764f4ad350.zip
Notes
Diffstat (limited to 'deskutils/zim')
-rw-r--r--deskutils/zim/Makefile9
-rw-r--r--deskutils/zim/distinfo5
-rw-r--r--deskutils/zim/files/patch-zim_newfs_____init____.py17
3 files changed, 23 insertions, 8 deletions
diff --git a/deskutils/zim/Makefile b/deskutils/zim/Makefile
index e73892d60164..87f9274c4d85 100644
--- a/deskutils/zim/Makefile
+++ b/deskutils/zim/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= zim
-PORTVERSION= 0.65
+PORTVERSION= 0.66
CATEGORIES= deskutils python
MASTER_SITES= http://www.zim-wiki.org/downloads/
@@ -12,13 +12,13 @@ COMMENT= Desktop wiki editor
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xdg>0:devel/py-xdg \
xdg-open:devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
NO_ARCH= yes
-
-USES= desktop-file-utils gettext python:2 shared-mime-info
+USES= desktop-file-utils gettext python:-2.7 shared-mime-info
USE_GNOME= pygtk2
USE_PYTHON= autoplist distutils
INSTALLS_ICONS= yes
@@ -48,8 +48,5 @@ post-patch:
s|share/man|man| ; \
/.skip_xdg_cmd = /s|0|1|' \
${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e \
- 's|decode('utf-8')|decode('utf-8','replace')|g' \
- ${WRKSRC}/zim/utils.py
.include <bsd.port.mk>
diff --git a/deskutils/zim/distinfo b/deskutils/zim/distinfo
index 8467a9bee266..dd0ab9e3ff07 100644
--- a/deskutils/zim/distinfo
+++ b/deskutils/zim/distinfo
@@ -1,2 +1,3 @@
-SHA256 (zim-0.65.tar.gz) = 5442f3334395a2beafc5b9a2bbec2e53e38270d4bad696b5c4053dd51dc1ed96
-SIZE (zim-0.65.tar.gz) = 1899614
+TIMESTAMP = 1494271021
+SHA256 (zim-0.66.tar.gz) = e8b53948097f211972713252f3a89b2957e3a63f55eb53587e2474dfc4cbf6c4
+SIZE (zim-0.66.tar.gz) = 2020216
diff --git a/deskutils/zim/files/patch-zim_newfs_____init____.py b/deskutils/zim/files/patch-zim_newfs_____init____.py
new file mode 100644
index 000000000000..c5d176eb153b
--- /dev/null
+++ b/deskutils/zim/files/patch-zim_newfs_____init____.py
@@ -0,0 +1,17 @@
+--- zim/newfs/__init__.py.orig 2017-05-08 19:57:42 UTC
++++ zim/newfs/__init__.py
+@@ -6,12 +6,14 @@
+
+ import sys
+ import os
++import logging
+
+ FS_CASE_SENSITIVE = (os.name != 'nt') #: file system case-sensitive yes or no
+
+ FS_SUPPORT_NON_LOCAL_FILE_SHARES = (os.name == 'nt') #: Support \\host\share paths yes or no
+
+ FS_ENCODING = sys.getfilesystemencoding() #: file system encoding for paths
++logger = logging.getLogger('zim.newfs')
+ if FS_ENCODING.upper() in (
+ 'ASCII', 'US-ASCII', 'ANSI_X3.4-1968', 'ISO646-US', # some aliases for ascii
+ 'LATIN1', 'ISO-8859-1', 'ISO_8859-1', 'ISO_8859-1:1987', # aliases for latin1