aboutsummaryrefslogtreecommitdiff
path: root/deskutils/znotes/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-08 15:09:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-08 15:09:59 +0000
commit56baf8d0ab2461986a233cf5cd48e1ea0bc31ed6 (patch)
tree6e4e9739dbc74d7610a213d9603db785414e11d0 /deskutils/znotes/Makefile
parent9285f749d9735bbd0b65f7b28a9c8e039bba365b (diff)
downloadports-56baf8d0ab2461986a233cf5cd48e1ea0bc31ed6.tar.gz
ports-56baf8d0ab2461986a233cf5cd48e1ea0bc31ed6.zip
Notes
Diffstat (limited to 'deskutils/znotes/Makefile')
-rw-r--r--deskutils/znotes/Makefile26
1 files changed, 21 insertions, 5 deletions
diff --git a/deskutils/znotes/Makefile b/deskutils/znotes/Makefile
index 71dc767c0471..392ad0eadc7f 100644
--- a/deskutils/znotes/Makefile
+++ b/deskutils/znotes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= znotes
-PORTVERSION= 0.3.9
+PORTVERSION= 0.4.0
CATEGORIES= deskutils
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -22,18 +22,34 @@ DESKTOP_ENTRIES="zNotes" "Simple notes" \
"${PREFIX}/share/pixmaps/${PORTNAME}.png" "${PORTNAME}" \
"Utility;TextEditor;Qt;" ${FALSE}
+OPTIONS= NLS "Build with NLS support" on
+
PLIST_FILES= bin/${PORTNAME} \
share/pixmaps/${PORTNAME}.png
post-patch:
@${REINPLACE_CMD} -e 's|lrelease|lrelease-qt4|g' \
- ${WRKSRC}/znotes.pro
+ ${WRKSRC}/${PORTNAME}.pro
+ @${REINPLACE_CMD} -i -e 's,QCoreApplication::applicationDirPath()+"/translations","${DATADIR}/translations",g' \
+ ${WRKSRC}/settings.cpp
+
+.include <bsd.port.pre.mk>
do-configure:
cd ${WRKSRC} && ${QMAKE} ${QMAKE_PRO}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/znotes.png ${PREFIX}/share/pixmaps/
-
-.include <bsd.port.mk>
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+
+.if defined(WITH_NLS)
+ ${MKDIR} ${DATADIR}/translations
+ ${INSTALL_DATA} ${WRKSRC}/translations/*.qm ${DATADIR}/translations
+PLIST_FILES+= share/${PORTNAME}/translations/${PORTNAME}_cs.qm \
+ share/${PORTNAME}/translations/${PORTNAME}_ru.qm
+PLIST_DIRS+= share/${PORTNAME}/translations \
+ share/${PORTNAME}
+.else
+.endif
+
+.include <bsd.port.post.mk>