aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:29:39 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-09-29 22:29:39 +0000
commit34156e93e84fe00711fac9dbf19e33534dc665f9 (patch)
tree644edaf7864f48d3652926a9f242a0f01e0cdf92 /deskutils
parentff71c9d91c68253cfaa8c6a682953afd5329b26f (diff)
downloadports-34156e93e84fe00711fac9dbf19e33534dc665f9.tar.gz
ports-34156e93e84fe00711fac9dbf19e33534dc665f9.zip
Go ports: cleanup, finish transition to USES=go started with r505321 (cat. audio-mail)
- Remove custom build/install targets left in place after r505321 - Switch to the new GO_TARGET tuple syntax introduced in r512001 - Switch to go:modules when upstream already uses them Reviewed by: tobik Approved by: araujo (mentor), portmgr (adamw) Differential Revision: https://reviews.freebsd.org/D21741
Notes
Notes: svn path=/head/; revision=513274
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/chart/Makefile21
-rw-r--r--deskutils/noti/Makefile8
-rw-r--r--deskutils/pet/Makefile1
3 files changed, 9 insertions, 21 deletions
diff --git a/deskutils/chart/Makefile b/deskutils/chart/Makefile
index 803419ebf403..e8fc3a74854c 100644
--- a/deskutils/chart/Makefile
+++ b/deskutils/chart/Makefile
@@ -14,27 +14,18 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go
USE_GITHUB= yes
-
-PORTDOCS= README.md
-OPTIONS_DEFINE= DOCS
-
GH_ACCOUNT= marianogappa
GH_SUBDIR= src/github.com/marianogappa/chart
-GH_TUPLE= Sirupsen:logrus:v1.0.5:logrus/src/github.com/Sirupsen/logrus \
- skratchdot:open-golang:75fb7ed:skratchdot/src/github.com/skratchdot/open-golang \
- golang:crypto:027cca1:crypto/src/golang.org/x/crypto \
- golang:sys:6c888cc:sys/src/golang.org/x/sys
+GH_TUPLE= Sirupsen:logrus:v1.0.5:logrus/vendor/github.com/Sirupsen/logrus \
+ skratchdot:open-golang:75fb7ed:skratchdot/vendor/github.com/skratchdot/open-golang \
+ golang:crypto:027cca1:crypto/vendor/golang.org/x/crypto \
+ golang:sys:6c888cc:sys/vendor/golang.org/x/sys
+PORTDOCS= README.md
PLIST_FILES= bin/chart
-do-build:
- ( cd ${WRKSRC}; \
- ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
- go build ${BUILD_FLAGS} -o bin/chart )
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/chart ${STAGEDIR}${PREFIX}/bin/chart
+OPTIONS_DEFINE= DOCS
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/deskutils/noti/Makefile b/deskutils/noti/Makefile
index 261637ea26c9..e5600cfca950 100644
--- a/deskutils/noti/Makefile
+++ b/deskutils/noti/Makefile
@@ -13,17 +13,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= notify-send:devel/libnotify
USES= go:modules
-USE_GITHUB= yes
+USE_GITHUB= yes
GH_ACCOUNT= variadico
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
-GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}/cmd/noti
+GO_TARGET= ./cmd/noti
PLIST_FILES= bin/noti man/man1/noti.1.gz man/man5/noti.yaml.5.gz
-do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/bin/noti ${STAGEDIR}${PREFIX}/bin
+post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/noti.1 ${STAGEDIR}${MANPREFIX}/man/man1/noti.1
${INSTALL_MAN} ${WRKSRC}/docs/man/noti.yaml.5 ${STAGEDIR}${MANPREFIX}/man/man5/noti.yaml.5
diff --git a/deskutils/pet/Makefile b/deskutils/pet/Makefile
index 1fcaa5be22c7..9b8c56f46973 100644
--- a/deskutils/pet/Makefile
+++ b/deskutils/pet/Makefile
@@ -37,7 +37,6 @@ GH_TUPLE= \
spf13:cobra:v0.0.3:spf13_cobra/vendor/github.com/spf13/cobra \
spf13:pflag:v1.0.1:spf13_pflag/vendor/github.com/spf13/pflag \
xanzy:go-gitlab:v0.10.5:xanzy_go_gitlab/vendor/github.com/xanzy/go-gitlab
-GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}