aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-09-12 12:37:24 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-09-12 12:37:24 +0000
commit3d66637d50372bf5c698b6959cdaa541f9d30c2d (patch)
treef4ede2836b6915f5a936467a747779cd02671a24 /deskutils
parent9f070e39171870dfa29634c6119f647f5cf01fe9 (diff)
downloadports-3d66637d50372bf5c698b6959cdaa541f9d30c2d.tar.gz
ports-3d66637d50372bf5c698b6959cdaa541f9d30c2d.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calcurse/Makefile15
-rw-r--r--deskutils/calcurse/distinfo4
-rw-r--r--deskutils/calcurse/files/patch-doc_Makefile.in53
3 files changed, 13 insertions, 59 deletions
diff --git a/deskutils/calcurse/Makefile b/deskutils/calcurse/Makefile
index ff99963c5002..90a1dd142936 100644
--- a/deskutils/calcurse/Makefile
+++ b/deskutils/calcurse/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= calcurse
-PORTVERSION= 2.9.1
+PORTVERSION= 2.9.2
CATEGORIES= deskutils
MASTER_SITES= http://calcurse.org/files/ \
ftp://ftp2.culot.org/culot/
@@ -18,6 +18,8 @@ LICENSE= BSD
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --without-asciidoc
+
MAN1= calcurse.1
.if defined(WITHOUT_NLS)
@@ -34,9 +36,14 @@ post-patch:
's|^docdir = .*|docdir = ${DOCSDIR}|' \
${WRKSRC}/doc/Makefile.in
.else
- ${REINPLACE_CMD} -e \
- '/install-data-am/ s|install-dist_docDATA||' \
- ${WRKSRC}/doc/Makefile.in
+CONFIGURE_ARGS+= --disable-docs
+.endif
+
+post-install:
+.if defined(NOPORTDOCS)
+.for file in ${MAN1}
+ @${INSTALL_MAN} ${WRKSRC}/doc/${file} ${MANPREFIX}/man/man1
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/deskutils/calcurse/distinfo b/deskutils/calcurse/distinfo
index b192529062e0..e8611aae302f 100644
--- a/deskutils/calcurse/distinfo
+++ b/deskutils/calcurse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (calcurse-2.9.1.tar.gz) = 72a1977d723d0fbbf22cf33500fc28a7d45f96d5feeb457beb597d2e5549343a
-SIZE (calcurse-2.9.1.tar.gz) = 512707
+SHA256 (calcurse-2.9.2.tar.gz) = e116c52fb82a051b38950bdbdb3f9df99fce2713c64d3eda1de236bacba28a55
+SIZE (calcurse-2.9.2.tar.gz) = 517071
diff --git a/deskutils/calcurse/files/patch-doc_Makefile.in b/deskutils/calcurse/files/patch-doc_Makefile.in
deleted file mode 100644
index 85cc64d88684..000000000000
--- a/deskutils/calcurse/files/patch-doc_Makefile.in
+++ /dev/null
@@ -1,53 +0,0 @@
---- doc/Makefile.in 2011-08-03 12:48:00.783627595 +0200
-+++ doc/Makefile.in 2011-08-03 12:48:38.390809562 +0200
-@@ -35,8 +35,8 @@ POST_UNINSTALL = :
- build_triplet = @build@
- host_triplet = @host@
- subdir = doc
--DIST_COMMON = $(am__dist_doc_DATA_DIST) $(dist_man_MANS) \
-- $(srcdir)/Makefile.am $(srcdir)/Makefile.in
-+DIST_COMMON = $(dist_doc_DATA) $(dist_man_MANS) $(srcdir)/Makefile.am \
-+ $(srcdir)/Makefile.in
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
- am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
- $(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
-@@ -76,7 +76,6 @@ man1dir = $(mandir)/man1
- am__installdirs = "$(DESTDIR)$(man1dir)" "$(DESTDIR)$(docdir)"
- NROFF = nroff
- MANS = $(dist_man_MANS)
--am__dist_doc_DATA_DIST = manual.html
- DATA = $(dist_doc_DATA)
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- A2X = @A2X@
-@@ -193,20 +192,20 @@ top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- AUTOMAKE_OPTIONS = foreign
--@HAVE_ASCIIDOC_TRUE@ASCIIDOC_ARGS = \
--@HAVE_ASCIIDOC_TRUE@ -n \
--@HAVE_ASCIIDOC_TRUE@ -a toc \
--@HAVE_ASCIIDOC_TRUE@ -a icons
-+ASCIIDOC_ARGS = \
-+ -n \
-+ -a toc \
-+ -a icons
-
--@HAVE_ASCIIDOC_TRUE@dist_doc_DATA = \
--@HAVE_ASCIIDOC_TRUE@ manual.html
-+A2X_ARGS = \
-+ -d manpage \
-+ -f manpage
-
--@HAVE_A2X_TRUE@A2X_ARGS = \
--@HAVE_A2X_TRUE@ -d manpage \
--@HAVE_A2X_TRUE@ -f manpage
-+dist_doc_DATA = \
-+ manual.html
-
--@HAVE_A2X_TRUE@dist_man_MANS = \
--@HAVE_A2X_TRUE@ calcurse.1
-+dist_man_MANS = \
-+ calcurse.1
-
- EXTRA_DIST = \
- manual.txt \