aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-11 19:33:09 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2022-12-11 19:35:47 +0000
commit42c12704a4c9c1e1da8a43c8d5671808aa897246 (patch)
tree59c84576883f536d05fbff1e7400d8072f2472af /deskutils
parentd5a8c7ca5954840b99c01aff42630441b90ae237 (diff)
downloadports-42c12704a4c9c1e1da8a43c8d5671808aa897246.tar.gz
ports-42c12704a4c9c1e1da8a43c8d5671808aa897246.zip
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/horde-groupware/Makefile6
-rw-r--r--deskutils/horde-kronolith/Makefile17
-rw-r--r--deskutils/horde-mnemo/Makefile6
-rw-r--r--deskutils/horde-nag/Makefile4
4 files changed, 20 insertions, 13 deletions
diff --git a/deskutils/horde-groupware/Makefile b/deskutils/horde-groupware/Makefile
index 69e6a3b11ab0..b31f1073c009 100644
--- a/deskutils/horde-groupware/Makefile
+++ b/deskutils/horde-groupware/Makefile
@@ -7,9 +7,9 @@ MAINTAINER= horde@FreeBSD.org
COMMENT= Horde Groupware
WWW= https://www.horde.org/apps/groupware/
-CONFLICTS= horde-webmail-[456]*
+IGNORE_WITH_PHP=80 81 82
-USES= horde cpe
+USES= horde cpe php
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
content \
@@ -22,4 +22,6 @@ USE_HORDE_RUN= Horde_Role \
trean \
turba
+CONFLICTS= horde-webmail-[456]*
+
.include <bsd.port.mk>
diff --git a/deskutils/horde-kronolith/Makefile b/deskutils/horde-kronolith/Makefile
index 6f1acd3f0cee..e33a624afd58 100644
--- a/deskutils/horde-kronolith/Makefile
+++ b/deskutils/horde-kronolith/Makefile
@@ -10,14 +10,11 @@ WWW= https://www.horde.org/apps/kronolith/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFAULT= DATE_HOLIDAYS TIMEOBJECTS
-OPTIONS_DEFINE= DATE_HOLIDAYS TIMEOBJECTS XMLWRITER
-DATE_HOLIDAYS_DESC= Depend on PEAR Date_Holidays
-TIMEOBJECTS_DESC= Depenbd on Horde timeobjects
-XMLWRITER_DESC= Depend on PHP xmlwriter extension
+IGNORE_WITH_PHP=80 81 82
+
+RUN_DEPENDS+= ${PEARDIR}/Date.php:devel/pear-Date@${PHP_FLAVOR}
USES= horde php cpe
-USE_PHP= gettext json simplexml
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
content \
@@ -51,11 +48,15 @@ USE_HORDE_RUN= Horde_Role \
Horde_Url \
Horde_Util \
Horde_View
+USE_PHP= gettext json simplexml
-RUN_DEPENDS+= ${PEARDIR}/Date.php:devel/pear-Date@${PHP_FLAVOR}
+OPTIONS_DEFINE= DATE_HOLIDAYS TIMEOBJECTS XMLWRITER
+OPTIONS_DEFAULT= DATE_HOLIDAYS TIMEOBJECTS
+DATE_HOLIDAYS_DESC= Depend on PEAR Date_Holidays
+TIMEOBJECTS_DESC= Depenbd on Horde timeobjects
+XMLWRITER_DESC= Depend on PHP xmlwriter extension
DATE_HOLIDAYS_RUN_DEPENDS= ${PEARDIR}/Date/Holidays.php:devel/pear-Date_Holidays@${PHP_FLAVOR}
-
TIMEOBJECTS_USE= HORDE_RUN=timeobjects
XMLWRITER_USE= PHP=xmlwriter
diff --git a/deskutils/horde-mnemo/Makefile b/deskutils/horde-mnemo/Makefile
index d60656780737..a941d0180619 100644
--- a/deskutils/horde-mnemo/Makefile
+++ b/deskutils/horde-mnemo/Makefile
@@ -11,8 +11,9 @@ WWW= https://www.horde.org/apps/mnemo/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+IGNORE_WITH_PHP=80 81 82
+
USES= horde php cpe
-USE_PHP= gettext
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
horde \
@@ -32,9 +33,10 @@ USE_HORDE_RUN= Horde_Role \
Horde_Support \
Horde_Text_Filter \
Horde_Util
+USE_PHP= gettext
-OPTIONS_DEFAULT= PDF
OPTIONS_DEFINE= PDF
+OPTIONS_DEFAULT= PDF
PDF_DESC= Support PDF generation
PDF_USE= HORDE_RUN=Horde_Pdf
diff --git a/deskutils/horde-nag/Makefile b/deskutils/horde-nag/Makefile
index ceaa2c2648cf..4f8c3d00fb71 100644
--- a/deskutils/horde-nag/Makefile
+++ b/deskutils/horde-nag/Makefile
@@ -10,8 +10,9 @@ WWW= https://www.horde.org/apps/nag/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+IGNORE_WITH_PHP=80 81 82
+
USES= horde php cpe
-USE_PHP= gettext
USE_HORDE_BUILD= Horde_Role
USE_HORDE_RUN= Horde_Role \
content \
@@ -37,5 +38,6 @@ USE_HORDE_RUN= Horde_Role \
Horde_Url \
Horde_Util \
Horde_View
+USE_PHP= gettext
.include <bsd.port.mk>