aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-07-31 16:28:54 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-07-31 16:28:54 +0000
commit4933e4626f9d55e6608f6e0d5cf59b86ff32d949 (patch)
tree7296154e98758baf020a6d3dc345a43402bf8d84 /deskutils
parent134ab3ff52596c19c98ba2a171c2e0579af7933c (diff)
downloadports-4933e4626f9d55e6608f6e0d5cf59b86ff32d949.tar.gz
ports-4933e4626f9d55e6608f6e0d5cf59b86ff32d949.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/calibre/Makefile11
-rw-r--r--deskutils/calibre/distinfo6
-rw-r--r--deskutils/calibre/files/patch-src_calibre_linux.py11
-rw-r--r--deskutils/calibre/pkg-plist40
4 files changed, 19 insertions, 49 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index 61dd9a0e76b8..d4d276a874f8 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 3.4.0
+PORTVERSION= 3.5.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
@@ -26,7 +26,8 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}cssutils>=1.0.1,1:www/py-cssutils \
${PYTHON_PKGNAMEPREFIX}apsw>=0:databases/py-apsw \
${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.3:devel/py-msgpack-python \
- ${PYTHON_PKGNAMEPREFIX}regex>=0:textproc/py-regex
+ ${PYTHON_PKGNAMEPREFIX}regex>=0:textproc/py-regex \
+ ${PYTHON_PKGNAMEPREFIX}html5-parser>=0.4.3:www/py-html5-parser
RUN_DEPENDS= xdg-open:devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}cssutils>=1.0.1,1:www/py-cssutils \
${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython \
@@ -43,13 +44,13 @@ RUN_DEPENDS= xdg-open:devel/xdg-utils \
${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.3:devel/py-msgpack-python \
${PYTHON_PKGNAMEPREFIX}regex>=0:textproc/py-regex \
${PYTHON_PKGNAMEPREFIX}chardet>=0:textproc/py-chardet \
+ ${PYTHON_PKGNAMEPREFIX}html5-parser>=0.4.3:www/py-html5-parser \
pdftohtml:graphics/poppler-utils
-USE_RC_SUBR= calibre
-EXTRACT_BEFORE_ARGS= -x -s '/^calibre/~-src/' -f
-
USES= desktop-file-utils gettext-runtime gnome localbase:ldflags pkgconfig \
python:2 pyqt:5 shared-mime-info shebangfix ssl tar:xz
+USE_RC_SUBR= calibre
+EXTRACT_BEFORE_ARGS= -x -s '/^calibre/~-src/' -f
SHEBANG_GLOB= *.sh *.py
python_OLD_CMD= "/usr/bin/env python2" /bin/python2 /usr/bin/python2 /usr/local/bin/python2
USE_PYQT= core gui network sip svg webkit widgets webkitwidgets xmlpatterns
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 3a3d9662e9b3..bfbfabe31451 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1500018001
-SHA256 (calibre-3.4.0.tar.xz) = 418590334174435fe11192ae4bcabf99a3bb017c9cb531cf2a248b7f90197071
-SIZE (calibre-3.4.0.tar.xz) = 36473372
+TIMESTAMP = 1501231218
+SHA256 (calibre-3.5.0.tar.xz) = bb13d96cbe24c6cc75f3affe750ff13005b2cc0dc3c4015ca69dee1f82df80aa
+SIZE (calibre-3.5.0.tar.xz) = 36347912
diff --git a/deskutils/calibre/files/patch-src_calibre_linux.py b/deskutils/calibre/files/patch-src_calibre_linux.py
index be17c814e954..5b10c7bdfd48 100644
--- a/deskutils/calibre/files/patch-src_calibre_linux.py
+++ b/deskutils/calibre/files/patch-src_calibre_linux.py
@@ -1,5 +1,14 @@
---- src/calibre/linux.py.orig 2017-06-16 04:00:12 UTC
+--- src/calibre/linux.py.orig 2017-07-28 04:07:52 UTC
+++ src/calibre/linux.py
+@@ -841,7 +841,7 @@ class PostInstall:
+ f.close()
+ des = ('calibre-gui.desktop', 'calibre-lrfviewer.desktop',
+ 'calibre-ebook-viewer.desktop', 'calibre-ebook-edit.desktop')
+- appdata = os.path.join(os.path.dirname(self.opts.staging_sharedir), 'metainfo')
++ appdata = os.path.join(os.path.dirname(self.opts.staging_sharedir), 'appdata')
+ if not os.path.exists(appdata):
+ try:
+ os.mkdir(appdata)
@@ -1008,7 +1008,7 @@ Name=E-book Viewer
GenericName=Viewer for E-books
Comment=Viewer for E-books in all the major formats
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 3bd83d213951..365b8fdb632e 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -1029,17 +1029,13 @@ lib/calibre/calibre/gui2/store/stores/mobileread/models.py
lib/calibre/calibre/gui2/store/stores/mobileread/store_dialog.py
lib/calibre/calibre/gui2/store/stores/mobileread/store_dialog_ui.py
lib/calibre/calibre/gui2/store/stores/nexto_plugin.py
-lib/calibre/calibre/gui2/store/stores/nook_uk_plugin.py
lib/calibre/calibre/gui2/store/stores/open_books_plugin.py
lib/calibre/calibre/gui2/store/stores/ozon_ru_plugin.py
lib/calibre/calibre/gui2/store/stores/pragmatic_bookshelf_plugin.py
lib/calibre/calibre/gui2/store/stores/publio_plugin.py
lib/calibre/calibre/gui2/store/stores/rw2010_plugin.py
lib/calibre/calibre/gui2/store/stores/smashwords_plugin.py
-lib/calibre/calibre/gui2/store/stores/sony_au_plugin.py
-lib/calibre/calibre/gui2/store/stores/sony_plugin.py
lib/calibre/calibre/gui2/store/stores/virtualo_plugin.py
-lib/calibre/calibre/gui2/store/stores/waterstones_uk_plugin.py
lib/calibre/calibre/gui2/store/stores/weightless_books_plugin.py
lib/calibre/calibre/gui2/store/stores/whsmith_uk_plugin.py
lib/calibre/calibre/gui2/store/stores/woblink_plugin.py
@@ -1396,42 +1392,6 @@ lib/calibre/css_selectors/select.py
lib/calibre/css_selectors/tests.py
lib/calibre/duktape/__init__.py
lib/calibre/duktape/tests.py
-lib/calibre/html5lib/__init__.py
-lib/calibre/html5lib/constants.py
-lib/calibre/html5lib/filters/__init__.py
-lib/calibre/html5lib/filters/_base.py
-lib/calibre/html5lib/filters/alphabeticalattributes.py
-lib/calibre/html5lib/filters/inject_meta_charset.py
-lib/calibre/html5lib/filters/lint.py
-lib/calibre/html5lib/filters/optionaltags.py
-lib/calibre/html5lib/filters/sanitizer.py
-lib/calibre/html5lib/filters/whitespace.py
-lib/calibre/html5lib/html5parser.py
-lib/calibre/html5lib/ihatexml.py
-lib/calibre/html5lib/inputstream.py
-lib/calibre/html5lib/sanitizer.py
-lib/calibre/html5lib/serializer/__init__.py
-lib/calibre/html5lib/serializer/htmlserializer.py
-lib/calibre/html5lib/tokenizer.py
-lib/calibre/html5lib/treeadapters/__init__.py
-lib/calibre/html5lib/treeadapters/sax.py
-lib/calibre/html5lib/treebuilders/__init__.py
-lib/calibre/html5lib/treebuilders/_base.py
-lib/calibre/html5lib/treebuilders/dom.py
-lib/calibre/html5lib/treebuilders/etree.py
-lib/calibre/html5lib/treebuilders/etree_lxml.py
-lib/calibre/html5lib/treewalkers/__init__.py
-lib/calibre/html5lib/treewalkers/_base.py
-lib/calibre/html5lib/treewalkers/dom.py
-lib/calibre/html5lib/treewalkers/etree.py
-lib/calibre/html5lib/treewalkers/genshistream.py
-lib/calibre/html5lib/treewalkers/lxmletree.py
-lib/calibre/html5lib/treewalkers/pulldom.py
-lib/calibre/html5lib/trie/__init__.py
-lib/calibre/html5lib/trie/_base.py
-lib/calibre/html5lib/trie/datrie.py
-lib/calibre/html5lib/trie/py.py
-lib/calibre/html5lib/utils.py
lib/calibre/lzma/__init__.py
lib/calibre/lzma/errors.py
lib/calibre/lzma/lzma1.py