aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-11-18 16:12:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-11-18 16:12:37 +0000
commit72fea002356b3f45185e4b5359b0be981cbd9178 (patch)
treeb3689b8e9ac0c3681a3f5531611ad672bdf4f353 /deskutils
parent6d8d7bb552549f4733d77dfd8c91c76b6997f322 (diff)
downloadports-72fea002356b3f45185e4b5359b0be981cbd9178.tar.gz
ports-72fea002356b3f45185e4b5359b0be981cbd9178.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/x-tile/Makefile24
-rw-r--r--deskutils/x-tile/distinfo2
-rw-r--r--deskutils/x-tile/pkg-descr7
-rw-r--r--deskutils/x-tile/pkg-plist48
5 files changed, 82 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 79721ead1e1a..7333f2a84f53 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -284,6 +284,7 @@
SUBDIR += when
SUBDIR += wmpinboard
SUBDIR += wyrd
+ SUBDIR += x-tile
SUBDIR += x026
SUBDIR += xcalendar
SUBDIR += xchm
diff --git a/deskutils/x-tile/Makefile b/deskutils/x-tile/Makefile
new file mode 100644
index 000000000000..782a5d733585
--- /dev/null
+++ b/deskutils/x-tile/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: x-tile
+# Date created: 2010-09-17
+# Whom: Pedro Garcia Freitas <sawp@sawp.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= x-tile
+PORTVERSION= 1.8.1
+CATEGORIES= deskutils devel python
+MASTER_SITES= http://www.sawp.com.br/share/xtile/
+
+MAINTAINER= sawp@sawp.com.br
+COMMENT= A GNOME applet to tile the opened windows
+
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_EGGINFO= X_Tile-${PYDISTUTILS_PKGVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
+
+post-patch:
+ @${REINPLACE_CMD} -i "" -e 's|: docfiles|: []|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/deskutils/x-tile/distinfo b/deskutils/x-tile/distinfo
new file mode 100644
index 000000000000..46246b08b767
--- /dev/null
+++ b/deskutils/x-tile/distinfo
@@ -0,0 +1,2 @@
+SHA256 (x-tile-1.8.1.tar.gz) = e828ad4b918d0bfddce1ddfd6648c297b91edfa65ab08ac5c8a402180f57483b
+SIZE (x-tile-1.8.1.tar.gz) = 171631
diff --git a/deskutils/x-tile/pkg-descr b/deskutils/x-tile/pkg-descr
new file mode 100644
index 000000000000..69d8eb47abd4
--- /dev/null
+++ b/deskutils/x-tile/pkg-descr
@@ -0,0 +1,7 @@
+X-tile is a gnome applet for your panel (or optionally a standalone
+application, working with kde as well) that allows you to select a number of
+windows and tile them in different ways. This is especially useful for
+comparing products in separate web pages, or for programmers refering to
+documentation as they are programming.
+
+WWW: http://www.giuspen.com/x-tile/
diff --git a/deskutils/x-tile/pkg-plist b/deskutils/x-tile/pkg-plist
new file mode 100644
index 000000000000..72f4fd0d2dc4
--- /dev/null
+++ b/deskutils/x-tile/pkg-plist
@@ -0,0 +1,48 @@
+bin/x-tile
+lib/bonobo/servers/x-tile.server
+share/applications/x-tile.desktop
+share/locale/de/LC_MESSAGES/x-tile.mo
+share/locale/es/LC_MESSAGES/x-tile.mo
+share/locale/fr/LC_MESSAGES/x-tile.mo
+share/locale/it/LC_MESSAGES/x-tile.mo
+share/locale/ja/LC_MESSAGES/x-tile.mo
+share/locale/pt_BR/LC_MESSAGES/x-tile.mo
+share/locale/ru/LC_MESSAGES/x-tile.mo
+share/locale/zh_TW/LC_MESSAGES/x-tile.mo
+share/pixmaps/x-tile.svg
+share/x-tile/glade/checkbox_checked.svg
+share/x-tile/glade/checkbox_unchecked.svg
+share/x-tile/glade/close-checked-windows.svg
+share/x-tile/glade/help-contents.svg
+share/x-tile/glade/maximize-checked-windows.svg
+share/x-tile/glade/reload-windows-list.svg
+share/x-tile/glade/tile-custom-1-exe.svg
+share/x-tile/glade/tile-custom-1-set.svg
+share/x-tile/glade/tile-custom-2-exe.svg
+share/x-tile/glade/tile-custom-2-set.svg
+share/x-tile/glade/tile-custom-exe.svg
+share/x-tile/glade/tile-custom-set.svg
+share/x-tile/glade/tile-horizontally.svg
+share/x-tile/glade/tile-quad.svg
+share/x-tile/glade/tile-triangle-down.svg
+share/x-tile/glade/tile-triangle-left.svg
+share/x-tile/glade/tile-triangle-right.svg
+share/x-tile/glade/tile-triangle-up.svg
+share/x-tile/glade/tile-vertically.svg
+share/x-tile/glade/toolbar.png
+share/x-tile/glade/unmaximize-checked-windows.svg
+share/x-tile/glade/vbuttonbox.png
+share/x-tile/glade/x-tile.glade
+share/x-tile/glade/x-tile.glade.h
+share/x-tile/glade/x-tile.svg
+share/x-tile/modules/cons.py
+share/x-tile/modules/core.py
+share/x-tile/modules/globs.py
+share/x-tile/modules/support.py
+share/x-tile/modules/tilings.py
+@dirrm share/x-tile/modules
+@dirrm share/x-tile/glade
+@dirrm share/x-tile
+@dirrmtry share/applications
+@dirrmtry lib/bonobo/servers
+@dirrmtry lib/bonobo