aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-12 13:46:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-12-12 13:46:44 +0000
commit81d238774d762a931f027498a43c9d426aaa5f92 (patch)
treeeb039b6f285a2336f6fa58b02c7d195d6fb6bddd /deskutils
parent891ef4d473b69f14b1f885f2a3598f66e9e6d691 (diff)
downloadports-81d238774d762a931f027498a43c9d426aaa5f92.tar.gz
ports-81d238774d762a931f027498a43c9d426aaa5f92.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/notecase/Makefile8
-rw-r--r--deskutils/notecase/distinfo6
-rw-r--r--deskutils/notecase/files/patch-Makefile33
3 files changed, 32 insertions, 15 deletions
diff --git a/deskutils/notecase/Makefile b/deskutils/notecase/Makefile
index 9724c74c921e..ede7ed10f2c7 100644
--- a/deskutils/notecase/Makefile
+++ b/deskutils/notecase/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= notecase
-PORTVERSION= 1.9.7
+PORTVERSION= 1.9.8
CATEGORIES= deskutils textproc
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}_src
@@ -15,7 +15,7 @@ MAINTAINER= ganael.laplanche@martymac.com
COMMENT= A hierarchical text notes manager
USE_GMAKE= yes
-USE_GNOME= gtk20 gnomevfs2 desktopfileutils pkgconfig
+USE_GNOME= gtk20 gtksourceview2 gnomevfs2 desktopfileutils pkgconfig
USE_GETTEXT= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -26,9 +26,9 @@ INSTALL_TARGET= install docinstall
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|prefix=/usr|prefix=${PREFIX}|' \
+ @${REINPLACE_CMD} -e 's|^prefix=.*|prefix=${PREFIX}|' \
${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|docsdir=|docsdir=${DOCSDIR}|' \
+ @${REINPLACE_CMD} -e 's|^docsdir=.*|docsdir=${DOCSDIR}|' \
${WRKSRC}/Makefile
post-install:
diff --git a/deskutils/notecase/distinfo b/deskutils/notecase/distinfo
index 4d7fadd05c8a..6c6808acab94 100644
--- a/deskutils/notecase/distinfo
+++ b/deskutils/notecase/distinfo
@@ -1,3 +1,3 @@
-MD5 (notecase-1.9.7_src.tar.gz) = e4f18591e87a9d119b1ff4f503ba6d20
-SHA256 (notecase-1.9.7_src.tar.gz) = 1993bb71a36f8e0b20bf78f25d826a3ea1dc0a007d3c6981890462dd91c42ae5
-SIZE (notecase-1.9.7_src.tar.gz) = 930981
+MD5 (notecase-1.9.8_src.tar.gz) = 9fe7d2db959d4c457d53313bb8faac35
+SHA256 (notecase-1.9.8_src.tar.gz) = 0b7e23ec97efd5cd4ada651ac93273f9e5ed2cfff027abfb4ae130039563b746
+SIZE (notecase-1.9.8_src.tar.gz) = 928579
diff --git a/deskutils/notecase/files/patch-Makefile b/deskutils/notecase/files/patch-Makefile
index 7ae44b4f69e5..65d49c627a03 100644
--- a/deskutils/notecase/files/patch-Makefile
+++ b/deskutils/notecase/files/patch-Makefile
@@ -1,14 +1,18 @@
---- Makefile.orig 2008-10-28 13:39:40.000000000 +0100
-+++ Makefile 2008-11-04 15:51:07.000000000 +0100
-@@ -13,6 +13,7 @@
- prefix=/usr
+--- Makefile.orig 2008-12-09 11:07:06.000000000 +0100
++++ Makefile 2008-12-12 09:15:50.220188108 +0100
+@@ -10,9 +10,10 @@
+ VERSION=1.9.8
+
+ # define install target dirs
+-prefix=/usr
++prefix=/usr/local
bindir=$(prefix)/bin
datadir=$(prefix)/share
-+docsdir=
++docsdir=/usr/local/share/doc/notecase
# define top of RPM build area
topdir=/usr/src/redhat
-@@ -592,18 +593,21 @@
+@@ -601,18 +602,21 @@
pouninstall:
@rm -vf $(DESTDIR)$(datadir)/locale/*/LC_MESSAGES/notecase.mo
@echo done uninstalling translations
@@ -22,7 +26,7 @@
#
# install application
#
- install: notecase$(EXE) poinstall
+ install: $(BIN)/notecase$(EXE) poinstall
install -d -m 755 $(DESTDIR)$(bindir)
- install -d -m 755 $(DESTDIR)$(datadir)/doc/notecase/
install -d -m 755 $(DESTDIR)$(datadir)/applications/
@@ -33,7 +37,20 @@
$(INSTALL) -m 644 docs/notecase.xml "$(DESTDIR)$(datadir)/mime/packages/notecase.xml"
$(Q)if [ -n "$(NOKIA_MAEMO_BUILD)" ]; then \
$(INSTALL) -m 644 docs/notecase.desktop "$(DESTDIR)$(datadir)/applications/hildon/notecase.desktop"; \
-@@ -800,7 +804,7 @@
+@@ -694,12 +698,6 @@
+ echo 'pkg-config error detected $(shell pkg-config --cflags $(LIBS))';\
+ exit 1;\
+ fi;
+- $(Q)if [ "$(HAVE_GTKSOURCEVIEW)" = "1" ]; then \
+- if [[ "$(TEST_SRCVIEW_VER)" < "2.4.1" ]]; then \
+- echo 'ERROR: gtksourceview package is too old ($(shell pkg-config --modversion gtksourceview-2.0))!';\
+- exit 1;\
+- fi;\
+- fi;
+ $(Q)echo 'Configuration: GNOME_VFS=$(HAVE_GNOME_VFS);GTKSOURCEVIEW=$(HAVE_GTKSOURCEVIEW);DEBUG=$(DEBUG);PROFILE=$(PROFILE);BYTE_ORDER=$(BYTE_ORDER);PLATFORM=$(PLATFORM)'
+ $(Q)$(SED) 's/^Version:.*/Version: $(VERSION)/' ./docs/notecase.spec
+ $(Q)$(SED) 's/^Source:.*/Source: $(archive)_src.tar.gz/' ./docs/notecase.spec
+@@ -820,7 +818,7 @@
#
# Note: first "make" command forces generating correct help file path in "config.h"
#