aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-10-03 21:08:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-10-03 21:08:30 +0000
commitb69470380bc261f686a8e0577027630dc898d854 (patch)
tree83afa82e781691a039ceaeeaf31ca57a374d2a2f /deskutils
parent342c774626811658f3c8ec19f198cb96aa833dcf (diff)
downloadports-b69470380bc261f686a8e0577027630dc898d854.tar.gz
ports-b69470380bc261f686a8e0577027630dc898d854.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/basket/Makefile26
-rw-r--r--deskutils/basket/distinfo1
-rw-r--r--deskutils/basket/files/patch-configaction.cpp19
-rw-r--r--deskutils/basket/files/patch-configaction.h13
-rw-r--r--deskutils/basket/pkg-descr6
-rw-r--r--deskutils/basket/pkg-plist12
7 files changed, 78 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 5046fa750b7f..e8e3c3ebb560 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -4,6 +4,7 @@
SUBDIR += abacus
SUBDIR += aspostit
SUBDIR += babytrans
+ SUBDIR += basket
SUBDIR += bigyear
SUBDIR += cal
SUBDIR += cbb
diff --git a/deskutils/basket/Makefile b/deskutils/basket/Makefile
new file mode 100644
index 000000000000..adabeeaa39a3
--- /dev/null
+++ b/deskutils/basket/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: basket
+# Date created: Mon Sep 8 19:32:42 CEST 2003
+# Whom: Markus Brueffer <brueffer@phoenix-systems.de>
+#
+# $FreeBSD$
+
+PORTNAME= basket
+PORTVERSION= 0.3
+CATEGORIES= deskutils kde
+MASTER_SITES= http://www.sebastien.laout.tuxfamily.org/basket/
+
+MAINTAINER= brueffer@phoenix-systems.de
+COMMENT= Desktop organization tool
+
+USE_KDELIBS_VER= 3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/-O2//g; s/-lpthread/${PTHREAD_LIBS}/g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/deskutils/basket/distinfo b/deskutils/basket/distinfo
new file mode 100644
index 000000000000..4cc68ff6686e
--- /dev/null
+++ b/deskutils/basket/distinfo
@@ -0,0 +1 @@
+MD5 (basket-0.3.tar.gz) = 2a72ade0ba1a16c7e7d26a15cbc0cef6
diff --git a/deskutils/basket/files/patch-configaction.cpp b/deskutils/basket/files/patch-configaction.cpp
new file mode 100644
index 000000000000..72b2697ea419
--- /dev/null
+++ b/deskutils/basket/files/patch-configaction.cpp
@@ -0,0 +1,19 @@
+--- basket/configaction.cpp.orig Mon Sep 8 19:22:28 2003
++++ basket/configaction.cpp Mon Sep 8 19:22:55 2003
+@@ -38,16 +38,6 @@
+ {
+ }
+
+-int ConfigAction::action()
+-{
+- return m_action;
+-}
+-
+-QString ConfigAction::runCommand()
+-{
+- return m_runCommand;
+-}
+-
+ void ConfigAction::setAction(int action)
+ {
+ m_action = action;
diff --git a/deskutils/basket/files/patch-configaction.h b/deskutils/basket/files/patch-configaction.h
new file mode 100644
index 000000000000..6f98d004c21d
--- /dev/null
+++ b/deskutils/basket/files/patch-configaction.h
@@ -0,0 +1,13 @@
+--- basket/configaction.h.orig Mon Sep 8 19:21:02 2003
++++ basket/configaction.h Mon Sep 8 19:22:16 2003
+@@ -35,8 +35,8 @@
+ public:
+ ConfigAction(int action = 0, QString runCommand = "");
+ ~ConfigAction();
+- inline int action();
+- inline QString runCommand();
++ inline int action() { return m_action; };
++ inline QString runCommand() { return m_runCommand; };
+ inline void setAction(int action);
+ inline void setRunCommand(QString runCommand);
+ private:
diff --git a/deskutils/basket/pkg-descr b/deskutils/basket/pkg-descr
new file mode 100644
index 000000000000..c4b364e36480
--- /dev/null
+++ b/deskutils/basket/pkg-descr
@@ -0,0 +1,6 @@
+BasKet is a desktop organization tool. It uses baskets / drawers ("baskets")
+to organize objects, such as text, URLs, images, sounds or other documents.
+Objects in a basket can be edited, copied, moved, dragged, etc.
+
+Author: Sebastien Laout <sebastien.laout@tuxfamily.org>
+WWW: http://www.sebastien.laout.tuxfamily.org/basket
diff --git a/deskutils/basket/pkg-plist b/deskutils/basket/pkg-plist
new file mode 100644
index 000000000000..b644ce51ded7
--- /dev/null
+++ b/deskutils/basket/pkg-plist
@@ -0,0 +1,12 @@
+bin/basket
+share/applnk/Applications/basket.desktop
+share/icons/locolor/16x16/apps/basket.png
+share/icons/locolor/32x32/apps/basket.png
+@unexec rmdir %D/share/icons/locolor/32x32/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/32x32 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16/apps 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor/16x16 2>/dev/null || true
+@unexec rmdir %D/share/icons/locolor 2>/dev/null || true
+@unexec rmdir %D/share/icons 2>/dev/null || true
+@unexec rmdir %D/share/applnk/Applications 2>/dev/null || true
+@unexec rmdir %D/share/applnk 2>/dev/null || true