aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2018-12-12 14:17:08 +0000
committerDavid Naylor <dbn@FreeBSD.org>2018-12-12 14:17:08 +0000
commitbbbef7017406e6eb30648d5bf799bf3c71836223 (patch)
treedb0ecd6f4394175211fb1b88af561da9312ab5e0 /deskutils
parent470cba1f0447b571172268df38b50b2ded5e820b (diff)
downloadports-bbbef7017406e6eb30648d5bf799bf3c71836223.tar.gz
ports-bbbef7017406e6eb30648d5bf799bf3c71836223.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/fasd/Makefile20
-rw-r--r--deskutils/fasd/distinfo3
-rw-r--r--deskutils/fasd/pkg-descr5
-rw-r--r--deskutils/fasd/pkg-message7
5 files changed, 36 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b5fe2b39530e..061e3728c409 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -51,6 +51,7 @@
SUBDIR += flameshot
SUBDIR += freemind
SUBDIR += freeplane
+ SUBDIR += fasd
SUBDIR += fusenshi
SUBDIR += gaddr
SUBDIR += ganttproject
diff --git a/deskutils/fasd/Makefile b/deskutils/fasd/Makefile
new file mode 100644
index 000000000000..0129d658071f
--- /dev/null
+++ b/deskutils/fasd/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= fasd
+PORTVERSION= 1.0.1
+CATEGORIES= deskutils
+
+MAINTAINER= mail@dbalan.in
+COMMENT= Shell helper program to autocomplete paths faster
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= clvv
+
+MAKE_ARGS+= prefix=${PREFIX} \
+ MANDIR=${MANPREFIX}/man
+
+PLIST_FILES= bin/fasd man/man1/fasd.1.gz
+
+.include <bsd.port.mk>
diff --git a/deskutils/fasd/distinfo b/deskutils/fasd/distinfo
new file mode 100644
index 000000000000..8b0c0f949581
--- /dev/null
+++ b/deskutils/fasd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1528835657
+SHA256 (clvv-fasd-1.0.1_GH0.tar.gz) = 88efdfbbed8df408699a14fa6c567450bf86480f5ff3dde42d0b3e1dee731f65
+SIZE (clvv-fasd-1.0.1_GH0.tar.gz) = 16018
diff --git a/deskutils/fasd/pkg-descr b/deskutils/fasd/pkg-descr
new file mode 100644
index 000000000000..d62449836d01
--- /dev/null
+++ b/deskutils/fasd/pkg-descr
@@ -0,0 +1,5 @@
+Fasd is a handy shell helper program to access files and directories faster.
+Fasd will try to expand path arguments from previously seen ones ordered by
+frequency of access.
+
+WWW: https://github.com/clvv/fasd
diff --git a/deskutils/fasd/pkg-message b/deskutils/fasd/pkg-message
new file mode 100644
index 000000000000..669444a0a64a
--- /dev/null
+++ b/deskutils/fasd/pkg-message
@@ -0,0 +1,7 @@
+To get fasd working in a shell, some initialization code must be run. Put the
+line below in your shell rc.
+
+eval "$(fasd --init auto)"
+
+This will setup a command hook that executes on every command and advanced tab
+completion for zsh and bash.