aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2021-02-12 10:54:45 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2021-02-12 10:54:45 +0000
commitbd8021cacf335a3a89a0487f8e765a80674258b8 (patch)
tree670659faeb6d60dd7764e26264ab7e1ae7a2dbfc /deskutils
parenteefde745d97312945b16d7fae7adeccd0929285c (diff)
downloadports-bd8021cacf335a3a89a0487f8e765a80674258b8.tar.gz
ports-bd8021cacf335a3a89a0487f8e765a80674258b8.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/gnome-pomodoro/Makefile50
-rw-r--r--deskutils/gnome-pomodoro/distinfo3
-rw-r--r--deskutils/gnome-pomodoro/pkg-descr6
-rw-r--r--deskutils/gnome-pomodoro/pkg-plist66
5 files changed, 126 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b45027c57933..6d4f25c4f5d0 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -72,6 +72,7 @@
SUBDIR += gnome-initial-setup
SUBDIR += gnome-maps
SUBDIR += gnome-photos
+ SUBDIR += gnome-pomodoro
SUBDIR += gnome-screenshot
SUBDIR += gnome-search-tool
SUBDIR += gnome-shell-extension-audio-output-switcher
diff --git a/deskutils/gnome-pomodoro/Makefile b/deskutils/gnome-pomodoro/Makefile
new file mode 100644
index 000000000000..fa111c071ac5
--- /dev/null
+++ b/deskutils/gnome-pomodoro/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= gnome-pomodoro
+PORTVERSION= 0.18.0
+CATEGORIES= deskutils gnome
+
+MAINTAINER= tagattie@FreeBSD.org
+COMMENT= Time management utility for GNOME
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= appstream-util:devel/appstream-glib \
+ autoconf-archive>0:devel/autoconf-archive \
+ valac:lang/vala
+LIB_DEPENDS= libcanberra.so:audio/libcanberra \
+ libgom-1.0.so:databases/gom \
+ libpeas-1.0.so:devel/libpeas
+
+USES= autoreconf desktop-file-utils gettext-tools gmake gnome \
+ libtool pkgconfig sqlite
+
+USE_GITHUB= yes
+
+GNU_CONFIGURE= yes
+
+USE_GCC= yes
+USE_GNOME= cairo glib20 gtk30 introspection
+USE_GSTREAMER1= yes
+
+INSTALL_TARGET= install-strip
+
+GLIB_SCHEMAS= org.gnome.pomodoro.gschema.xml \
+ org.gnome.pomodoro.plugins.actions.gschema.xml \
+ org.gnome.pomodoro.plugins.gnome.gschema.xml \
+ org.gnome.pomodoro.plugins.sounds.gschema.xml
+INSTALLS_ICONS= yes
+
+PORTDOCS= NEWS README.md
+
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+
+NLS_CONFIGURE_ENABLE= nls
+
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/deskutils/gnome-pomodoro/distinfo b/deskutils/gnome-pomodoro/distinfo
new file mode 100644
index 000000000000..ede991082bbf
--- /dev/null
+++ b/deskutils/gnome-pomodoro/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1612702013
+SHA256 (gnome-pomodoro-gnome-pomodoro-0.18.0_GH0.tar.gz) = 16cb0a772a5e0adad1519dbc63f98a6959887b4e65f8db512a9b7a4d24fcc52d
+SIZE (gnome-pomodoro-gnome-pomodoro-0.18.0_GH0.tar.gz) = 6203162
diff --git a/deskutils/gnome-pomodoro/pkg-descr b/deskutils/gnome-pomodoro/pkg-descr
new file mode 100644
index 000000000000..c6df14c500df
--- /dev/null
+++ b/deskutils/gnome-pomodoro/pkg-descr
@@ -0,0 +1,6 @@
+GNOME Pomodoro is a small application that helps managing time
+according to Pomodoro Technique. It intends to improve productivity
+and focus by taking short breaks. It uses GNOME technologies, and so
+it has complete integration with the GNOME desktop environment.
+
+WWW: https://gnomepomodoro.org
diff --git a/deskutils/gnome-pomodoro/pkg-plist b/deskutils/gnome-pomodoro/pkg-plist
new file mode 100644
index 000000000000..25a1a4ae70a0
--- /dev/null
+++ b/deskutils/gnome-pomodoro/pkg-plist
@@ -0,0 +1,66 @@
+bin/gnome-pomodoro
+lib/gnome-pomodoro/plugins/actions.plugin
+lib/gnome-pomodoro/plugins/dark-theme.plugin
+lib/gnome-pomodoro/plugins/gnome.plugin
+lib/gnome-pomodoro/plugins/libactions.a
+lib/gnome-pomodoro/plugins/libactions.so
+lib/gnome-pomodoro/plugins/libdark-theme.a
+lib/gnome-pomodoro/plugins/libdark-theme.so
+lib/gnome-pomodoro/plugins/libgnome.a
+lib/gnome-pomodoro/plugins/libgnome.so
+lib/gnome-pomodoro/plugins/libsounds.a
+lib/gnome-pomodoro/plugins/libsounds.so
+lib/gnome-pomodoro/plugins/sounds.plugin
+lib/libgnome-pomodoro.a
+lib/libgnome-pomodoro.so
+lib/libgnome-pomodoro.so.0
+lib/libgnome-pomodoro.so.0.0.0
+share/applications/org.gnome.Pomodoro.desktop
+share/dbus-1/services/org.gnome.Pomodoro.service
+%%DATADIR%%/sounds/bell.ogg
+%%DATADIR%%/sounds/birds.ogg
+%%DATADIR%%/sounds/clock.ogg
+%%DATADIR%%/sounds/loud-bell.ogg
+%%DATADIR%%/sounds/timer.ogg
+share/gnome-shell/extensions/pomodoro@arun.codito.in/capabilities.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/config.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/dbus.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/dialogs.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/extension.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/indicator.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/metadata.json
+share/gnome-shell/extensions/pomodoro@arun.codito.in/notifications.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/presence.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/settings.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/stylesheet.css
+share/gnome-shell/extensions/pomodoro@arun.codito.in/timer.js
+share/gnome-shell/extensions/pomodoro@arun.codito.in/utils.js
+share/icons/hicolor/16x16/apps/gnome-pomodoro.png
+share/icons/hicolor/24x24/apps/gnome-pomodoro.png
+share/icons/hicolor/256x256/apps/gnome-pomodoro.png
+share/icons/hicolor/32x32/apps/gnome-pomodoro.png
+share/icons/hicolor/48x48/apps/gnome-pomodoro.png
+share/icons/hicolor/512x512/apps/gnome-pomodoro.png
+share/icons/hicolor/scalable/apps/gnome-pomodoro-symbolic.svg
+%%NLS%%share/locale/ca/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/id/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gnome-pomodoro.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnome-pomodoro.mo
+share/metainfo/org.gnome.Pomodoro.appdata.xml