aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2012-11-08 11:21:37 +0000
committerJason E. Hale <jhale@FreeBSD.org>2012-11-08 11:21:37 +0000
commitcf5116463a8765221eba3ef3e76b179f1ec514c8 (patch)
treefa63027eaa777142b14f5d7ecf42b8ad26406578 /deskutils
parent8d1275d48ae6c54471086b1dd49d1356c9164a9f (diff)
downloadports-cf5116463a8765221eba3ef3e76b179f1ec514c8.tar.gz
ports-cf5116463a8765221eba3ef3e76b179f1ec514c8.zip
- Update to 5.18.2
- Remove name of port from COMMENT - Move LICENSE to correct location and mark it GPLv2 or GPLv3 - Respect MANPREFIX - Add NLS option - Whitespace cleanup - Convert to new options framework - Trim Makefile header - Tab -> space in pkg-descr WWW line PR: Based on ports/168679 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com> Approved by: maintainer timeout (5 months) makc, avilla (mentors, implicit) Feature safe: yes
Notes
Notes: svn path=/head/; revision=307171
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/fet/Makefile57
-rw-r--r--deskutils/fet/distinfo4
-rw-r--r--deskutils/fet/pkg-descr2
-rw-r--r--deskutils/fet/pkg-plist32
4 files changed, 66 insertions, 29 deletions
diff --git a/deskutils/fet/Makefile b/deskutils/fet/Makefile
index 868fc1f97e95..b34d7051be75 100644
--- a/deskutils/fet/Makefile
+++ b/deskutils/fet/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: fet
-# Date created: 11 March 2010
-# Whom: Leinier Cruz Salfran <salfrancl@yahoo.es>
-#
+# Created by: Leinier Cruz Salfran <salfrancl@yahoo.es>
# $FreeBSD$
-#
PORTNAME= fet
-PORTVERSION= 5.14.2
-PORTREVISION= 1
+PORTVERSION= 5.18.2
CATEGORIES= deskutils kde
MASTER_SITES= http://lalescu.ro/liviu/fet/download/ \
http://lalescu.ro/liviu/fet/download/old/ \
@@ -15,44 +10,54 @@ MASTER_SITES= http://lalescu.ro/liviu/fet/download/ \
http://timetabling.de/download/old/
MAINTAINER= salfrancl@yahoo.es
-COMMENT= FET is free timetabling software
+COMMENT= Free timetabling software
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
USE_BZIP2= yes
-USE_QT4= gui network qt3support xml \
+USE_QT4= gui network xml \
moc_build qmake_build rcc_build uic_build
HAS_CONFIGURE= yes
-QMAKE_ARGS= -unix PREFIX=${PREFIX} \
- INCLUDEPATH+=${LOCALBASE}/include \
- LIBS+=-L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
-LICENSE= GPLv2
-
-PLIST_FILES= bin/fet
MAN1= fet.1
-.ifndef(NOPORTEXAMPLES)
+
PORTEXAMPLES= *
+
+DESKTOP_ENTRIES="FET" \
+ "Free timetable software" \
+ "" \
+ "fet" \
+ "Application;Education;Qt;" \
+ true
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
.endif
-DESKTOP_ENTRIES= "FET" \
- "Free timetable software" \
- "" \
- "fet" \
- "Application;Education;Qt;" \
- true
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/share/fet|${DATADIR}|g' \
+ ${WRKSRC}/src/interface/fet.cpp
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS}
do-install:
- ${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/fet ${PREFIX}/bin
- ${MKDIR} ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/fet.1 ${PREFIX}/man/man1
-.ifndef(NOPORTEXAMPLES)
+ ${INSTALL_MAN} ${WRKSRC}/doc/fet.1 ${MANPREFIX}/man/man1
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \. ${EXAMPLESDIR}
.endif
+.if ${PORT_OPTIONS:MNLS}
+ ${MKDIR} ${DATADIR}/translations
+ cd ${WRKSRC}/translations && ${INSTALL_DATA} *.qm ${DATADIR}/translations
+.endif
.include <bsd.port.mk>
diff --git a/deskutils/fet/distinfo b/deskutils/fet/distinfo
index 2da2eb276c00..8735bae032aa 100644
--- a/deskutils/fet/distinfo
+++ b/deskutils/fet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fet-5.14.2.tar.bz2) = fc6849ef410936f7167a1683608228c89ddd9d6caaee3c7b8b6b6fdebd3ca2f9
-SIZE (fet-5.14.2.tar.bz2) = 5972903
+SHA256 (fet-5.18.2.tar.bz2) = bead2ff4bd67733e26c81973a8fac3fcb0f08e22a2450d6c971ecf2c7e39fea8
+SIZE (fet-5.18.2.tar.bz2) = 7676275
diff --git a/deskutils/fet/pkg-descr b/deskutils/fet/pkg-descr
index 6d7c8ead91e3..05c74b60eda7 100644
--- a/deskutils/fet/pkg-descr
+++ b/deskutils/fet/pkg-descr
@@ -10,4 +10,4 @@ difficult timetables, it may take a longer time, a matter of hours.
FET can mean "Free Educational Timetabling" (the "E" in the middle
may also stand for other words, based on your personal preference).
-WWW: http://lalescu.ro/liviu/fet/
+WWW: http://lalescu.ro/liviu/fet/
diff --git a/deskutils/fet/pkg-plist b/deskutils/fet/pkg-plist
new file mode 100644
index 000000000000..3f2a0273f032
--- /dev/null
+++ b/deskutils/fet/pkg-plist
@@ -0,0 +1,32 @@
+bin/fet
+%%NLS%%%%DATADIR%%/translations/fet_ar.qm
+%%NLS%%%%DATADIR%%/translations/fet_ca.qm
+%%NLS%%%%DATADIR%%/translations/fet_da.qm
+%%NLS%%%%DATADIR%%/translations/fet_de.qm
+%%NLS%%%%DATADIR%%/translations/fet_el.qm
+%%NLS%%%%DATADIR%%/translations/fet_es.qm
+%%NLS%%%%DATADIR%%/translations/fet_fa.qm
+%%NLS%%%%DATADIR%%/translations/fet_fr.qm
+%%NLS%%%%DATADIR%%/translations/fet_gl.qm
+%%NLS%%%%DATADIR%%/translations/fet_he.qm
+%%NLS%%%%DATADIR%%/translations/fet_hu.qm
+%%NLS%%%%DATADIR%%/translations/fet_id.qm
+%%NLS%%%%DATADIR%%/translations/fet_it.qm
+%%NLS%%%%DATADIR%%/translations/fet_lt.qm
+%%NLS%%%%DATADIR%%/translations/fet_mk.qm
+%%NLS%%%%DATADIR%%/translations/fet_ms.qm
+%%NLS%%%%DATADIR%%/translations/fet_nl.qm
+%%NLS%%%%DATADIR%%/translations/fet_pl.qm
+%%NLS%%%%DATADIR%%/translations/fet_pt_BR.qm
+%%NLS%%%%DATADIR%%/translations/fet_ro.qm
+%%NLS%%%%DATADIR%%/translations/fet_ru.qm
+%%NLS%%%%DATADIR%%/translations/fet_si.qm
+%%NLS%%%%DATADIR%%/translations/fet_sk.qm
+%%NLS%%%%DATADIR%%/translations/fet_sr.qm
+%%NLS%%%%DATADIR%%/translations/fet_tr.qm
+%%NLS%%%%DATADIR%%/translations/fet_uk.qm
+%%NLS%%%%DATADIR%%/translations/fet_untranslated.qm
+%%NLS%%%%DATADIR%%/translations/fet_uz.qm
+%%NLS%%%%DATADIR%%/translations/fet_vi.qm
+%%NLS%%@dirrm %%DATADIR%%/translations
+%%NLS%%@dirrm %%DATADIR%%