aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2021-06-13 10:32:22 +0000
committerGleb Popov <arrowd@FreeBSD.org>2021-06-13 14:32:48 +0000
commite06c7c5297c43b9b5cb85078a2bd284b88f22058 (patch)
tree05e8eae3147e8f04c8cd457237a5d99ac1520f08 /deskutils
parent182121fa658239fb8f2f74b29e0df89a2b15fe8b (diff)
downloadports-e06c7c5297c43b9b5cb85078a2bd284b88f22058.tar.gz
ports-e06c7c5297c43b9b5cb85078a2bd284b88f22058.zip
deskutils/libportal: + An API library to Flatpak portals.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/libportal/Makefile19
-rw-r--r--deskutils/libportal/distinfo3
-rw-r--r--deskutils/libportal/pkg-descr8
-rw-r--r--deskutils/libportal/pkg-plist59
5 files changed, 90 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 918ebc967e62..8d3229a7fe1e 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -145,6 +145,7 @@
SUBDIR += kuserfeedback
SUBDIR += latte-dock
SUBDIR += libkdepim
+ SUBDIR += libportal
SUBDIR += ljclive
SUBDIR += lookbook
SUBDIR += lumina-archiver
diff --git a/deskutils/libportal/Makefile b/deskutils/libportal/Makefile
new file mode 100644
index 000000000000..9b51f1f76791
--- /dev/null
+++ b/deskutils/libportal/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= libportal
+PORTVERSION= 0.4
+CATEGORIES= deskutils
+
+MAINTAINER= arrowd@FreeBSD.org
+COMMENT= GIO-styled async APIs for Flatpak
+
+LICENSE= GPLv2+
+
+BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
+
+USES= gnome meson pkgconfig
+
+USE_GNOME= glib20 introspection
+
+USE_GITHUB= yes
+GH_ACCOUNT= flatpak
+
+.include <bsd.port.mk>
diff --git a/deskutils/libportal/distinfo b/deskutils/libportal/distinfo
new file mode 100644
index 000000000000..93cd026b8d5e
--- /dev/null
+++ b/deskutils/libportal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623579186
+SHA256 (flatpak-libportal-0.4_GH0.tar.gz) = 01c1c5035f9c15095c7d0d015a4825c2fe6b8e6b729cd078641fbc921c953b84
+SIZE (flatpak-libportal-0.4_GH0.tar.gz) = 67508
diff --git a/deskutils/libportal/pkg-descr b/deskutils/libportal/pkg-descr
new file mode 100644
index 000000000000..fef465f3707a
--- /dev/null
+++ b/deskutils/libportal/pkg-descr
@@ -0,0 +1,8 @@
+Flatpak is a technology for packaging and distributing standalone dekstop
+applications. It uses interfaces called "portals" to communicate with the
+rest of the system.
+
+libportal is a small library that provides an asynchronous API to the
+most Flatpak portals.
+
+WWW: https://github.com/flatpak/libportal
diff --git a/deskutils/libportal/pkg-plist b/deskutils/libportal/pkg-plist
new file mode 100644
index 000000000000..9a69ae33f58e
--- /dev/null
+++ b/deskutils/libportal/pkg-plist
@@ -0,0 +1,59 @@
+include/libportal/account.h
+include/libportal/background.h
+include/libportal/camera.h
+include/libportal/email.h
+include/libportal/filechooser.h
+include/libportal/inhibit.h
+include/libportal/location.h
+include/libportal/notification.h
+include/libportal/openuri.h
+include/libportal/portal-enums.h
+include/libportal/portal-gtk3.h
+include/libportal/portal-gtk4.h
+include/libportal/portal-helpers.h
+include/libportal/portal-qt5.h
+include/libportal/portal.h
+include/libportal/print.h
+include/libportal/remote.h
+include/libportal/screenshot.h
+include/libportal/spawn.h
+include/libportal/trash.h
+include/libportal/updates.h
+include/libportal/wallpaper.h
+lib/libportal.so
+lib/libportal.so.0
+lib/libportal.so.0.0.1
+libdata/pkgconfig/libportal.pc
+share/gtk-doc/html/libportal/XdpPortal.html
+share/gtk-doc/html/libportal/XdpSession.html
+share/gtk-doc/html/libportal/aux.html
+share/gtk-doc/html/libportal/home.png
+share/gtk-doc/html/libportal/index.html
+share/gtk-doc/html/libportal/left-insensitive.png
+share/gtk-doc/html/libportal/left.png
+share/gtk-doc/html/libportal/libportal-Accounts.html
+share/gtk-doc/html/libportal/libportal-Background.html
+share/gtk-doc/html/libportal/libportal-Camera.html
+share/gtk-doc/html/libportal/libportal-Email.html
+share/gtk-doc/html/libportal/libportal-File.html
+share/gtk-doc/html/libportal/libportal-Location.html
+share/gtk-doc/html/libportal/libportal-Notification.html
+share/gtk-doc/html/libportal/libportal-Open.html
+share/gtk-doc/html/libportal/libportal-Print.html
+share/gtk-doc/html/libportal/libportal-Remote-desktop.html
+share/gtk-doc/html/libportal/libportal-Screencast.html
+share/gtk-doc/html/libportal/libportal-Screenshot.html
+share/gtk-doc/html/libportal/libportal-Session.html
+share/gtk-doc/html/libportal/libportal-Spawn.html
+share/gtk-doc/html/libportal/libportal-Trash.html
+share/gtk-doc/html/libportal/libportal-Updates.html
+share/gtk-doc/html/libportal/libportal-Wallpaper.html
+share/gtk-doc/html/libportal/libportal-XdpParent.html
+share/gtk-doc/html/libportal/libportal.devhelp2
+share/gtk-doc/html/libportal/libportal.html
+share/gtk-doc/html/libportal/right-insensitive.png
+share/gtk-doc/html/libportal/right.png
+share/gtk-doc/html/libportal/style.css
+share/gtk-doc/html/libportal/up-insensitive.png
+share/gtk-doc/html/libportal/up.png
+