aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-20 20:04:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-20 20:04:09 +0000
commite138b520734bd403b870beb0d5493af3e4c8fcaa (patch)
treea695f4d9ed986d542186143503efa1cc0637c17a /deskutils
parente09c7f6bbc7b025dce14668dabee8cf3ec51dcf8 (diff)
downloadports-e138b520734bd403b870beb0d5493af3e4c8fcaa.tar.gz
ports-e138b520734bd403b870beb0d5493af3e4c8fcaa.zip
Notes
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/google-gadgets/Makefile14
-rw-r--r--deskutils/google-gadgets/distinfo6
-rw-r--r--deskutils/google-gadgets/files/patch-ggadget_module.cc31
-rw-r--r--deskutils/google-gadgets/pkg-install13
-rw-r--r--deskutils/google-gadgets/pkg-plist18
5 files changed, 45 insertions, 37 deletions
diff --git a/deskutils/google-gadgets/Makefile b/deskutils/google-gadgets/Makefile
index 660fd8656ef8..ced2d7f5ef9c 100644
--- a/deskutils/google-gadgets/Makefile
+++ b/deskutils/google-gadgets/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= google-gadgets
-PORTVERSION= 0.9.3
+PORTVERSION= 0.10.0
CATEGORIES= deskutils
MASTER_SITES= http://google-gadgets-for-linux.googlecode.com/files/
DISTNAME= ${PORTNAME}-for-linux-${PORTVERSION}
@@ -27,15 +27,17 @@ LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
dbus-1.3:${PORTSDIR}/devel/dbus \
curl.4:${PORTSDIR}/ftp/curl \
rsvg-2.2:${PORTSDIR}/graphics/librsvg2
-RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/firefox-js.pc:${PORTSDIR}/www/firefox \
+ ${LOCALBASE}/bin/update-mime-database:${PORTSDIR}/misc/shared-mime-info
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gtk20
+USE_GCC= 4.2+
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" CPPFLAGS="-I${LOCALBASE}/include -Wno-deprecated-declarations" LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-qt-host --enable-ltdl-install=no
+CONFIGURE_ARGS= --disable-qt-host --enable-ltdl-install=no --disable-update-mime-database
USE_AUTOTOOLS= libtool:15:env autoconf:261:env automake:110:env aclocal:110:env libltdl:15
OPTIONS= DEBUGGING "Enable debug output on runtime" on
@@ -52,4 +54,10 @@ post-patch:
pre-configure:
@cd ${WRKSRC} && ${SH} autotools/bootstrap.sh && ${CP} ${AUTOMAKE_DIR}/mkinstalldirs libltdl/
+post-deinstall:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
+
+post-install:
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
.include <bsd.port.post.mk>
diff --git a/deskutils/google-gadgets/distinfo b/deskutils/google-gadgets/distinfo
index 7d91b80a7066..309256aabd82 100644
--- a/deskutils/google-gadgets/distinfo
+++ b/deskutils/google-gadgets/distinfo
@@ -1,3 +1,3 @@
-MD5 (google-gadgets-for-linux-0.9.3.tar.gz) = 590b6fefbf9cbbbfe5dc34f99c0932f4
-SHA256 (google-gadgets-for-linux-0.9.3.tar.gz) = 6b93b3d39719c10063e143e919e9ee65956dacc51bbc5aa1cafef76c71abcff6
-SIZE (google-gadgets-for-linux-0.9.3.tar.gz) = 2338243
+MD5 (google-gadgets-for-linux-0.10.0.tar.gz) = 315406fe83ab05d31e48200e07344496
+SHA256 (google-gadgets-for-linux-0.10.0.tar.gz) = 5367a44d47d60e31fc17dc43b7b1e1d393147bd901cb8c24f7975781e4abed5a
+SIZE (google-gadgets-for-linux-0.10.0.tar.gz) = 2499027
diff --git a/deskutils/google-gadgets/files/patch-ggadget_module.cc b/deskutils/google-gadgets/files/patch-ggadget_module.cc
deleted file mode 100644
index 4b987924f7c7..000000000000
--- a/deskutils/google-gadgets/files/patch-ggadget_module.cc
+++ /dev/null
@@ -1,31 +0,0 @@
-
-$FreeBSD$
-
---- ggadget/module.cc.orig
-+++ ggadget/module.cc
-@@ -34,6 +34,12 @@
- // #define DEBUG_MODULES
- #endif
-
-+#if __GNUC__ < 4
-+#define CAST_HACK(x) (x)
-+#else
-+#define CAST_HACK(x) reinterpret_cast<x>
-+#endif
-+
- namespace ggadget {
-
- static const char *kModulePathEnv = "GGL_MODULE_PATH";
-@@ -117,10 +123,10 @@
-
- NormalizeNameString(&module_name);
-
-- InitializeFunction new_initialize = reinterpret_cast<InitializeFunction>(
-+ InitializeFunction new_initialize = CAST_HACK(InitializeFunction)(
- GetModuleSymbol(new_handle, module_name.c_str(),
- kModuleInitializeSymbol));
-- FinalizeFunction new_finalize = reinterpret_cast<FinalizeFunction>(
-+ FinalizeFunction new_finalize = CAST_HACK(FinalizeFunction)(
- GetModuleSymbol(new_handle, module_name.c_str(),
- kModuleFinalizeSymbol));
-
diff --git a/deskutils/google-gadgets/pkg-install b/deskutils/google-gadgets/pkg-install
new file mode 100644
index 000000000000..db7ff4a18fa2
--- /dev/null
+++ b/deskutils/google-gadgets/pkg-install
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+UPDATE_MIME_DATABASE=update-mime-database
+
+case $2 in
+POST-INSTALL)
+ ${UPDATE_MIME_DATABASE} ${PKG_PREFIX}/share/mime
+ ;;
+POST-DEINSTALL)
+ ${UPDATE_MIME_DATABASE} ${PKG_PREFIX}/share/mime
+ ;;
+esac
+
diff --git a/deskutils/google-gadgets/pkg-plist b/deskutils/google-gadgets/pkg-plist
index ae28975c93aa..fecf2a9eb688 100644
--- a/deskutils/google-gadgets/pkg-plist
+++ b/deskutils/google-gadgets/pkg-plist
@@ -39,6 +39,7 @@ include/google-gadgets/ggadget/gadget_consts.h
include/google-gadgets/ggadget/gadget_manager_interface.h
include/google-gadgets/ggadget/graphics_interface.h
include/google-gadgets/ggadget/gtk/cairo_graphics.h
+include/google-gadgets/ggadget/gtk/hotkey.h
include/google-gadgets/ggadget/gtk/key_convert.h
include/google-gadgets/ggadget/gtk/main_loop.h
include/google-gadgets/ggadget/gtk/menu_builder.h
@@ -51,6 +52,8 @@ include/google-gadgets/ggadget/image_cache.h
include/google-gadgets/ggadget/image_interface.h
include/google-gadgets/ggadget/img_element.h
include/google-gadgets/ggadget/item_element.h
+include/google-gadgets/ggadget/js/js_utils.h
+include/google-gadgets/ggadget/js/jscript_massager.h
include/google-gadgets/ggadget/label_element.h
include/google-gadgets/ggadget/listbox_element.h
include/google-gadgets/ggadget/locales.h
@@ -67,6 +70,7 @@ include/google-gadgets/ggadget/object_element.h
include/google-gadgets/ggadget/options_interface.h
include/google-gadgets/ggadget/progressbar_element.h
include/google-gadgets/ggadget/registerable_interface.h
+include/google-gadgets/ggadget/run_once.h
include/google-gadgets/ggadget/scoped_ptr.h
include/google-gadgets/ggadget/script_context_interface.h
include/google-gadgets/ggadget/script_runtime_interface.h
@@ -156,19 +160,33 @@ lib/libggadget-gtk-1.0.a
lib/libggadget-gtk-1.0.la
lib/libggadget-gtk-1.0.so
lib/libggadget-gtk-1.0.so.0
+lib/libggadget-js-1.0.a
+lib/libggadget-js-1.0.la
+lib/libggadget-js-1.0.so
+lib/libggadget-js-1.0.so.0
libdata/pkgconfig/libggadget-1.0.pc
libdata/pkgconfig/libggadget-dbus-1.0.pc
libdata/pkgconfig/libggadget-gtk-1.0.pc
+libdata/pkgconfig/libggadget-js-1.0.pc
+share/applications/ggl-gtk.desktop
+%%DATADIR%%/analog_clock.gg
+%%DATADIR%%/digital_alarm_clock.gg
%%DATADIR%%/google-gadget-browser.gg
%%DATADIR%%/igoogle.gg
%%DATADIR%%/resources.gg
%%DATADIR%%/rss.gg
+share/mime/packages/00-google-gadgets.xml
+share/mime/application/x-google-gadgets.xml
+share/pixmaps/google-gadgets.png
+@dirrm share/mime/packages
@dirrm %%DATADIR%%
@dirrm lib/google-gadgets/modules
@dirrm lib/google-gadgets/include/ggadget
@dirrm lib/google-gadgets/include
@dirrm lib/google-gadgets
+@dirrm include/google-gadgets/ggadget/js
@dirrm include/google-gadgets/ggadget/gtk
@dirrm include/google-gadgets/ggadget/dbus
@dirrm include/google-gadgets/ggadget
@dirrm include/google-gadgets
+@dirrmtry share/mime/application