aboutsummaryrefslogtreecommitdiff
path: root/devel/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-05 21:13:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-05 21:13:31 +0000
commit94d0728d0346b4778dbc920bdb370ffef0cfe093 (patch)
tree63dc1d35e817539c26ffc65071bfc4e33243ba24 /devel/Makefile
parent8caf43c2d8e94a18cd72b733603426e95c4f26c7 (diff)
OpenTop contains framework classes that provide the features
you need to write network-centric, web-enabled and internationalized applications in C++. It enables you to: * create network clients and servers using either raw socket facilities or higher-level protocols such as HTTP and FTP. * create multi-threaded applications and manage synchronization between threads using simple but effective threading abstractions which are common to all platforms. * use the full Unicode character range, using built-in character types and standard string classes. * use byte and character streams and manipulate files using an API inspired by the excellent java.io package. * take advantage of its open architecture by registering your own (or third-party) classes to perform custom processing. * write portable applications and extension libraries. OpenTop is an ideal base on which to deliver cross-platform solutions, benefitting independent software vendors and corporate IT departments. * integrate XML into your C++ applications with the C++ XML Toolkit extension library. PR: 59887 Submitted by: Sergey Matveychuk <sem@ciam.ru>
Notes
Notes: svn path=/head/; revision=95160
Diffstat (limited to 'devel/Makefile')
-rw-r--r--devel/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b79e5782a5ff..399cbd672118 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -486,6 +486,7 @@
SUBDIR += omniORB
SUBDIR += oniguruma
SUBDIR += openthreads
+ SUBDIR += opentop
SUBDIR += openzz
SUBDIR += orbitcpp
SUBDIR += ossp-al