aboutsummaryrefslogtreecommitdiff
path: root/devel/ORBit2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-12-26 19:23:26 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-12-26 19:23:26 +0000
commita2db97f7ff8c3bb0cf352e0cd8f907b54e35e5ba (patch)
tree8d92a2e33d7f1691bf71a2cfce69cd6cfa68a229 /devel/ORBit2/Makefile
parent9da7159d85159bb738c5fc69faddbb6375e1e6da (diff)
downloadports-a2db97f7ff8c3bb0cf352e0cd8f907b54e35e5ba.tar.gz
ports-a2db97f7ff8c3bb0cf352e0cd8f907b54e35e5ba.zip
Notes
Diffstat (limited to 'devel/ORBit2/Makefile')
-rw-r--r--devel/ORBit2/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/devel/ORBit2/Makefile b/devel/ORBit2/Makefile
index 3ce8372fe347..941406c83830 100644
--- a/devel/ORBit2/Makefile
+++ b/devel/ORBit2/Makefile
@@ -1,25 +1,33 @@
# New ports collection makefile for: orbit
-# Version required: 0.3.0
+# Version required: 0.3.90
# Date Created: 16 Aug 1998
# Whom: Chia-liang Kao <clkao@CirX.ORG>
#
-# $Id: Makefile,v 1.6 1998/11/25 00:42:11 asami Exp $
+# $Id: Makefile,v 1.7 1998/11/25 13:16:32 vanilla Exp $
#
-DISTNAME= ORBit-0.3.0
+DISTNAME= ORBit-0.3.90
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.gnome.org/pub/ORBit/
+MASTER_SITES= ftp://ftp.jimpick.com/pub/mirrors/gnome/sources/ \
+ ftp://ftp.gnome.org/pub/GNOME/sources/
+#MASTER_SITES= ftp://ftp.gnome.org/pub/ORBit/
MAINTAINER= clkao@CirX.ORG
-LIB_DEPENDS= glib11.0:${PORTSDIR}/devel/glib
+LIB_DEPENDS= glib11d.1:${PORTSDIR}/devel/glib11-devel
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= INSTALL='$${INSTALL} -c'
+CONFIGURE_ENV= INSTALL='$${INSTALL} -c' \
+ GLIB_CONFIG="${LOCALBASE}/bin/glib11d-config"
CONFIGURE_ARGS= --disable-indent
+pre-install:
+ @if [ ! -f ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+
post-install:
@${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib