aboutsummaryrefslogtreecommitdiff
path: root/devel/ORBit
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-12 21:56:07 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-12 21:56:07 +0000
commit9929ffb6707e03927b36f0db8371793c1cf5ab72 (patch)
tree0810199f54cebd60d51f7495de1dad9f751983b4 /devel/ORBit
parent59ce27939f84adf6b5cf29aefb997ec6c5f5971c (diff)
downloadports-9929ffb6707e03927b36f0db8371793c1cf5ab72.tar.gz
ports-9929ffb6707e03927b36f0db8371793c1cf5ab72.zip
Notes
Diffstat (limited to 'devel/ORBit')
-rw-r--r--devel/ORBit/Makefile6
-rw-r--r--devel/ORBit/distinfo2
-rw-r--r--devel/ORBit/files/patch-ae106
-rw-r--r--devel/ORBit/files/patch-configure.in7
-rw-r--r--devel/ORBit/files/patch-libIDL::ltmain.sh36
-rw-r--r--devel/ORBit/files/patch-ltmain.sh36
-rw-r--r--devel/ORBit/files/patch-src::IIOP::giop-msg-buffer.c33
-rw-r--r--devel/ORBit/files/patch-src::ORBitutil::compat.c47
8 files changed, 111 insertions, 162 deletions
diff --git a/devel/ORBit/Makefile b/devel/ORBit/Makefile
index 470870e518a1..8766b597aacd 100644
--- a/devel/ORBit/Makefile
+++ b/devel/ORBit/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= ORBit
-PORTVERSION= 0.5.13
-PORTREVISION= 3
+PORTVERSION= 0.5.14
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/ORBit
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
@@ -18,6 +18,7 @@ BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GLIB= yes
INSTALLS_SHLIB= yes
@@ -25,6 +26,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-indent
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
@${TOUCH} ${WRKSRC}/configure
diff --git a/devel/ORBit/distinfo b/devel/ORBit/distinfo
index d346af3d33c5..e01b62bdbc59 100644
--- a/devel/ORBit/distinfo
+++ b/devel/ORBit/distinfo
@@ -1 +1 @@
-MD5 (ORBit-0.5.13.tar.gz) = 89b16a12e565798945b49e9f41d1db5d
+MD5 (gnome/ORBit-0.5.14.tar.bz2) = cd119457cd933a61499dbabf83435e7c
diff --git a/devel/ORBit/files/patch-ae b/devel/ORBit/files/patch-ae
index 205f906c7e30..2be458b349d7 100644
--- a/devel/ORBit/files/patch-ae
+++ b/devel/ORBit/files/patch-ae
@@ -1,11 +1,11 @@
$FreeBSD$
---- configure.orig Mon Jan 7 11:09:58 2002
-+++ configure Fri Jan 11 11:51:55 2002
-@@ -2151,9 +2151,9 @@
- rm -f conf.glibtest
+--- configure.orig Mon Mar 11 14:42:53 2002
++++ configure Tue Mar 12 16:33:49 2002
+@@ -7189,9 +7189,9 @@
+ rm -f conf.glibtest
-GMODULE_CFLAGS=`glib-config --cflags gmodule`
+GMODULE_CFLAGS=`$GLIB_CONFIG --cflags gmodule`
@@ -13,23 +13,24 @@ $FreeBSD$
-GMODULE_LIBS=`glib-config --libs gmodule`
+GMODULE_LIBS=`$GLIB_CONFIG --libs gmodule`
-
for ac_prog in 'bison -y' byacc
-@@ -3757,37 +3757,30 @@
- fi
+ do
+@@ -9298,39 +9298,33 @@
+ fi
-+echo $ac_n "checking how many vectors writev is capable to handle""... $ac_c" 1>&6
-+echo "configure:3761: checking how many vectors writev is capable to handle" >&5
- if test "$cross_compiling" = yes; then
-- cat >> confdefs.h <<\EOF
+-if test "$cross_compiling" = yes; then
+- cat >>confdefs.h <<\EOF
-#define HAVE_LIMITED_WRITEV 1
-EOF
--
++echo $ac_n "checking how many vectors writev is capable to handle""... $ac_c" 1>&6
++echo "configure:3761: checking how many vectors writev is capable to handle" >&5
+
++if test "$cross_compiling" = yes; then
+ MAXIOV=16
else
- cat > conftest.$ac_ext <<EOF
- #line 3768 "configure"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line 9308 "configure"
#include "confdefs.h"
-#include <fcntl.h>
@@ -54,59 +55,52 @@ $FreeBSD$
- return(1);
-
- if(writev(fd, iovecs, NIOVECS) < 0)
-+ FILE *f;
-+ int fd, i;
-+ static struct iovec iovecs[4097];
-+ if ((f = fopen("conftestval", "w")) == NULL || \
-+ (fd = open("/dev/null", O_WRONLY)) < 0)
- return 1;
+- return 1;
-
-+ for (i = 1; i < 4098 && writev(fd, iovecs, i) >= 0; i++);
-+ fprintf(f, "%d\n", i - 1);
-+ fclose(f);
- close(fd);
- return 0;
+- close(fd);
+- return 0;
++ FILE *f;
++ int fd, i;
++ static struct iovec iovecs[4097];
++ if ((f = fopen("conftestval", "w")) == NULL || \
++ (fd = open("/dev/null", O_WRONLY)) < 0)
++ exit(1);
++ for (i = 1; i < 4098 && writev(fd, iovecs, i) >= 0; i++);
++ fprintf(f, "%d\n", i - 1);
++ fclose(f);
++ close(fd);
++ exit(0);
}
-@@ -3795,19 +3788,16 @@
- EOF
- if { (eval echo configure:3797: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
- then
+
+ _ACEOF
+@@ -9345,18 +9339,16 @@
+ ac_status=$?
+ echo "$as_me:9346: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
- :
+ MAXIOV=`cat conftestval`
else
- echo "configure: failed program was:" >&5
- cat conftest.$ac_ext >&5
- rm -fr conftest*
-- cat >> confdefs.h <<\EOF
+ echo "$as_me: program exited with status $ac_status" >&5
+ echo "$as_me: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+-cat >>confdefs.h <<\EOF
-#define HAVE_LIMITED_WRITEV 1
-EOF
-
+ MAXIOV=16
fi
- rm -fr conftest*
+ rm -f core core.* *.core conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
fi
--
+echo "$ac_t""$MAXIOV" 1>&6
-
#######################
-@@ -4740,7 +4730,7 @@
- s%@LIB_WRAP@%$LIB_WRAP%g
- s%@HAVE_HOSTS_ACCESS_TRUE@%$HAVE_HOSTS_ACCESS_TRUE%g
- s%@HAVE_HOSTS_ACCESS_FALSE@%$HAVE_HOSTS_ACCESS_FALSE%g
--s%@HAVE_LIMITED_WRITEV@%$HAVE_LIMITED_WRITEV%g
-+s%@MAXIOV@%$MAXIOV%g
- s%@subdirs@%$subdirs%g
- s%@pkglibdir@%$pkglibdir%g
-
-@@ -5064,10 +5054,6 @@
- *) # Relative path.
- ac_sub_cache_file="$ac_dots$cache_file" ;;
- esac
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
-
- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
- # The eval makes quoting arguments work.
+ # type alignment test #
+@@ -10755,7 +10747,7 @@
+ s,@LIB_WRAP@,$LIB_WRAP,;t t
+ s,@HAVE_HOSTS_ACCESS_TRUE@,$HAVE_HOSTS_ACCESS_TRUE,;t t
+ s,@HAVE_HOSTS_ACCESS_FALSE@,$HAVE_HOSTS_ACCESS_FALSE,;t t
+-s,@HAVE_LIMITED_WRITEV@,$HAVE_LIMITED_WRITEV,;t t
++s,@MAXIOV@,$MAXIOV,;t t
+ s,@subdirs@,$subdirs,;t t
+ s,@pkglibdir@,$pkglibdir,;t t
+ CEOF
diff --git a/devel/ORBit/files/patch-configure.in b/devel/ORBit/files/patch-configure.in
index abd947f9dfe7..a6079ae06aee 100644
--- a/devel/ORBit/files/patch-configure.in
+++ b/devel/ORBit/files/patch-configure.in
@@ -1,8 +1,8 @@
$FreeBSD$
---- configure.in 2001/10/27 12:08:05 1.1
-+++ configure.in 2001/10/27 12:33:26
+--- configure.in 2002/03/12 14:47:33 1.1
++++ configure.in 2002/03/12 14:47:53
@@ -241,33 +241,29 @@
dnl This generates warnings from autoconf...
AC_C_BIGENDIAN
@@ -13,10 +13,9 @@ $FreeBSD$
+#include <sys/types.h>
#include <sys/uio.h>
-#define NIOVECS 50
--int main(int argc, char *argv[])
+#include <fcntl.h>
+#include <stdio.h>
-+int main()
+ int main(int argc, char *argv[])
{
- char dumbuf[20] = "\n";
- struct iovec iovecs[NIOVECS];
diff --git a/devel/ORBit/files/patch-libIDL::ltmain.sh b/devel/ORBit/files/patch-libIDL::ltmain.sh
index 99556a375dd2..e27c1baf1c8f 100644
--- a/devel/ORBit/files/patch-libIDL::ltmain.sh
+++ b/devel/ORBit/files/patch-libIDL::ltmain.sh
@@ -1,19 +1,29 @@
$FreeBSD$
---- libIDL/ltmain.sh Mon Jan 7 11:09:55 2002
-+++ libIDL/ltmain.sh Thu Jan 24 16:32:50 2002
-@@ -1795,6 +1795,9 @@
- *-*-cygwin* | *-*-mingw* | *-*-os2* | *-*-beos*)
- # these systems don't actually have a c library (as such)!
- ;;
-+ *-*-freebsd*)
-+ # has libc, but it shouldn't be explicitly linked in
-+ ;;
- *-*-rhapsody*)
- # rhapsody is a little odd...
- deplibs="$deplibs -framework System"
-@@ -3360,10 +3366,12 @@
+--- libIDL/ltmain.sh.orig Mon Mar 11 14:42:53 2002
++++ libIDL/ltmain.sh Tue Mar 12 16:39:28 2002
+@@ -1042,6 +1042,9 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
++ *-*-freebsd*)
++ # has libc, but it shouldn't be explicitly linked in
++ ;;
+ esac
+ fi
+ deplibs="$deplibs $arg"
+@@ -2438,6 +2441,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # has libc, but it shouldn't be explicitly linked in
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4223,10 +4229,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/devel/ORBit/files/patch-ltmain.sh b/devel/ORBit/files/patch-ltmain.sh
index c6c98237ec0f..ea6bf0c18bb8 100644
--- a/devel/ORBit/files/patch-ltmain.sh
+++ b/devel/ORBit/files/patch-ltmain.sh
@@ -1,19 +1,29 @@
$FreeBSD$
---- ltmain.sh.orig Mon Jan 7 11:09:55 2002
-+++ ltmain.sh Thu Jan 24 16:32:50 2002
-@@ -1795,6 +1795,9 @@
- *-*-cygwin* | *-*-mingw* | *-*-os2* | *-*-beos*)
- # these systems don't actually have a c library (as such)!
- ;;
-+ *-*-freebsd*)
-+ # has libc, but it shouldn't be explicitly linked in
-+ ;;
- *-*-rhapsody*)
- # rhapsody is a little odd...
- deplibs="$deplibs -framework System"
-@@ -3360,10 +3366,12 @@
+--- ltmain.sh.orig Mon Mar 11 14:42:39 2002
++++ ltmain.sh Tue Mar 12 16:38:49 2002
+@@ -1042,6 +1042,9 @@
+ # These systems don't actually have a C library (as such)
+ test "X$arg" = "X-lc" && continue
+ ;;
++ *-*-freebsd*)
++ # has libc, but it shouldn't be explicitly linked in
++ ;;
+ esac
+ fi
+ deplibs="$deplibs $arg"
+@@ -2438,6 +2441,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # has libc, but it shouldn't be explicitly linked in
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4223,10 +4229,12 @@
fi
# Install the pseudo-library for information purposes.
diff --git a/devel/ORBit/files/patch-src::IIOP::giop-msg-buffer.c b/devel/ORBit/files/patch-src::IIOP::giop-msg-buffer.c
index d6184df8952a..0ffa6f6b514e 100644
--- a/devel/ORBit/files/patch-src::IIOP::giop-msg-buffer.c
+++ b/devel/ORBit/files/patch-src::IIOP::giop-msg-buffer.c
@@ -1,34 +1,15 @@
$FreeBSD$
---- src/IIOP/giop-msg-buffer.c.orig Wed Oct 3 09:51:21 2001
-+++ src/IIOP/giop-msg-buffer.c Sat Oct 27 15:52:11 2001
-@@ -34,10 +34,6 @@
+--- src/IIOP/giop-msg-buffer.c.orig Mon Mar 11 14:40:02 2002
++++ src/IIOP/giop-msg-buffer.c Tue Mar 12 16:43:03 2002
+@@ -34,7 +34,8 @@
#include "IIOP.h"
#include "IIOP-private.h"
--#ifdef HAVE_LIMITED_WRITEV
--#define writev g_writev
--#endif
--
- /* type defs */
+-#define MAX_LIMITED_IOVECS 16
++#define MAX_LIMITED_IOVECS MAXIOV
++#define HAVE_LIMITED_WRITEV
#ifdef __GNUC__
-@@ -197,7 +193,7 @@
- sum);
- }
- #endif
-- res = writev(fd, curvec, nvecs);
-+ res = g_writev(fd, curvec, nvecs);
-
- sum = (GIOP_MESSAGE_BUFFER(send_buffer)->message_header.message_size + sizeof(GIOPMessageHeader));
- if(res < sum) {
-@@ -227,7 +223,7 @@
-
- fcntl(fd, F_SETFL, fcntl(fd, F_GETFL, 0) & ~O_NONBLOCK);
-
-- t = writev(fd, curvec, nvecs);
-+ t = g_writev(fd, curvec, nvecs);
-
- fcntl(fd, F_SETFL, fcntl(fd, F_GETFL, 0) | O_NONBLOCK);
-
+ #define PACKED __attribute__((packed))
diff --git a/devel/ORBit/files/patch-src::ORBitutil::compat.c b/devel/ORBit/files/patch-src::ORBitutil::compat.c
deleted file mode 100644
index e907c22b66b9..000000000000
--- a/devel/ORBit/files/patch-src::ORBitutil::compat.c
+++ /dev/null
@@ -1,47 +0,0 @@
-
-$FreeBSD$
-
---- src/ORBitutil/compat.c.orig Wed Sep 9 07:08:14 1998
-+++ src/ORBitutil/compat.c Mon Oct 29 18:50:04 2001
-@@ -1,18 +1,34 @@
-+#include <errno.h>
-+#include <fcntl.h>
-+
- #include "config.h"
- #include "util.h"
-
--#define MAX_IOVS 16
--
- int g_writev(int fd, const struct iovec * vector, size_t count)
- {
-- int retval = 0;
-+ int fdflags, retval, wcur;
-+ int sum = 0;
-
-- while(count > MAX_IOVS) {
-- retval += writev(fd, vector, MAX_IOVS);
-- vector += MAX_IOVS; count -= MAX_IOVS;
-+ fdflags = fcntl(fd, F_GETFL);
-+ /* Get rid of the O_NONBLOCK - we don't need it here */
-+ fcntl(fd, F_SETFL, fdflags & ~O_NONBLOCK);
-+ for (wcur = MAXIOV; wcur == MAXIOV && count != 0; count -= MAXIOV) {
-+ if (wcur > count)
-+ wcur = count;
-+ do {
-+ retval = writev(fd, vector, wcur);
-+ } while (retval <= 0 && (errno == EAGAIN || errno == EINTR));
-+ if (retval < 0) {
-+ sum = retval;
-+ break;
-+ }
-+ vector += wcur;
-+ sum += retval;
- }
-
-- return writev(fd, vector, count) + retval;
-+ /* Restore flags */
-+ fcntl(fd, F_SETFD, fdflags);
-+ return sum;
- }
-
- #ifndef HAVE_INET_ATON