aboutsummaryrefslogtreecommitdiff
path: root/devel/argtable/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-20 17:23:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-20 17:23:45 +0000
commit39f9c7546f83091d0c4035d2f4cd0d4b4cdc6988 (patch)
treefcf9c03b08ac1d4573bd6d0af0b26e5ac39e8799 /devel/argtable/Makefile
parent19d9ddbc29f015ddec7d51c936bb3789ca327d54 (diff)
downloadports-39f9c7546f83091d0c4035d2f4cd0d4b4cdc6988.tar.gz
ports-39f9c7546f83091d0c4035d2f4cd0d4b4cdc6988.zip
Notes
Diffstat (limited to 'devel/argtable/Makefile')
-rw-r--r--devel/argtable/Makefile29
1 files changed, 22 insertions, 7 deletions
diff --git a/devel/argtable/Makefile b/devel/argtable/Makefile
index dd5ff0b974a9..b8d02a5a2595 100644
--- a/devel/argtable/Makefile
+++ b/devel/argtable/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= argtable
-PORTVERSION= 2.2
-PORTREVISION= 1
+PORTVERSION= 2.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,13 +15,29 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An ANSI C library for parsing GNU style command line arguments
+WRKSRC= ${WRKDIR}/${PORTNAME}2
+
USE_GETOPT_LONG= yes
-USE_GETTEXT= yes
-WRKSRC= ${WRKDIR}/argtable2
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN3= argtable2.3
-MAN3= argtable2.3
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/argtable2.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/src/libargtable2.a ${PREFIX}/lib
+ ${INSTALL_MAN} ${WRKSRC}/doc/argtable2.3 ${MANPREFIX}/man/man3
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in argtable2-intro.html argtable2-intro.pdf argtable2-intro.ps \
+ argtable2.html argtable2.pdf argtable2.ps
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in Makefile README.txt echo.c ls.c mv.c myprog.c myprog_C89.c \
+ rm.c uname.c
+ ${INSTALL_DATA} ${WRKSRC}/example/${file} ${EXAMPLESDIR}
+.endfor
+.endif
.include <bsd.port.mk>