aboutsummaryrefslogtreecommitdiff
path: root/devel/arm-none-eabi-gcc
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2019-10-23 17:44:28 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2019-10-23 17:44:28 +0000
commit42fe764b81c4c209933501771c0bb04db50de473 (patch)
tree5fb73f9c45056506eb16abe516b3b4b438200ea6 /devel/arm-none-eabi-gcc
parent1f6c77968fa6de2582d64b0a030055b84628ea85 (diff)
downloadports-42fe764b81c4c209933501771c0bb04db50de473.tar.gz
ports-42fe764b81c4c209933501771c0bb04db50de473.zip
Notes
Diffstat (limited to 'devel/arm-none-eabi-gcc')
-rw-r--r--devel/arm-none-eabi-gcc/Makefile15
1 files changed, 1 insertions, 14 deletions
diff --git a/devel/arm-none-eabi-gcc/Makefile b/devel/arm-none-eabi-gcc/Makefile
index 8b0e875ec20b..ff0a5642d6fc 100644
--- a/devel/arm-none-eabi-gcc/Makefile
+++ b/devel/arm-none-eabi-gcc/Makefile
@@ -1,26 +1,13 @@
# $FreeBSD$
PKGNAMEPREFIX= arm-none-eabi-
-COMMENT= GNU Compiler Collection for bare metal arm cross-development
GCC_TARGET= arm-none-eabi
PLIST= ${.CURDIR}/pkg-plist
-# U-Boot requires libgcc, crossbuild and install it along with the compiler.
-ALL_TARGET= all-gcc all-target-libgcc
-INSTALL_TARGET= install-gcc install-target-libgcc
-
# libstdcxx won't build, but we don't need it or multiple float-abi libs.
CONFIGURE_ARGS= --disable-libstdcxx \
--disable-multilib
-BROKEN_mips= configure: error: cannot compute suffix of object files: cannot compile
-BROKEN_mips64= configure: error: cannot compute suffix of object files: cannot compile
-
-MASTERDIR= ${.CURDIR}/../powerpc64-gcc
+MASTERDIR= ${.CURDIR}/../aarch64-none-elf-gcc
.include "${MASTERDIR}/Makefile"
-
-# The following is required for clang to bootstrap gcc.
-.if ${COMPILER_TYPE} == clang
-MAKE_ARGS+= CXXFLAGS=-fbracket-depth=512
-.endif