aboutsummaryrefslogtreecommitdiff
path: root/devel/astah-community
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2012-01-02 00:36:50 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2012-01-02 00:36:50 +0000
commit5d85b57059f0f6fc08c33a851b0d6ce211a98116 (patch)
tree4b683e23bb2dfecc785e061ec91a26ca995a71d8 /devel/astah-community
parent8f56a53e0fd513265b1d317c25883978c3e6809b (diff)
downloadports-5d85b57059f0f6fc08c33a851b0d6ce211a98116.tar.gz
ports-5d85b57059f0f6fc08c33a851b0d6ce211a98116.zip
Notes
Diffstat (limited to 'devel/astah-community')
-rw-r--r--devel/astah-community/Makefile25
-rw-r--r--devel/astah-community/distinfo4
-rw-r--r--devel/astah-community/files/patch-astah-command.sh16
3 files changed, 32 insertions, 13 deletions
diff --git a/devel/astah-community/Makefile b/devel/astah-community/Makefile
index 6cf99ebf464b..831111baa7dd 100644
--- a/devel/astah-community/Makefile
+++ b/devel/astah-community/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= astah
-PORTVERSION= 6.5
+PORTVERSION= 6.5.1
CATEGORIES= devel java
MASTER_SITES= #
PKGNAMESUFFIX= -community
@@ -38,19 +38,19 @@ IGNORE= needs you to fetch manually the distribution file\
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
-DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}${PKGNAMESUFFIX}
-PLIST_FILES= bin/astah
-.if !defined(NOPORTDATA)
+PLIST_FILES= bin/astah bin/astah-command.sh
PORTDATA= astah-community.jar astah-api.jar astah-gui_en.properties_org \
astah.ico astah-doc.ico Welcome.asta Welcome_ja.asta \
lib template
-.endif
.if !defined(NOPORTDOCS)
-PORTDOCS= ReleaseNote-e.html ReleaseNote.html \
- API_sample_program_license_agreement-e.txt \
+PORTDOCS= API_sample_program_license_agreement-e.txt \
API_sample_program_license_agreement.txt \
+ CommandRunner-e.html CommandRunner.html \
+ ProductInformation.txt \
+ ReleaseNote-e.html ReleaseNote.html \
api
.endif
@@ -59,18 +59,21 @@ PORTEXAMPLES= astah-key.properties_org Sample.asta
.endif
post-patch:
+.for script in ${PLIST_FILES:S!bin/!!}
${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!g; \
- s!%%DATADIR%%!${DATADIR}!" ${WRKSRC}/astah
+ s!%%DATADIR%%!${DATADIR}!" \
+ ${WRKSRC}/${script}
+.endfor
.if !defined(NOPORTDOCS)
${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/astahAPI_reference.html
.endif
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/astah ${PREFIX}/bin
-.if !defined(NOPORTDATA)
+.for script in ${PLIST_FILES:S!bin/!!}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+.endfor
${MKDIR} ${DATADIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${DATADIR})
-.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for docfile in ${PORTDOCS:Napi}
diff --git a/devel/astah-community/distinfo b/devel/astah-community/distinfo
index fe96c656c529..8d4b14fb2c8e 100644
--- a/devel/astah-community/distinfo
+++ b/devel/astah-community/distinfo
@@ -1,2 +1,2 @@
-SHA256 (astah-community-6_5.zip) = dd9c753747b7550d301197b0bb4e9b8c32defe0c4aa2b0b32bdb42152508dd75
-SIZE (astah-community-6_5.zip) = 19932727
+SHA256 (astah-community-6_5_1.zip) = 7d4f41c768e186a27e128716e838ad46180a9942658e9a3f9445bfe46cc1d75e
+SIZE (astah-community-6_5_1.zip) = 21299957
diff --git a/devel/astah-community/files/patch-astah-command.sh b/devel/astah-community/files/patch-astah-command.sh
new file mode 100644
index 000000000000..42d91c0ee875
--- /dev/null
+++ b/devel/astah-community/files/patch-astah-command.sh
@@ -0,0 +1,16 @@
+--- astah-command.sh.orig 2011-11-15 14:35:20.000000000 +0900
++++ astah-command.sh 2012-01-02 07:58:58.000000000 +0900
+@@ -22,11 +22,11 @@
+ #export PATH=$PATH:$JAVA_HOME/bin
+
+ #ASTAH_HOME=/usr/lib/astah_professional
+-ASTAH_HOME=`pwd`
++ASTAH_HOME=%%DATADIR%%
+
+ INITIAL_HEAP_SIZE=64m
+ MAXIMUM_HEAP_SIZE=1024m
+
+ JAVA_OPTS="-Xms$INITIAL_HEAP_SIZE -Xmx$MAXIMUM_HEAP_SIZE"
+
+-java $JAVA_OPTS -cp $ASTAH_HOME/astah-community.jar com.change_vision.jude.cmdline.JudeCommandRunner "$@"
++LD_LIBRARY_PATH=%%JAVA_HOME%%/jre/lib/i386/jli %%JAVA_HOME%%/bin/java $JAVA_OPTS -cp $ASTAH_HOME/astah-community.jar com.change_vision.jude.cmdline.JudeCommandRunner "$@"