aboutsummaryrefslogtreecommitdiff
path: root/devel/atlas/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-08 12:50:26 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-08 12:50:26 +0000
commit4994477e3470811485db323b6a0706879f1e0c67 (patch)
tree9e01debd50348540b39bb92abb966e13478c27ce /devel/atlas/Makefile
parenta97995aca7b8725f3005b083fa9394b58578e1f1 (diff)
Notes
Diffstat (limited to 'devel/atlas/Makefile')
-rw-r--r--devel/atlas/Makefile17
1 files changed, 15 insertions, 2 deletions
diff --git a/devel/atlas/Makefile b/devel/atlas/Makefile
index 8f3e8b144bda..45d75305b190 100644
--- a/devel/atlas/Makefile
+++ b/devel/atlas/Makefile
@@ -6,16 +6,29 @@
#
PORTNAME= Atlas
-PORTVERSION= 0.4.4
+PORTVERSION= 0.4.6
CATEGORIES= devel
MASTER_SITES= ftp://victor.worldforge.org/pub/worldforge/libs/Atlas-C++/ \
ftp://ftp.ecs.soton.ac.uk/pub/worldforge/libs/Atlas-C++/
DISTNAME= ${PORTNAME}-C++-${PORTVERSION}
-MAINTAINER= oliver@freebsd.org
+MAINTAINER= oliver@FreeBSD.org
COMMENT= A C++ reference implementation of the Atlas protocol
+USE_REINPLACE= YES
USE_LIBTOOL= YES
GNU_CONFIGURE= YES
+post-patch:
+ @${REINPLACE_CMD} -e 's| install-data-local||g' \
+ -e 's|\(^pkgconfigdir =\) .*|\1 ${PREFIX}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in README COPYING AUTHORS THANKS NEWS
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>