aboutsummaryrefslogtreecommitdiff
path: root/devel/bats-core
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2018-07-01 23:28:16 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2018-07-01 23:28:16 +0000
commitbfc0e045ba741d35904edd5ae587a746e92b81a8 (patch)
tree67f8788e41e35ee95134ab5f81ed60bba908a43a /devel/bats-core
parent5e8368d4cdca33c8dcb8faa37694700e2ba3f86b (diff)
downloadports-bfc0e045ba741d35904edd5ae587a746e92b81a8.tar.gz
ports-bfc0e045ba741d35904edd5ae587a746e92b81a8.zip
Notes
Diffstat (limited to 'devel/bats-core')
-rw-r--r--devel/bats-core/Makefile46
-rw-r--r--devel/bats-core/distinfo3
-rw-r--r--devel/bats-core/pkg-descr4
3 files changed, 53 insertions, 0 deletions
diff --git a/devel/bats-core/Makefile b/devel/bats-core/Makefile
new file mode 100644
index 000000000000..1da3ff2b2020
--- /dev/null
+++ b/devel/bats-core/Makefile
@@ -0,0 +1,46 @@
+# $FreeBSD$
+
+PORTNAME= bats-core
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.2
+CATEGORIES= devel
+
+MAINTAINER= lifanov@FreeBSD.org
+COMMENT= Bash automated testing system
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= bash:shells/bash
+
+USES= shebangfix
+SHEBANG_FILES= ${SCRIPTS:S/^/libexec\/${PORTNAME}\//}
+
+USE_GITHUB= yes
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+SCRIPTS= bats \
+ bats-exec-suite \
+ bats-exec-test \
+ bats-format-tap-stream \
+ bats-preprocess
+
+PLIST_FILES= ${SCRIPTS:S/^/libexec\/${PORTNAME}\//} \
+ bin/bats \
+ man/man1/bats.1.gz \
+ man/man7/bats.7.gz
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
+.for f in ${SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/libexec/${PORTNAME}/${f} \
+ ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/${f}
+.endfor
+ ${RLN} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}/bats \
+ ${STAGEDIR}${PREFIX}/bin/bats
+ ${INSTALL_MAN} ${WRKSRC}/man/bats.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/bats.7 ${STAGEDIR}${MAN7PREFIX}/man/man7
+
+.include <bsd.port.mk>
diff --git a/devel/bats-core/distinfo b/devel/bats-core/distinfo
new file mode 100644
index 000000000000..b6034e68c298
--- /dev/null
+++ b/devel/bats-core/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1530486850
+SHA256 (bats-core-bats-core-v1.0.2_GH0.tar.gz) = 4ad77fbf3c0be1f1221477a3df7af13884f33f56d9596ad7c6e37e2d9ae45ff0
+SIZE (bats-core-bats-core-v1.0.2_GH0.tar.gz) = 36002
diff --git a/devel/bats-core/pkg-descr b/devel/bats-core/pkg-descr
new file mode 100644
index 000000000000..d728ea76a293
--- /dev/null
+++ b/devel/bats-core/pkg-descr
@@ -0,0 +1,4 @@
+Bats is a TAP-compliant testing framework for Bash. It provides a simple
+way to verify that the UNIX programs you write behave as expected.
+
+WWW: https://github.com/sstephenson/bats