aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2020-11-04 14:21:43 +0000
committerDimitry Andric <dim@FreeBSD.org>2020-11-04 14:21:43 +0000
commit04a457063b6d1370c7ee63f3a23d70a9497f9b12 (patch)
treec168a5f95b0bf44599d4be2d84d56e64839e5cca /devel/binutils
parentd3da0f459c8bf1ef53415cc34325013047a3f01c (diff)
downloadports-04a457063b6d1370c7ee63f3a23d70a9497f9b12.tar.gz
ports-04a457063b6d1370c7ee63f3a23d70a9497f9b12.zip
devel/binutils: Apply upstream patch to fix "undefined symbol:
bswap_identity_64" and similar errors, when building devel/binutils in certain environments. This has been sitting in a bug for almost a year now without any action, which is why I am committing it now. MFH: 2020Q4 PR: 250783
Notes
Notes: svn path=/head/; revision=554081
Diffstat (limited to 'devel/binutils')
-rw-r--r--devel/binutils/Makefile2
-rw-r--r--devel/binutils/files/patch-libctf_swap.h34
2 files changed, 35 insertions, 1 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 1cf7831d749d..ef2bef012f98 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -3,7 +3,7 @@
PORTNAME= binutils
PORTVERSION= 2.33.1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH?= 1
CATEGORIES?= devel
MASTER_SITES= SOURCEWARE/binutils/releases
diff --git a/devel/binutils/files/patch-libctf_swap.h b/devel/binutils/files/patch-libctf_swap.h
new file mode 100644
index 000000000000..eefb60856c72
--- /dev/null
+++ b/devel/binutils/files/patch-libctf_swap.h
@@ -0,0 +1,34 @@
+--- libctf/swap.h.orig 2019-09-09 13:19:45 UTC
++++ libctf/swap.h
+@@ -28,13 +28,13 @@
+ #else
+
+ /* Provide our own versions of the byteswap functions. */
+-inline uint16_t
++static inline uint16_t
+ bswap_16 (uint16_t v)
+ {
+ return ((v >> 8) & 0xff) | ((v & 0xff) << 8);
+ }
+
+-inline uint32_t
++static inline uint32_t
+ bswap_32 (uint32_t v)
+ {
+ return ( ((v & 0xff000000) >> 24)
+@@ -43,13 +43,13 @@ bswap_32 (uint32_t v)
+ | ((v & 0x000000ff) << 24));
+ }
+
+-inline uint64_t
++static inline uint64_t
+ bswap_identity_64 (uint64_t v)
+ {
+ return v;
+ }
+
+-inline uint64_t
++static inline uint64_t
+ bswap_64 (uint64_t v)
+ {
+ return ( ((v & 0xff00000000000000ULL) >> 56)