aboutsummaryrefslogtreecommitdiff
path: root/devel/binutils
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-24 09:47:45 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-01-24 09:47:45 +0000
commit427208847c53b6995fa2642b44761edb86fc2fd3 (patch)
tree0ff1cbac27271fbd1d3db4b70a3801e3f5c5c324 /devel/binutils
parentbb86d7028dfd74c0b2f3dde647180a13b30b10f2 (diff)
downloadports-427208847c53b6995fa2642b44761edb86fc2fd3.tar.gz
ports-427208847c53b6995fa2642b44761edb86fc2fd3.zip
devel/binutils: fix build on powerpc and powerpc64 with gcc
The check with clang was unnecessary. Reported by: linimon Pointy hat: me
Notes
Notes: svn path=/head/; revision=523960
Diffstat (limited to 'devel/binutils')
-rw-r--r--devel/binutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index d355acc89d75..4b5dc5fa516c 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -108,7 +108,7 @@ MAKE_ARGS+= LIBDL=""
.include <bsd.port.pre.mk>
# Actual earliest version may differ slightly
-.if (${ARCH} != sparc64 && ${ARCH} != mips && ${ARCH} != mips64 && ${ARCH} != powerpcspe && !defined(PKGNAMEPREFIX)) || ((${ARCH} == powerpc || ${ARCH} == powerpc64) && ${CHOSEN_COMPILER_TYPE} == clang && !defined(PKGNAMEPREFIX))
+.if (${ARCH} != sparc64 && ${ARCH} != mips && ${ARCH} != mips64 && ${ARCH} != powerpcspe && ${ARCH} != powerpc && ${ARCH} != powerpc64 && !defined(PKGNAMEPREFIX)) || ((${ARCH} == powerpc || ${ARCH} == powerpc64) && ${CHOSEN_COMPILER_TYPE} != gcc && !defined(PKGNAMEPREFIX))
CONFIGURE_ARGS+= --enable-gold --enable-plugins
CXXFLAGS+= -Wno-c++11-narrowing
PLIST_SUB+= GOLD=""