aboutsummaryrefslogtreecommitdiff
path: root/devel/bison
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-28 16:26:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-28 16:26:57 +0000
commit6d5018c2dac2f16c7b132c2bd28653926b51735f (patch)
treee416c6d9a64391e0666807b9abc870ac04007c07 /devel/bison
parentf4c577e0fb4c741ea9706022b9ca7127a8398f90 (diff)
downloadports-6d5018c2dac2f16c7b132c2bd28653926b51735f.tar.gz
ports-6d5018c2dac2f16c7b132c2bd28653926b51735f.zip
Notes
Diffstat (limited to 'devel/bison')
-rw-r--r--devel/bison/Makefile22
-rw-r--r--devel/bison/pkg-plist19
2 files changed, 18 insertions, 23 deletions
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 29180a35c6c1..1d8b1855d0c2 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -17,28 +17,26 @@ COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-CONFLICTS= bison-[0-9]+
-.if !defined(WITHOUT_NLS)
-PLIST_SUB= NLS=""
-.else
-PLIST_SUB= NLS="@comment "
-.endif
+CONFLICTS= bison-[0-9]+
USE_BZIP2= yes
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
-.endif
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS= --disable-nls
-.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
MAKEINFO="makeinfo --no-split"
MAN1= bison.1
+INFO= bison
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
.ifdef USE_BISON
.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
diff --git a/devel/bison/pkg-plist b/devel/bison/pkg-plist
index 53c5d22a1325..f1d3f5a225f8 100644
--- a/devel/bison/pkg-plist
+++ b/devel/bison/pkg-plist
@@ -1,14 +1,11 @@
@comment $FreeBSD$
bin/bison
-@unexec install-info --delete %D/info/bison.info %D/info/dir
-info/bison.info
-@exec install-info %D/info/bison.info %D/info/dir
-share/bison/c.m4
-share/bison/glr.c
-share/bison/lalr1.cc
-share/bison/m4sugar/m4sugar.m4
-share/bison/m4sugar/version.m4
-share/bison/yacc.c
+%%DATADIR%%/c.m4
+%%DATADIR%%/glr.c
+%%DATADIR%%/lalr1.cc
+%%DATADIR%%/m4sugar/m4sugar.m4
+%%DATADIR%%/m4sugar/version.m4
+%%DATADIR%%/yacc.c
%%NLS%%share/locale/de/LC_MESSAGES/bison.mo
%%NLS%%share/locale/es/LC_MESSAGES/bison.mo
%%NLS%%share/locale/et/LC_MESSAGES/bison.mo
@@ -22,5 +19,5 @@ share/bison/yacc.c
%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
%%NLS%%share/locale/tr/LC_MESSAGES/bison.mo
-@dirrm share/bison/m4sugar
-@dirrm share/bison
+@dirrm %%DATADIR%%/m4sugar
+@dirrm %%DATADIR%%