aboutsummaryrefslogtreecommitdiff
path: root/devel/blitz/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-24 19:02:50 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-24 19:02:50 +0000
commitabdbad66be33e2b41894fc92b69a0d892fca1c7c (patch)
tree8bd88ad1fcecbd0d26206b4128ae14d906e211e9 /devel/blitz/Makefile
parent742ed9faab3a201a077c7afe0a1604614a869513 (diff)
Notes
Diffstat (limited to 'devel/blitz/Makefile')
-rw-r--r--devel/blitz/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/devel/blitz/Makefile b/devel/blitz/Makefile
new file mode 100644
index 000000000000..73e9a8fd62fc
--- /dev/null
+++ b/devel/blitz/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= blitz
+DISTVERSION= 1.0.1
+CATEGORIES= devel science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Blitz++ Multi-Dimensional Array Library for C++
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake libtool localbase python:build
+USE_GITHUB= yes
+GH_ACCOUNT= blitzpp
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+TEST_TARGET= check-testsuite
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS= --enable-shared
+MAKE_ARGS= CXXFLAGS="${CXXFLAGS}" FREEBSD_PYTHON_CMD=${PYTHON_CMD}
+
+OPTIONS_DEFINE= APAD FORTRAN SERIALIZATION TBB THREADSAFE
+APAD_DESC= Pad all lowest-rank lengths to nearest larger SIMD width
+SERIALIZATION_DESC= Enable serialization support using Boost::Serialization
+TBB_DESC= Use Intel Threading Building Blocks atomic types
+THREADSAFE_DESC= Enable thread-safety features
+
+APAD_CONFIGURE_ENABLE= array-length-padding
+FORTRAN_CONFIGURE_ENABLE= fortran
+FORTRAN_USES= fortran
+SERIALIZATION_CONFIGURE_ENABLE= serialization
+SERIALIZATION_BUILD_DEPENDS= ${LOCALBASE}/include/boost/mpi.hpp:devel/boost-libs
+TBB_CONFIGURE_ON= --with-tbb # TBB_CONFIGURE_WITH=tbb doesn't work: https://github.com/blitzpp/blitz/issues/20
+TBB_BUILD_DEPENDS= ${LOCALBASE}/include/tbb/atomic.h:devel/tbb
+THREADSAFE_CONFIGURE_ENABLE= threadsafe
+
+post-install:
+ @${RM} -r ${STAGEDIR}${DOCSDIR}* # https://github.com/blitzpp/blitz/issues/21
+
+.include <bsd.port.mk>