aboutsummaryrefslogtreecommitdiff
path: root/devel/boost-python-libs
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:33:04 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:33:04 +0000
commit3f6692467b46056d3a9c7fe9bc78c439f0274b0b (patch)
tree7134ace5e6a89215f59520c4db5ef4ec5cdd4162 /devel/boost-python-libs
parentf5646e4a1ca307e327df3a308bd22d48f9673cc4 (diff)
downloadports-3f6692467b46056d3a9c7fe9bc78c439f0274b0b.tar.gz
ports-3f6692467b46056d3a9c7fe9bc78c439f0274b0b.zip
- update to 1.52.0
- pass maintainership to office@ - detect if compiler is gcc or clang and correctly set the toolset for bjam - enable long-double support - some cleanup Approved by: maintainer timeout (3 weeks with no reply)
Notes
Notes: svn path=/head/; revision=311308
Diffstat (limited to 'devel/boost-python-libs')
-rw-r--r--devel/boost-python-libs/Makefile61
-rw-r--r--devel/boost-python-libs/distinfo4
-rw-r--r--devel/boost-python-libs/files/patch-boostcpp.jam11
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_engine_build.jam11
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam17
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam47
-rw-r--r--devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam11
-rw-r--r--devel/boost-python-libs/pkg-plist218
8 files changed, 16 insertions, 364 deletions
diff --git a/devel/boost-python-libs/Makefile b/devel/boost-python-libs/Makefile
index ab32735afab1..b951369a7ac3 100644
--- a/devel/boost-python-libs/Makefile
+++ b/devel/boost-python-libs/Makefile
@@ -1,22 +1,17 @@
-# Ports collection makefile for: boost-python-libs
-# Date Created: 18 March 2009
-# Whom: Alexander Churanov <churanov.port.maintainer@gmail.com>
-#
+# Created by: Alexander Churanov <churanov.port.maintainer@gmail.com>
# $FreeBSD$
-#
PORTNAME= boost-python-libs
COMMENT= Framework for interfacing Python and C++
-USE_BZIP2= yes
USE_PYTHON= yes
-OPTIONS= VERBOSE_BUILD "Show compiler messages" off \
- DEBUG "Build debugging symbols" off \
- OPTIMIZED_CFLAGS "Enable -O3 optimization" off
+OPTIONS_DEFINE= VERBOSE_BUILD DEBUG OPTIMIZED_CFLAGS
+VERBOSE_BUILD_DESC= Show compiler messages
+
+.include "${.CURDIR}/../boost-all/common.mk"
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/boost-all/common.mk"
.include "${PORTSDIR}/devel/boost-all/compiled.mk"
.if ${ARCH} == "sparc64"
@@ -32,41 +27,18 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libboost_thread.so.${BOOST_SHARED_LIB_VER}:${PORT
BUILD_DEPENDS+= ${BJAM}:${PORTSDIR}/devel/boost-jam
-post-patch: customize-boost-build
-
do-build:
- ${ECHO_CMD} "using python : " ${PYTHON_VER} " : " ${PYTHON_CMD} " : " ${PYTHON_INCLUDEDIR} ";" >> ${WRKSRC}/tools/build/v2/site-config.jam
+ @${ECHO_CMD} "using python : " ${PYTHON_VER} " : " ${PYTHON_CMD} " : " ${PYTHON_INCLUDEDIR} ";" >> ${WRKSRC}/tools/build/v2/site-config.jam
# build the library
- cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_OPTIONS} --prefix=${PREFIX}\
- --toolset=${BOOST_TOOLS} --with-python
-
-# Remove non-python headers
- cd ${WRKSRC} && \
- ${FIND} boost -not -path '*boost/python*' -delete
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${BJAM} ${BJAM_ARGS} --with-python stage
+ @cd ${WRKSRC}/stage/lib && \
+ ( for l in lib*.so.*; do ${LN} -sf $${l} $${l%.*}; done )
do-install:
-# Install libraries
- ${FIND} ${WRKSRC}/bin.v2/libs/python -type f -name "*.a"\
- -exec ${INSTALL_DATA} \{\} ${PREFIX}/lib \;
-
- ${FIND} -E ${WRKSRC}/bin.v2/libs/python -type f \
- -regex '.*so' \
- -exec ${INSTALL_DATA} \{\} ${PREFIX}/lib \;
-
-# Create symlink for shared library
- cd ${PREFIX}/lib/ && \
- ${MV} "libboost_python.so" "libboost_python.so.${BOOST_SHARED_LIB_VER}" && \
- ${LN} -fs "libboost_python.so.${BOOST_SHARED_LIB_VER}" "libboost_python.so"
-
-# Install headers
- cd ${WRKSRC} && \
- ${FIND} boost -type d -a \! -name "*.orig"\
- -exec ${MKDIR} ${PREFIX}/include/\{\} \;
-
- cd ${WRKSRC} && \
- ${FIND} boost -type f -a \! -name "*.orig"\
- -exec ${INSTALL_DATA} \{\} ${PREFIX}/include/\{\} \;
+ @cd ${WRKSRC}/stage/lib && ${PAX} -rw -p p libboost* ${PREFIX}/lib
+# For some reasons BJAM forget about the links
+ @cd ${WRKSRC}/stage/ && ${FIND} lib -type l | ${PAX} -rw -p p ${PREFIX}
post-install:
# display pkg-message
@@ -82,12 +54,7 @@ post-install:
-e "s|%%PYTHON_LIBDIR%%|${PYTHON_LIBDIR}|g" \
-e "s|%%PYTHON_VERSION%%|${PYTHON_VERSION}|g" ${PKGMESSAGE}
@if [ -s ${PKGMESSAGE} ]; then \
- ${ECHO_CMD} ; \
- ${ECHO_CMD} "===============================================================================" ; \
- ${ECHO_CMD} ; \
- ${CAT} ${PKGMESSAGE}; \
- ${ECHO_CMD} "===============================================================================" ; \
- ${ECHO_CMD} ; \
+ ${CAT} ${PKGMESSAGE}; \
fi
.include <bsd.port.post.mk>
diff --git a/devel/boost-python-libs/distinfo b/devel/boost-python-libs/distinfo
index e192fd2476cc..488de463621f 100644
--- a/devel/boost-python-libs/distinfo
+++ b/devel/boost-python-libs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (boost_1_48_0.tar.bz2) = 1bf254b2d69393ccd57a3cdd30a2f80318a005de8883a0792ed2f5e2598e5ada
-SIZE (boost_1_48_0.tar.bz2) = 48236989
+SHA256 (boost_1_52_0.tar.bz2) = 222b6afd7723f396f5682c20130314a10196d3999feab5ba920d2a6bf53bac92
+SIZE (boost_1_52_0.tar.bz2) = 54421709
diff --git a/devel/boost-python-libs/files/patch-boostcpp.jam b/devel/boost-python-libs/files/patch-boostcpp.jam
deleted file mode 100644
index ec350a5736b5..000000000000
--- a/devel/boost-python-libs/files/patch-boostcpp.jam
+++ /dev/null
@@ -1,11 +0,0 @@
---- boostcpp.jam.orig 2011-12-15 18:33:48.000000000 +0300
-+++ boostcpp.jam 2011-12-15 18:34:05.000000000 +0300
-@@ -154,7 +154,7 @@
- # suffixes either. Pgi compilers can not accept library with version
- # suffix.
- if $(type) = SHARED_LIB &&
-- ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix ) &&
-+ ( ! ( [ $(property-set).get <target-os> ] in windows cygwin darwin aix freebsd ) &&
- ! ( [ $(property-set).get <toolset> ] in pgi ) )
- {
- result = $(result).$(BOOST_VERSION) ;
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_engine_build.jam b/devel/boost-python-libs/files/patch-tools_build_v2_engine_build.jam
deleted file mode 100644
index 6ad52f6cc549..000000000000
--- a/devel/boost-python-libs/files/patch-tools_build_v2_engine_build.jam
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/build/v2/engine/build.jam.orig Tue Jul 29 15:43:31 2008
-+++ tools/build/v2/engine/build.jam Tue Nov 11 23:52:09 2008
-@@ -176,7 +176,7 @@
- ## GCC 2.x, 3.x, 4.x
- toolset gcc gcc : "-o " : -D
- : -pedantic -fno-strict-aliasing
-- [ opt --release : [ opt --symbols : -g : -s ] -O3 ]
-+ [ opt --release : [ opt --symbols : -g : -s ] -O3 -fno-strict-aliasing ]
- [ opt --debug : -g -O0 -fno-inline ]
- -I$(--python-include) -I$(--extra-include) -Wno-long-long
- : -L$(--python-lib[1]) -l$(--python-lib[2]) ;
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam b/devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam
deleted file mode 100644
index cc306b204292..000000000000
--- a/devel/boost-python-libs/files/patch-tools_build_v2_tools_common.jam
+++ /dev/null
@@ -1,17 +0,0 @@
---- tools/build/v2/tools/common.jam.orig 2009-09-23 16:39:31.000000000 +0400
-+++ tools/build/v2/tools/common.jam 2009-09-23 16:39:33.000000000 +0400
-@@ -765,14 +765,6 @@
- result += [ join-tag $(f:G=) : [ toolset-tag $(name) : $(type) :
- $(property-set) ] ] ;
-
-- case <threading> :
-- result += [ join-tag $(f:G=) : [ threading-tag $(name) : $(type)
-- : $(property-set) ] ] ;
--
-- case <runtime> :
-- result += [ join-tag $(f:G=) : [ runtime-tag $(name) : $(type) :
-- $(property-set) ] ] ;
--
- case <qt> :
- result += [ join-tag $(f:G=) : [ qt-tag $(name) : $(type) :
- $(property-set) ] ] ;
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam b/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam
deleted file mode 100644
index 3113b8ffac55..000000000000
--- a/devel/boost-python-libs/files/patch-tools_build_v2_tools_gcc.jam
+++ /dev/null
@@ -1,47 +0,0 @@
---- tools/build/v2/tools/gcc.jam.orig 2011-06-07 00:36:21.000000000 +0400
-+++ tools/build/v2/tools/gcc.jam 2011-12-15 18:01:36.000000000 +0300
-@@ -70,7 +70,7 @@
- local tool-command = ;
- if $(command)
- {
-- tool-command = [ common.get-invocation-command-nodefault gcc : g++ : $(command) ] ;
-+ tool-command = [ common.get-invocation-command-nodefault gcc : %%CXX%% : $(command) ] ;
- if ! $(tool-command)
- {
- errors.error "toolset gcc initialization:" :
-@@ -86,7 +86,7 @@
- #2.1) fallback: check whether "g++" reports the requested version
- if ! $(tool-command)
- {
-- tool-command = [ common.get-invocation-command-nodefault gcc : g++ ] ;
-+ tool-command = [ common.get-invocation-command-nodefault gcc : %%CXX%% ] ;
- if $(tool-command)
- {
- local tool-command-string = $(tool-command:J=" ") ;
-@@ -122,7 +122,7 @@
- #3) default: no command and no version specified, try using default command "g++"
- else
- {
-- tool-command = [ common.get-invocation-command-nodefault gcc : g++ ] ;
-+ tool-command = [ common.get-invocation-command-nodefault gcc : %%CXX%% ] ;
- if ! $(tool-command)
- {
- errors.error "toolset gcc initialization:" :
-@@ -365,7 +365,7 @@
-
- # Declare flags and action for compilation.
- toolset.flags gcc.compile OPTIONS <optimization>off : -O0 ;
--toolset.flags gcc.compile OPTIONS <optimization>speed : -O3 ;
-+toolset.flags gcc.compile OPTIONS <optimization>speed : %%CXXFLAGS%% ;
- toolset.flags gcc.compile OPTIONS <optimization>space : -Os ;
-
- toolset.flags gcc.compile OPTIONS <inlining>off : -fno-inline ;
-@@ -1049,7 +1049,7 @@
- }
- case *bsd :
- {
-- option = -pthread ;
-+ option = %%PTHREAD_LIBS%% %%PTHREAD_CFLAGS%% ;
- # There is no -lrt on BSD.
- }
- case sgi :
diff --git a/devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam b/devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam
deleted file mode 100644
index bf2212b3d520..000000000000
--- a/devel/boost-python-libs/files/patch-tools_build_v2_tools_python.jam
+++ /dev/null
@@ -1,11 +0,0 @@
---- tools/build/v2/tools/python.jam.orig Thu Oct 16 12:42:03 2008
-+++ tools/build/v2/tools/python.jam Tue Nov 11 23:50:21 2008
-@@ -650,7 +650,7 @@
- case windows : return ;
-
- case hpux : return <library>rt ;
-- case *bsd : return <library>pthread <toolset>gcc:<library>util ;
-+ case *bsd : return <library>%%PTHREAD_LIBS%% <toolset>gcc:<library>util ;
-
- case aix : return <library>pthread <library>dl ;
-
diff --git a/devel/boost-python-libs/pkg-plist b/devel/boost-python-libs/pkg-plist
index b687cf942b50..a61020bfa8b5 100644
--- a/devel/boost-python-libs/pkg-plist
+++ b/devel/boost-python-libs/pkg-plist
@@ -1,221 +1,3 @@
-include/boost/python.hpp
-include/boost/python/arg_from_python.hpp
-include/boost/python/args.hpp
-include/boost/python/args_fwd.hpp
-include/boost/python/back_reference.hpp
-include/boost/python/base_type_traits.hpp
-include/boost/python/bases.hpp
-include/boost/python/borrowed.hpp
-include/boost/python/call.hpp
-include/boost/python/call_method.hpp
-include/boost/python/cast.hpp
-include/boost/python/class.hpp
-include/boost/python/class_fwd.hpp
-include/boost/python/converter/arg_from_python.hpp
-include/boost/python/converter/arg_to_python.hpp
-include/boost/python/converter/arg_to_python_base.hpp
-include/boost/python/converter/as_to_python_function.hpp
-include/boost/python/converter/builtin_converters.hpp
-include/boost/python/converter/constructor_function.hpp
-include/boost/python/converter/context_result_converter.hpp
-include/boost/python/converter/convertible_function.hpp
-include/boost/python/converter/from_python.hpp
-include/boost/python/converter/implicit.hpp
-include/boost/python/converter/obj_mgr_arg_from_python.hpp
-include/boost/python/converter/object_manager.hpp
-include/boost/python/converter/pointer_type_id.hpp
-include/boost/python/converter/pyobject_traits.hpp
-include/boost/python/converter/pyobject_type.hpp
-include/boost/python/converter/pytype_function.hpp
-include/boost/python/converter/pytype_object_mgr_traits.hpp
-include/boost/python/converter/registered.hpp
-include/boost/python/converter/registered_pointee.hpp
-include/boost/python/converter/registrations.hpp
-include/boost/python/converter/registry.hpp
-include/boost/python/converter/return_from_python.hpp
-include/boost/python/converter/rvalue_from_python_data.hpp
-include/boost/python/converter/shared_ptr_deleter.hpp
-include/boost/python/converter/shared_ptr_from_python.hpp
-include/boost/python/converter/shared_ptr_to_python.hpp
-include/boost/python/converter/to_python_function_type.hpp
-include/boost/python/copy_const_reference.hpp
-include/boost/python/copy_non_const_reference.hpp
-include/boost/python/data_members.hpp
-include/boost/python/def.hpp
-include/boost/python/def_visitor.hpp
-include/boost/python/default_call_policies.hpp
-include/boost/python/detail/aix_init_module.hpp
-include/boost/python/detail/api_placeholder.hpp
-include/boost/python/detail/borrowed_ptr.hpp
-include/boost/python/detail/caller.hpp
-include/boost/python/detail/config.hpp
-include/boost/python/detail/construct.hpp
-include/boost/python/detail/convertible.hpp
-include/boost/python/detail/copy_ctor_mutates_rhs.hpp
-include/boost/python/detail/cv_category.hpp
-include/boost/python/detail/dealloc.hpp
-include/boost/python/detail/decorated_type_id.hpp
-include/boost/python/detail/decref_guard.hpp
-include/boost/python/detail/def_helper.hpp
-include/boost/python/detail/def_helper_fwd.hpp
-include/boost/python/detail/defaults_def.hpp
-include/boost/python/detail/defaults_gen.hpp
-include/boost/python/detail/dependent.hpp
-include/boost/python/detail/destroy.hpp
-include/boost/python/detail/enable_if.hpp
-include/boost/python/detail/exception_handler.hpp
-include/boost/python/detail/force_instantiate.hpp
-include/boost/python/detail/if_else.hpp
-include/boost/python/detail/indirect_traits.hpp
-include/boost/python/detail/invoke.hpp
-include/boost/python/detail/is_auto_ptr.hpp
-include/boost/python/detail/is_shared_ptr.hpp
-include/boost/python/detail/is_wrapper.hpp
-include/boost/python/detail/is_xxx.hpp
-include/boost/python/detail/make_keyword_range_fn.hpp
-include/boost/python/detail/make_tuple.hpp
-include/boost/python/detail/map_entry.hpp
-include/boost/python/detail/mpl_lambda.hpp
-include/boost/python/detail/msvc_typeinfo.hpp
-include/boost/python/detail/none.hpp
-include/boost/python/detail/not_specified.hpp
-include/boost/python/detail/nullary_function_adaptor.hpp
-include/boost/python/detail/operator_id.hpp
-include/boost/python/detail/overloads_fwd.hpp
-include/boost/python/detail/pointee.hpp
-include/boost/python/detail/prefix.hpp
-include/boost/python/detail/preprocessor.hpp
-include/boost/python/detail/python22_fixed.h
-include/boost/python/detail/python_type.hpp
-include/boost/python/detail/raw_pyobject.hpp
-include/boost/python/detail/referent_storage.hpp
-include/boost/python/detail/result.hpp
-include/boost/python/detail/scope.hpp
-include/boost/python/detail/sfinae.hpp
-include/boost/python/detail/signature.hpp
-include/boost/python/detail/string_literal.hpp
-include/boost/python/detail/target.hpp
-include/boost/python/detail/translate_exception.hpp
-include/boost/python/detail/type_list.hpp
-include/boost/python/detail/type_list_impl.hpp
-include/boost/python/detail/type_list_impl_no_pts.hpp
-include/boost/python/detail/unwind_type.hpp
-include/boost/python/detail/unwrap_type_id.hpp
-include/boost/python/detail/unwrap_wrapper.hpp
-include/boost/python/detail/value_arg.hpp
-include/boost/python/detail/value_is_shared_ptr.hpp
-include/boost/python/detail/value_is_xxx.hpp
-include/boost/python/detail/void_ptr.hpp
-include/boost/python/detail/void_return.hpp
-include/boost/python/detail/wrap_python.hpp
-include/boost/python/detail/wrapper_base.hpp
-include/boost/python/dict.hpp
-include/boost/python/docstring_options.hpp
-include/boost/python/enum.hpp
-include/boost/python/errors.hpp
-include/boost/python/exception_translator.hpp
-include/boost/python/exec.hpp
-include/boost/python/extract.hpp
-include/boost/python/handle.hpp
-include/boost/python/handle_fwd.hpp
-include/boost/python/has_back_reference.hpp
-include/boost/python/implicit.hpp
-include/boost/python/import.hpp
-include/boost/python/init.hpp
-include/boost/python/instance_holder.hpp
-include/boost/python/iterator.hpp
-include/boost/python/list.hpp
-include/boost/python/long.hpp
-include/boost/python/lvalue_from_pytype.hpp
-include/boost/python/make_constructor.hpp
-include/boost/python/make_function.hpp
-include/boost/python/manage_new_object.hpp
-include/boost/python/module.hpp
-include/boost/python/module_init.hpp
-include/boost/python/numeric.hpp
-include/boost/python/object.hpp
-include/boost/python/object/add_to_namespace.hpp
-include/boost/python/object/class.hpp
-include/boost/python/object/class_detail.hpp
-include/boost/python/object/class_metadata.hpp
-include/boost/python/object/class_wrapper.hpp
-include/boost/python/object/enum_base.hpp
-include/boost/python/object/find_instance.hpp
-include/boost/python/object/forward.hpp
-include/boost/python/object/function.hpp
-include/boost/python/object/function_doc_signature.hpp
-include/boost/python/object/function_handle.hpp
-include/boost/python/object/function_object.hpp
-include/boost/python/object/inheritance.hpp
-include/boost/python/object/inheritance_query.hpp
-include/boost/python/object/instance.hpp
-include/boost/python/object/iterator.hpp
-include/boost/python/object/iterator_core.hpp
-include/boost/python/object/life_support.hpp
-include/boost/python/object/make_holder.hpp
-include/boost/python/object/make_instance.hpp
-include/boost/python/object/make_ptr_instance.hpp
-include/boost/python/object/pickle_support.hpp
-include/boost/python/object/pointer_holder.hpp
-include/boost/python/object/py_function.hpp
-include/boost/python/object/stl_iterator_core.hpp
-include/boost/python/object/value_holder.hpp
-include/boost/python/object/value_holder_fwd.hpp
-include/boost/python/object_attributes.hpp
-include/boost/python/object_call.hpp
-include/boost/python/object_core.hpp
-include/boost/python/object_fwd.hpp
-include/boost/python/object_items.hpp
-include/boost/python/object_operators.hpp
-include/boost/python/object_protocol.hpp
-include/boost/python/object_protocol_core.hpp
-include/boost/python/object_slices.hpp
-include/boost/python/opaque_pointer_converter.hpp
-include/boost/python/operators.hpp
-include/boost/python/other.hpp
-include/boost/python/overloads.hpp
-include/boost/python/override.hpp
-include/boost/python/pointee.hpp
-include/boost/python/proxy.hpp
-include/boost/python/ptr.hpp
-include/boost/python/pure_virtual.hpp
-include/boost/python/raw_function.hpp
-include/boost/python/refcount.hpp
-include/boost/python/reference_existing_object.hpp
-include/boost/python/register_ptr_to_python.hpp
-include/boost/python/return_arg.hpp
-include/boost/python/return_by_value.hpp
-include/boost/python/return_internal_reference.hpp
-include/boost/python/return_opaque_pointer.hpp
-include/boost/python/return_value_policy.hpp
-include/boost/python/scope.hpp
-include/boost/python/self.hpp
-include/boost/python/signature.hpp
-include/boost/python/slice.hpp
-include/boost/python/slice_nil.hpp
-include/boost/python/ssize_t.hpp
-include/boost/python/stl_iterator.hpp
-include/boost/python/str.hpp
-include/boost/python/suite/indexing/container_utils.hpp
-include/boost/python/suite/indexing/detail/indexing_suite_detail.hpp
-include/boost/python/suite/indexing/indexing_suite.hpp
-include/boost/python/suite/indexing/map_indexing_suite.hpp
-include/boost/python/suite/indexing/vector_indexing_suite.hpp
-include/boost/python/tag.hpp
-include/boost/python/to_python_converter.hpp
-include/boost/python/to_python_indirect.hpp
-include/boost/python/to_python_value.hpp
-include/boost/python/tuple.hpp
-include/boost/python/type_id.hpp
-include/boost/python/with_custodian_and_ward.hpp
-include/boost/python/wrapper.hpp
lib/libboost_python.a
lib/libboost_python.so
lib/libboost_python.so.%%BOOST_SHARED_LIB_VER%%
-@dirrm include/boost/python/suite/indexing/detail
-@dirrm include/boost/python/suite/indexing
-@dirrm include/boost/python/suite
-@dirrm include/boost/python/object
-@dirrm include/boost/python/detail
-@dirrm include/boost/python/converter
-@dirrm include/boost/python